Recibe un "no se puede instalar este hardware" o "Error durante la instalación" mensaje de error cuando intenta instalar un dispositivo PCI

Ha finalizado el soporte técnico para Windows XP

Microsoft puso fin al soporte técnico para Windows XP el 8 de abril de 2014. Este cambio ha afectado a las actualizaciones de software y las opciones de seguridad. Sepa qué significa esto en su caso y cómo puede mantenerse protegido.

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Síntomas
Cuando intenta instalar un nuevo dispositivo de interconexión de componentes periféricos (PCI, Peripheral Component Interconnect) o un controlador de dispositivo PCI, puede recibir uno de los siguientes mensajes de error:
No se puede instalar este hardware. Se ha producido un problema al instalar este hardware.
Se ha producido un error durante la instalación del dispositivo. Los datos son inválidos.
Por ejemplo, puede recibir uno de estos mensajes de error si intenta instalar un módem PCI o un controlador de módem PCI.
Causa
Este problema puede producirse cuando se cumple una de las siguientes condiciones:
  • Una subclave del registro no tiene los permisos predeterminados de establece correctamente. Los permisos predeterminados se ha cambiado.
  • El programa de instalación para el dispositivo requiere permisos adicionales que son más estrictos que los permisos predeterminados.
Nota: La lista siguiente contiene los permisos predeterminados correspondientes para las subclaves del registro:
  • Todos: lectura
  • Sistema: Control total
Solución
Importante: esta sección, el método o la tarea contiene pasos que indican cómo modificar el registro. Sin embargo, pueden producirse problemas graves si modifica incorrectamente el registro. Por lo tanto, asegúrese de que sigue estos pasos cuidadosamente. Para una mayor protección, haga una copia de seguridad del registro antes de modificarlo. Entonces, puede restaurar el registro si se produce un problema. Para obtener más información acerca de cómo hacer copia de seguridad y restaurar el registro, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
322756 Cómo hacer copia de seguridad y restaurar el registro de Windows

Método 1: Restaurar la configuración predeterminada para la subclave del registro para el dispositivo

Si puede determinar qué subclave está relacionada con este problema, modifique el registro para configurar la configuración correcta en esa subclave. Para obtener información acerca de cómo solucionar este problema y determinar qué subclave se ve afectado por este problema, consulte la sección "Más información". Para configurar la configuración correcta en una subclave específica:
  1. Inicie sesión en el equipo con una cuenta que tenga credenciales administrativas.
  2. Haga clic en Inicio, haga clic en Ejecutar, tipo Regedit en el cuadro Abrir y a continuación, haga clic en Aceptar.
  3. Busque la siguiente clave del registro:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\ENUM\PCI
  4. Haga clic en la subclave que se relaciona con el dispositivo que está experimentando los síntomas y, a continuación, haga clic en permisos.
  5. Haga clic en Avanzadasy, a continuación, haga clic en la ficha permisos .
  6. Asegúrese de que están configurados los siguientes permisos predeterminados:
    • Todo el mundo: Lectura
    • Sistema: Control total
  7. Haga clic para activar la casilla de verificación reemplazar las entradas de permisos en todos los objetos secundarios con aquellas entradas incluidas aquí y que sean relativas a los objetos secundarios y, a continuación, haga clic en Aplicar.
  8. Haga clic en y, a continuación, haga clic en Aceptar dos veces.
  9. Salga del Editor del registro.
  10. Si el problema no se resuelve, repita este procedimiento y conceda control total a todos los permisos de grupo en esta subclave.

Método 2: Restaurar los permisos predeterminados para la clave PCI y sus subclaves

  1. Inicie sesión en el equipo con una cuenta que tenga credenciales administrativas.
  2. Haga clic en Inicio, haga clic en Ejecutar, tipo Regedit en el cuadro Abrir y a continuación, haga clic en Aceptar.
  3. Busque la siguiente clave del registro:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\ENUM\
  4. Haga clic en PCIy, a continuación, haga clic en permisos.
  5. Asegúrese de que están configurados los siguientes permisos predeterminados:
    • Todo el mundo: Lectura
    • Sistema: Control total
  6. Haga clic en Opciones avanzadas, haga clic para activar la casilla de verificación reemplazar las entradas de permisos en todos los objetos secundarios con aquellas entradas incluidas aquí y que sean relativas a los objetos secundarios y, a continuación, haga clic en Aplicar.
  7. Haga clic en y, a continuación, haga clic en Aceptar dos veces.
  8. Salga del Editor del registro.
Más información
Para la solución avanzada de problemas, configure el archivo Setupapi.log para utilizar el registro detallado y, a continuación, intente instalar al controlador de dispositivo.

Nota: El registro detallado aumenta el tamaño del archivo Setupapi.log. Recomendamos que sólo utilice el registro detallado y solucionar problemas. Cuando haya terminado, elimine el valor de nivel de registro para desactivar el registro detallado.

El registro puede registrar exactamente qué subclave del registro se relaciona con el síntoma que se describe en este artículo. Para configurar el registro detallado:
  1. Inicie sesión en el equipo con una cuenta que tenga credenciales administrativas.
  2. Haga clic en Inicio, haga clic en Ejecutar, tipo Regedit en el cuadro Abrir y a continuación, haga clic en Aceptar.
  3. Busque la siguiente clave del registro:
    HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Setup
  4. Haga clic en instalar, seleccione nuevoy, a continuación, haga clic en valor DWORD.
  5. Escriba el LogLevelnombre al nuevo valor y, a continuación, presione ENTRAR.
  6. Haga clic en el valor de nivel de registro que acaba de crear, haga clic en Modificar, tipo 0xFFFF en los datos del valor y a continuación, haga clic en Aceptar.
  7. Cambie el nombre existente en el archivo Setupapi.log Setupapi.old.

Advertencia: este artículo se tradujo automáticamente

Propiedades

Id. de artículo: 841567 - Última revisión: 12/08/2015 07:10:06 - Revisión: 2.0

Microsoft Windows XP Professional

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