Algunos hotfix anteriores al Service Pack 1 (SP1) no se migran a la versión SP1 cuando actualiza el equipo al SP1 de Windows XP

Ha finalizado el soporte técnico para Windows XP

Microsoft puso fin al soporte técnico para Windows XP el 8 de abril de 2014. Este cambio ha afectado a las actualizaciones de software y las opciones de seguridad. Sepa qué significa esto en su caso y cómo puede mantenerse protegido.

Este artículo se ha archivado. Se ofrece "tal cual" y no se volverá a actualizar.
Síntomas
Cuando actualiza un equipo basado en Microsoft Windows XP al Service Pack 1 (SP1) de Windows XP, algunas revisiones (o hotfix) anteriores al Service Pack 1 que estaban instaladas en el equipo no se pueden migrar correctamente de la versión comercial de Windows XP al Service Pack 1 de Windows XP.

Notas
  • Cuando instala un hotfix anterior al Service Pack 1 de Windows XP en un equipo basado en Windows XP, también se copia en el equipo una versión de dicho hotfix para el Service Pack 1 con el fin de usarla cuando se actualice el equipo a dicho Service Pack. Cuando actualiza el equipo al Service Pack 1 de Windows XP, la versión para el Service Pack 1 del hotfix se instala automáticamente.

    Para obtener información adicional sobre este proceso automático, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
    328848 Descripción de los paquetes de actualización de modo dual para Windows XP
  • Para comprobar si un hotfix migró al nivel del Service Pack 1 de Windows XP, revise el archivo Xpsp1hfm.log de la carpeta Windows.
  • Este problema no aparece cuando actualiza al Service Pack 2 (SP2) de Windows XP en cualquiera de los casos siguientes:
    • Realiza la actualización a partir de la versión comercial de Windows XP sin los hotfix instalados.
    • Realiza la actualización a partir del Service Pack 1 de Windows XP con los hotfix anteriores al Service Pack 2 de Windows XP instalados.
  • Después de actualizar el equipo al Service Pack 1 de Windows XP, no se pueden instalar algunos hotfix anteriores al Service Pack 1. Puede aparecer el mensaje de error siguiente:
    El programa de instalación encontró un error: Los archivos del paquete son incompatibles con los archivos del sistema.
    Este mensaje de error se muestra en el archivo de registro de la actualización, como KBxxxxxx.log. El programa Windows Installer también devuelve un código de error extendido 0xf0f1.
Causa
El archivo Branches.inf produce este problema. El archivo Branches.inf ayuda al programa Windows Installer a identificar qué versión de un hotfix concreto instalar.

El problema se produce si los hotfix siguientes están instalados:
841356 MS04-037: Una vulnerabilidad en el shell de Windows podría permitir la ejecución remota de código
840987 MS04-032: Actualización de seguridad para Microsoft Windows
824151 MS04-030: Una vulnerabilidad en un controlador de mensajes WebDAV XML podría producir una denegación de servicios
Solución
Para resolver este problema, al actualizar el equipo basado en Windows XP, use uno de los métodos siguientes:
Estado
Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a:".
Más información
Para obtener más información, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
824684 Descripción de la terminología estándar utilizada para describir las actualizaciones de software de Microsoft
Propiedades

Id. de artículo: 887822 - Última revisión: 01/16/2015 09:00:26 - Revisión: 3.0

  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
  • kbnosurvey kbarchive kbwinxppresp3fix kbwinxpsp3fix kbqfe kbfix kbbug KB887822
Comentarios