Estás trabajando sin conexión, espera a que vuelva la conexión a Internet

"Terminal leer: el identificador no es válido" mensaje de error cuando ejecuta el comando rsh en un equipo Windows_XP_Professional_Service_Pack_2-based

IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.

Haga clic aquí para ver el artículo original (en inglés): 892099
Síntomas
Cuando utiliza el comando rsh en un equipo basado en Microsoft Windows XP Professional que tiene instalado el Service Pack 2 (SP2) de Windows XP y incluya la opción - n en el comando para redirigir la entrada de rsh a NULL, recibirá el siguiente mensaje de error:
Terminal de lectura: el identificador no es válido.
Causa
Este problema se produce porque rsh ha cambiado en el Service Pack 2 para que no se interrumpe RSH.exe cuando un usuario presiona una tecla. Como parte del cambio rsh en SP2, se vacía el búfer de entrada de teclado. Si redirige la entrada de rsh a NULL con la opción - n , se produce un error de identificador no válido cuando se vacía el búfer de entrada.
Solución

Información de revisiones

Hay una revisión compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Aplíquela sólo a los sistemas que experimenten este problema específico. Esta revisión podría sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la siguiente actualización de software que contenga este hotfix.

Si la revisión está disponible para descarga, es hay una sección de "Descarga de revisión disponible" al principio de este artículo. Póngase en contacto si no aparece en esta sección, con los Microsoft cliente Servicios de y soporte técnico para obtener la revisión de.

Nota Si se producen problemas adicionales o si cualquier solución de problemas es necesario, quizás tenga que crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con esta revisión específica. Para obtener una lista completa de números de teléfono de servicio de atención al cliente y soporte técnico o para crear una solicitud de servicio independiente, visite el siguiente sitio Web: Nota El formulario "Descarga de revisión disponibles" muestra los idiomas para que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.

Requisitos previos

Esta revisión requiere Windows XP Service Pack 2.

Requisito de reinicio

No es necesario que reinicie el equipo una vez aplicado este hotfix.

Información de archivo

La versión en inglés de este hotfix tiene los atributos de archivo (o atributos de último archivo) mostrados en la siguiente tabla. Las fechas y las horas de estos archivos se muestran en hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para averiguar la diferencia entre hora UTC y la hora local, utilice la ficha zona horaria el elemento fecha y hora en el panel de control.
   Date         Time   Version            Size    File name   --------------------------------------------------------------   21-Jan-2005  19:40  5.1.2600.2601      13,312  Rexec.exe           21-Jan-2005  19:40  5.1.2600.2601      14,848  Rsh.exe          
Estado
Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a:".
Más información
Para obtener más información, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
824684Descripción de la terminología estándar utilizada para describir las actualizaciones de software de Microsoft
RSH REXEC UNIX SHELL REMOTO

Advertencia: este artículo se tradujo automáticamente

Propiedades

Id. de artículo: 892099 - Última revisión: 08/29/2007 14:28:23 - Revisión: 2.3

Microsoft Windows XP Service Pack 2

  • kbmt kbautohotfix kbpubtypekc kbqfe kbhotfixserver kbwinxpsp3fix kbwinxppresp3fix kbfix kbbug KB892099 KbMtes
Comentarios
y>