Mensaje de error al guardar una transacción o cuando se acumula la asistencia en Microsoft Dynamics GP: "No puede insertar transacciones para una fecha que no está dentro de un período de acumulación"

IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.

Haga clic aquí para ver el artículo original (en inglés): 937821
Síntomas
Al guardar una transacción o cuando se acumula asistencia, recibirá uno de los debajo de los mensajes de error:
No puede insertar transacciones para una fecha que no está dentro de un período de acumulación.

No es posible acumular asistencias para una fecha que no está dentro de un período de acumulación.
Cuando reciba este mensaje de error, no se puede completar la transacción actual de asistencia o la acumulación de asistencia actual.
Causa
Este problema se produce si uno o más de las condiciones siguientes son verdaderas en la ventana Configuración de período de acumulación en Microsoft Dynamics GP:
  • Faltan fechas de un año de acumulación.
  • Existen fechas superpuestas en un año de acumulación.
  • El año de acumulación no está completamente configurado.
  • No hay suficientes años se configuran.
  • La transacción es para una fecha que no se ha configurado.
  • Un empleado tiene una fecha de devengamiento siguiente para un período de acumulación no está configurado.
  • Códigos de acumulación sigue activos de recursos humanos para empleados inactivos.
Solución
Para resolver este problema, siga estos pasos:
  1. Utilice uno de los métodos siguientes:
    • En Microsoft Dynamics GP 10.0 y versiones posteriores: haga clic enMicrosoft Dynamics GP, seleccione Herramientas, seleccione configuración, recursos humanos, seleccione asistenciay, a continuación, haga clic en Períodos de acumulación.
    • En Microsoft Dynamics GP 9.0, haga clic en Herramientas, seleccione Programa de instalación, seleccione Recursos humanos, seleccione Asistenciay, a continuación, haga clic en Períodos de acumulación.
    • En Microsoft Business Solutions - Great Plains 8.0, haga clic en Herramientas, seleccione configuración, recursos humanos, asistenciay, a continuación, haga clic en Períodos de pago.
  2. Asegúrese de que se han configurado los siguientes tres años de los períodos de acumulación o pago:
    • El año anterior
    • El año actual
    • El próximo año
  3. Asegúrese de que no hay fechas faltan en una instalación de acumulación. Para ello, haga clic en cada período de acumulación y asegúrese de que todas las fechas se incluyen durante todo el año, hasta el 31 de diciembre (no 30). Por ejemplo, si utiliza una configuración quincenal, debe también revew las instalaciones semanales y quincenales. El sistema lee de arriba a abajo, así que asegúrese de establecer todos aquellos para las configuraciones de período hasta el uno que utiliza. Asegúrese de que en cada instalación, fechas no se pasan por alto o se superponen entre períodos y cada año.
    • Programa de instalación semanal
    • Programa de instalación quincenal
    • Programa de instalación quincenal
    Además, asegúrese de que no hay brechas existen entre períodos o años.
  4. Asegúrese de que no hay fechas existen que se incluyen varias veces en cualquier período de acumulación o en cualquier período de pago.
  5. Asegúrese de que todos los períodos de acumulación o pago tiene información de configuración especificada, incluso si no utiliza los períodos. Por ejemplo, si todos los períodos de acumulación o pago se completan según una programación Bimestral, tiene todavía configurar la información de períodos de acumulación semanal o de los períodos de pago.
  6. Si los errores están en las transacciones, asegúrese de que la fecha de laEntrada de transacciones de asistenciacuadro es correcto en elEntrada de transacciones de asistenciaventana. Además, asegúrese de que estas fechas están en el período de acumulación en el período de pago que desee.
  7. Si el error está en las acumulaciones, asegúrese de que la fecha en el cuadro acumulación de asistencia a través de es correcta en la ventana de Asistencia acumular .
  8. Si el error está en las acumulaciones, ejecute este script en SQL Server Management Studio en la base de datos de la compañía para ver si los empleados tienen una fecha de devengamiento siguiente que es mayor que el último día del año que haya establecido los períodos para los períodos de acumulación o antes de la primera fecha en que haya configurado para períodos de acumulación : (Para los registros encontrados, cambie la siguiente fecha de devengamiento a una fecha válida en la ventana Mantenimiento de asistencia de empleados.)
select * from TATM1030 where NEXTACCRUALDATE_I > 'YYYY-MM-DD' and INACTIVE = 0 and TIMETYPE_I = 4--Fill in the YYYY-MM-DD placeholder with the last day of the year that you have accrual periods set up for to see if any employees have a Next Accrual Date dated in the future. 

select * from TATM1030 where NEXTACCRUALDATE_I < 'YYYY-MM-DD' and INACTIVE = 0 and TIMETYPE_I = 4--Fill in the YYYY-MM-DD placeholder with the first day of the year that you have accrual periods set up for to see if any employees have a Next Accrual Date dated in the past.   



Propiedades

Id. de artículo: 937821 - Última revisión: 04/05/2016 16:29:00 - Revisión: 0.4

Microsoft Dynamics GP 2013, Microsoft Dynamics GP 2010, Microsoft Dynamics GP 10.0, Microsoft Dynamics GP 9.0, Microsoft Business Solutions–Great Plains 8.0

  • kberrmsg kbexpertisebeginner kbtshoot kbmbsmigrate kbprb kbexpertiseinter kbmt KB937821 KbMtes
Comentarios