Mensaje de error cuando intenta instalar una aplicación en un Windows Vista SP1 o un equipo con Windows 7: "error de sintaxis de opción de línea de comandos".

Support for Windows XP has ended

Microsoft ended support for Windows XP on April 8, 2014. This change has affected your software updates and security options. Learn what this means for you and how to stay protected.

IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.

Haga clic aquí para ver el artículo original (en inglés): 952211
Soporte para Windows Vista Service Pack 1 (SP1) finaliza el 12 de julio de 2011. Para seguir recibiendo actualizaciones de seguridad para Windows, asegúrese de que está ejecutando Windows Vista con Service Pack 2 (SP2). Para obtener más información, consulte la página web de Microsoft: Finaliza el soporte para algunas versiones de Windows.
Síntomas
Considere el siguiente escenario.
  • Está ejecutando Windows XP Service Pack 3 (SP3), Windows Vista Service Pack 1 (SP1) o un equipo basado de Windows 7
  • Utilice un nombre de usuario que incluye un carácter de caracteres de doble byte (DBCS) del conjunto.
Cuando intenta instalar una aplicación que utiliza Microsoft Visual C++ 2005 Redistributable Package, recibirá el siguiente mensaje de error:
Error de sintaxis de la opción de línea de comandos. 556085 Para obtener ayuda.
Causa
Este problema se produce porque la herramienta contenedor autoextraíble de Win32 no puede tratar los caracteres DBCS en el nombre de usuario.
Solución
Para que podamos corregir este problema para usted, vaya a la "Solucionarlo en mi lugar. Si prefiere corregir este problema manualmente, vaya a la "Solucionarlo por mí mismo.

Solucionarlo en mi lugar



Para corregir este problema automáticamente, haga clic en el arreglarlo botón o vínculo. A continuación, haga clic en ejecutar en el cuadro de diálogo Descarga de archivos cuadro y siga los pasos del Asistente para corregirlo .




Notas:
  • La corrección se solución no funcionará si su cuenta no es una cuenta de administrador.
  • Este asistente puede estar solo en inglés. Sin embargo, la corrección automática también funciona para otras versiones de idioma de Windows.
  • Si no está en el equipo que tiene el problema, guarde la solución Fix it una unidad flash o un CD y a continuación, ejecútela en el equipo que tiene el problema.

A continuación, vaya a la "¿Esto ha solucionado el problema?.



Solucionarlo por mí mismo

Para resolver este problema, siga estos pasos:
  1. Haga clic en InicioBotón Inicio, haga clic derecho en equipoy, a continuación, haga clic en Propiedades.
  2. En el área nombre de equipo, dominio y configuración de grupo de trabajo , haga clic en Cambiar configuración.

     Permiso de Control de cuentas de usuario Si se le pide una contraseña de administrador o una confirmación, escriba su contraseña o haga clic en continuar.
  3. Haga clic en Cambiar configuración y, a continuación, seleccione la ficha Avanzadas haga clic en el botón variables de entorno
  4. En el área variables de usuario , haga clic en TEMPy, a continuación, haga clic en Editar.
  5. En el cuadro valor de Variable , escriba C:\Tempy, a continuación, haga clic en Aceptar dos veces.
  6. Haga clic en Aplicary, a continuación, haga clic en Aceptar.
  7. Siga los pasos del 4 al 6 para la variable de entorno TMP también.
  8. Confirmar esa carpeta C:\Temp existe si no crear uno.
  9. Reinicie el equipo.
  10. Intente instalar de nuevo la aplicación.

¿Esto ha solucionado el problema?

FixIt corregirlo fixme

Atribuudid

Artikli ID: 952211 – viimati läbi vaadatud: 09/27/2016 23:48:00 – redaktsioon: 2.0

Windows 7 Home Premium, Windows 7 Home Premium E, Windows 7 Home Premium N, Windows 7 Enterprise, Windows 7 Enterprise E, Windows 7 Enterprise N, Windows 7 Home Basic, Windows 7 Professional, Windows 7 Professional E, Windows 7 Professional N, Windows 7 Starter, Windows 7 Starter E, Windows 7 Starter N, Windows 7 Ultimate, Windows 7 Ultimate E, Windows 7 Ultimate N, Service Pack 1 para Windows Vista, Service Pack 3 para Microsoft Windows XP

  • kberrmsg kb3rdpartyhardware kbexpertiseinter kbtshoot kbprb kbfixme kbmsifixme kbmt KB952211 KbMtes
Tagasiside