Los dispositivos remotos de NDIS (RNDIS) pueden no funcionar correctamente después de realizar una supresión imprevista en un equipo basado en Windows XP y, a continuación, conectar el dispositivo RNDIS al equipo nuevo

Ha finalizado el soporte técnico para Windows XP

Microsoft puso fin al soporte técnico para Windows XP el 8 de abril de 2014. Este cambio ha afectado a las actualizaciones de software y las opciones de seguridad. Sepa qué significa esto en su caso y cómo puede mantenerse protegido.

IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.

Haga clic aquí para ver el artículo original (en inglés): 959765
Síntomas
Considere el siguiente escenario:
  • Un dispositivo de especificación de interfaz de controlador de red remoto (RNDIS) está instalado en un equipo basado en Windows XP, como un dispositivo USB de radio.
  • Realizar una supresión imprevista del dispositivo RNDIS desde el equipo.

    Nota: Supresión imprevista es al quitar el dispositivo sin notificarlo previamente el sistema operativo.
  • Acople el dispositivo RNDIS al equipo nuevo.
En este escenario, el dispositivo RNDIS ya no funciona correctamente. Por ejemplo, la aplicación de datos en el equipo puede indicar un error que ha fallado la transmisión de datos. Para resolver este problema, tiene que reiniciar el equipo.
Causa
Este problema se produce porque, cuando ocurre una supresión imprevista, se produce un bloqueo entre dos subprocesos de Windows en el controlador de minipuerto RNDIS (Rndismpx.sys). Este problema se produce cuando se envía una consulta de identificador (también conocido como OID) de objeto para el dispositivo RNDIS y el cable se quita antes de que el equipo reciba una respuesta.

Debido a un interbloqueo, el dispositivo RNDIS no se quitará el sistema después de la supresión imprevista. Cuando este dispositivo está conectado a este equipo de nuevo, este dispositivo no se enumera porque todavía existe la instancia anterior. Por lo tanto, este dispositivo no funciona correctamente.
Solución

Información de la revisión

Existe un hotfix disponible desde Microsoft. Sin embargo, esta revisión se diseñó para corregir únicamente el problema que se describe en este artículo. Aplíquela sólo a sistemas que experimenten este problema específico.

Si la revisión está disponible para su descarga, hay una sección de "Descarga de revisión disponible" en la parte superior de este artículo de Knowledge Base. Si esta sección no aparece, envíe una solicitud al servicio de atención al cliente y soporte técnico para obtener la revisión.

Nota: Si se producen problemas adicionales o cualquier solución de problemas es necesario, tendrá que crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no califica para esta revisión específica. Para obtener una lista completa de los números de teléfono de servicio al cliente de Microsoft o para crear una solicitud de servicio independiente, visite el siguiente sitio Web de Microsoft: Nota: El formulario de "Descarga de Hotfix disponible" muestra los idiomas para los que el Hotfix está disponible. Si no ve su idioma, es porque no hay una revisión para ese idioma.

Requisitos previos

Para aplicar este hotfix, debe tener Windows XP Service Pack 2 o un service pack posterior instalado en el equipo.Para obtener más información, haga clic en el siguiente número de artículo para verlo en Microsoft Knowledge Base:
322389 Cómo obtener el service pack más reciente para Windows XP

Requisito de reinicio

Debe reiniciar el equipo después de aplicar este hotfix.

Información de reemplazo de revisión

Este hotfix no sustituye a otras revisiones.

Información de archivo

La versión en inglés de esta revisión tiene los atributos de archivo (o atributos del archivo más reciente) mostrados en la tabla siguiente. Las fechas y horas de estos archivos se muestran en la hora Universal coordinada (UTC). Al ver la información del archivo, se convierte en hora local. Para encontrar la diferencia entre la hora UTC y la hora local, utilice la ficha Zona horaria en el elemento de Fecha y hora del Panel de control.
Windows XP con Service Pack 2, versiones basadas en x 86
Nombre del archivoVersión del archivoTamaño de archivoFechaHoraPlataformaRequisito de SP
Rndismp.sys5.1.2600.348330,59224 de noviembre de 200810:54x86SERVICE PACK 2
Rndismpx.sys5.1.2600.348330,59224 de noviembre de 200810:54x86SERVICE PACK 2
Usb8023.sys5.1.2600.348312.80024 de noviembre de 200810:54x86SERVICE PACK 2
Usb8023x.sys5.1.2600.348312.80024 de noviembre de 200810:54x86SERVICE PACK 2
Windows XP con Service Pack 3, versiones basadas en x 86
Nombre del archivoVersión del archivoTamaño de archivoFechaHoraPlataformaRequisito de SP
Rndismp.sys5.1.2600.571630,59225 de noviembre de 200811:42x86SERVICE PACK 3
Rndismpx.sys5.1.2600.571630,59225 de noviembre de 200811:42x86SERVICE PACK 3
Estado
Microsoft ha confirmado que se trata de un problema de los productos de Microsoft que se enumeran en la sección "Aplicable a".
Más información
Para obtener más información acerca de RNDIS y Windows, visite el siguiente sitio Web:

Advertencia: este artículo se tradujo automáticamente

Propiedades

Id. de artículo: 959765 - Última revisión: 10/11/2015 06:42:00 - Revisión: 9.0

Microsoft Windows XP Professional, Microsoft Windows XP Home Edition

  • kbautohotfix kbexpertiseinter kbfix kbbug kbsurveynew kbqfe kbmt KB959765 KbMtes
Comentarios