Los usuarios no pueden realizar la autenticación a través de ADFS en un entorno de Windows Server 2003 R2 cuando los sufijos UPN contienen un carácter que se expande a un par de dos letras

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Síntomas
Tenga en cuenta la situación siguiente:
  • Establecer un entorno de servicios de federación de Active Directory (ADFS) en un servidor basado en Windows Server 2003 R2.
  • Uno de los idiomas siguientes está configurado en el servidor en el entorno de ADFS de recursos:
    • Bokmal
    • Croata
    • Checo
    • Danés
    • Húngaro
    • Nynorsk
    • Eslovaco
    • Español
    • Vietnamita
  • Los sufijos de nombre principal (UPN) de usuario para algunos usuarios contienen un carácter que se expande a un par de dos letras. Por ejemplo, el sufijo UPN contiene el carácter å y se expande el par de dos letras aa.
En este escenario, estos usuarios no pueden realizar la autenticación a través de ADFS.
Causa
Este problema se produce porque ADFS utiliza el comparador de cadena incorrectamente cuando intenta ordenar y buscar los sufijos UPN.
Solución

Información de revisiones

Hay una revisión compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Aplíquela sólo a los sistemas que experimenten este problema específico. Esta revisión podría sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la siguiente actualización de software que contenga este hotfix.

Si la revisión está disponible para descarga, es hay una sección de "Descarga de revisión disponible" al principio de este artículo. Póngase en contacto si no aparece en esta sección, con los Microsoft cliente Servicios de y soporte técnico para obtener la revisión de.

Nota Si se producen problemas adicionales o si cualquier solución de problemas es necesario, quizás tenga que crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con esta revisión específica. Para obtener una lista completa de números de teléfono de servicio de atención al cliente y soporte técnico o para crear una solicitud de servicio independiente, visite el siguiente sitio Web: Nota El formulario "Descarga de revisión disponibles" muestra los idiomas para que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.

Requisitos previos

Para aplicar este hotfix, el equipo debe tener instalado Windows Server 2003 R2 Service Pack 2 (SP2).

Requisito de reinicio

Tendrá que reiniciar el equipo después de aplicar este hotfix.

Información acerca de la sustitución de la revisión

Esta revisión no sustituye a ninguna otro publicada previamente.

Información de archivo

La versión en inglés de este hotfix tiene los atributos de archivo (o atributos de último archivo) mostrados en la siguiente tabla. Las fechas y las horas de estos archivos se muestran en hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para averiguar la diferencia entre hora UTC y la hora local, utilice la ficha zona horaria el elemento fecha y hora en el panel de control.
Windows Server 2003 R2 SP2, versiones basadas en 86 en x
Nombre de archivoArchivo VersiónTamaño del archivoFechaTiempoPlataformaRequisito de SP
Adfsreg.exe5.2.3790.44827.68024-Mar-200912: 56x 86SP2
System.Web.Security.SingleSignOn.dll5.2.3790.4482581,63224-Mar-200917: 42x 86SP2
Windows Server 2003 R2 SP2, versiones basadas en 64 x
Nombre de archivoArchivo VersiónTamaño del archivoFechaTiempoPlataformaRequisito de SP
Adfsreg.exe5.2.3790.44829,21624-Mar-200915: 33x 64SP2
System.Web.Security.SingleSignOn.dll5.2.3790.4482581,63224-Mar-200915: 33x 86SP2
Estado
Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a:".
Más información
Para obtener más información acerca de ADFS, visite el siguiente sitio Web de Microsoft: Para configurar un idioma en el servidor de recursos, siga estos pasos:
  1. Abra el elemento Configuración Regional y de idioma . Para ello, haga clic en Inicio , haga clic en Ejecutar , escriba intl.cpl en el cuadro Abrir y, a continuación, haga clic en Aceptar .
  2. En estándares y formatos , seleccione uno de los idiomas que se mencionan en la sección "Síntomas", como por ejemplo danés.
  3. En la ficha idiomas , haga clic en Detalles .
  4. Bajo Servicios instalados , haga clic en Agregar y, a continuación, seleccione el idioma que especificó en el paso 2.
  5. En el idioma de entrada predeterminado , seleccione el idioma agregado y, a continuación, haga clic en Aceptar .
  6. En la ficha Avanzadas , haga clic para seleccionar la casilla aplicar toda la configuración a la cuenta de usuario actual y al perfil de usuario predeterminado en configuración de cuenta de usuario predeterminada .
Para obtener más información, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
824684 Descripción de la terminología estándar utilizada para describir las actualizaciones de software de Microsoft

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Propiedades

Id. de artículo: 969451 - Última revisión: 01/15/2015 16:42:34 - Revisión: 1.0

  • Microsoft Windows Server 2003 R2 Datacenter Edition (32-Bit x86)
  • Microsoft Windows Server 2003 R2 Datacenter x64 Edition
  • Microsoft Windows Server 2003 R2 Enterprise Edition (32-Bit x86)
  • Microsoft Windows Server 2003 R2 Enterprise x64 Edition
  • Microsoft Windows Server 2003 R2 Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003 R2 Standard x64 Edition
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