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Un paquete de continuación de actualizaciones de Hyper-V está disponible para un equipo que ejecuta Windows Server 2008 R2

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Haga clic aquí para ver el artículo original (en inglés): 975354
INTRODUCCIÓN
Este paquete de continuación de actualizaciones resuelve algunos problemas que se producen cuando una copia de seguridad o restaurar máquinas virtuales Hyper-V.

Problemas corregidos en este paquete de continuación de actualizaciones

Problema 1

Tenga en cuenta la situación siguiente:
  • Algunas conexiones Internet SCSI (iSCSI) se crean en una máquina virtual que se está ejecutando Windows Server 2003.
  • Copia de este equipo virtual en el servidor host de máquina virtual.
En este escenario, el código de error 0x800423f4 se produce cuando se hace copia de seguridad de la máquina virtual. Además, se registra el suceso siguiente en el registro de sucesos del servicio de administración de Hyper-V Virtual Machine:

El número de volúmenes reverted no coincide con el número de volúmenes en la instantánea establecido para el equipo virtual "'nombre de máquina virtual' (ID de máquina virtual <GUID>)".

Problema 2

Tenga en cuenta la situación siguiente:
  • Volúmenes de clúster compartido están habilitados en un clúster de conmutación por error para Hyper-V.
  • Algunos equipos virtuales se guardan en el mismo volumen. Pero se ejecutan en distintos nodos.
  • Se realiza una copia de seguridad de estas máquinas virtuales en paralelo.
En este escenario, falla la operación de copia de seguridad de la máquina virtual.

Problema 3

Tenga en cuenta la situación siguiente:
  • Una máquina virtual se hace la copia de seguridad en un servidor que ejecuta Hyper-V.
  • Al mismo tiempo, se está realizando una operación de copia de seguridad de la aplicación en la misma máquina virtual.
En este escenario, se truncan algunos datos de la copia de seguridad de la aplicación en la máquina virtual. Por tanto, este comportamiento provoca la pérdida de datos.

Problema 4

Tenga en cuenta la situación siguiente:
  • Se realiza una copia de seguridad de una máquina virtual que tiene algunas instantáneas en un servidor que ejecuta Hyper-V.
  • A continuación, este equipo virtual se restaura a otra ubicación.
En este escenario, se producirá un error en la operación de restauración y la máquina virtual puede estar dañada.
Causa
Causa del problema 1

Cuando una máquina virtual se hace la copia de seguridad, el escritor de VSS del servidor que ejecuta Hyper-V realiza una llamada a la máquina virtual invitada para comprobar si existe cualquier conexiones iSCSI. Esta llamada tiene un tiempo de espera predeterminado de 60 segundos. Si esta llamada no se devuelve dentro de la limitación de tiempo, el escritor de VSS del servidor que ejecuta incorrectamente Hyper-V se supone que no hay ninguna conexión iSCSI. Por tanto, se produce un error en la operación de copia de seguridad.

Causa del problema 2

Cuando se realiza una copia de seguridad de los equipos virtuales en distintos nodos en paralelo, cada nodo espera a ser el propietario del volumen compartido de clúster para crear las instantáneas. Sin embargo, el servicio de Cluster Server mueve el propietario del volumen de un nodo a otro nodo inmediatamente después de crea una instantánea sin esperar a que las tareas posteriores a instantánea que se complete. Si otro nodo solicita que la misma compartida volumen para una operación de copia de seguridad antes de que se completen las tareas posteriores a instantánea, el servicio de Cluster Server cambia el volumen a otro nodo. Por tanto, el escritor de VSS que se encuentra en el nodo anterior no puede encontrar el volumen compartido de clúster localmente cuando realiza tareas posteriores a instantánea. Este comportamiento hace que la operación de copia de seguridad de máquina virtual a un error.

Causa del problema 3

La operación de copia de seguridad de aplicación en la máquina virtual incorrectamente se ve afectada por la operación de copia de seguridad de máquina virtual en el servidor que ejecuta Hyper-V.

Causa del problema 4

Los archivos de instantáneas no se restaurarán correctamente al restaurar el equipo virtual.
Solución
Importante Esta sección, método o de tarea contiene pasos que le indican cómo modificar el registro. Sin embargo, pueden producirse problemas graves si modifica incorrectamente el registro. Por tanto, asegúrese de que siga estos pasos cuidadosamente. Para obtener más protección, haga una copia de seguridad del registro antes de modificarlo. A continuación, puede restaurar el registro si se produce un problema. Para obtener más información acerca de cómo realizar una copia de seguridad y restaurar el registro, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
322756Cómo hacer copia de seguridad y restaurar el registro de Windows
Nota Puede experimentar todavía "Emisión 3" después de instalar este hotfix. Puede aplicar la entrada de registro siguiente en una máquina virtual para corregir "Emitir 3" para ese equipo virtual:
Ubicación: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Virtualization\VssRequestor
Nombre: TipoDeCopia
Tipo: REG_DWORD
Valor: 0 o 1
Si se crea esta entrada del registro y su valor se establece en 1, copia de seguridad de aplicación no se verán afectado por la operación de copia de seguridad de máquina virtual en el servidor que ejecuta Hyper-V. Si esta entrada del registro no existe o si su valor es 0, se produce el "problema 3".

Información de revisiones

Después de instalar esta revisión en el servidor Hyper-V, debe actualizar los componentes de integración en las máquinas virtuales. Para ello, abra la conexión de la máquina virtual para el equipo virtual en el Administrador de Hyper-V y, a continuación, seleccione la opción Insertar disco de instalación de Integration Services en el menú acción.

Hay un hotfix compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema que se describe en este artículo. Esta revisión sólo se aplican a los sistemas que experimenten el problema descrito en este artículo. Esta revisión podría ser sometida a comprobaciones adicionales. Por tanto, si no se ve muy afectado por este problema, recomendamos que espere la próxima actualización de software que contenga este hotfix.

Si la revisión está disponible para descarga, hay una sección de "Descarga de revisión disponible" en la parte superior de este artículo de Knowledge Base. Si esta sección no aparece, póngase en contacto con el servicio de atención al cliente y soporte técnico para obtener la revisión.

Nota Si se producen problemas adicionales o si se requiere cualquier solución de problemas, quizás tenga que crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no reúnan las condiciones necesarias para esta revisión específica. Para obtener una lista completa de servicio de atención al cliente y soporte números de teléfono o para crear una solicitud de servicio independiente, visite el siguiente sitio Web: Nota El formulario "Descarga de revisión disponible" muestra los idiomas para el que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.

Requisitos previos

Para aplicar esta revisión, el equipo debe estar ejecutando uno de los sistemas operativos siguientes:
  • Windows Server 2008 R2
  • Windows 7
Notas
  • Esta actualización contiene correcciones para VSS y Hyper-V. La actualización de Hyper-V sólo es aplicable a las versiones x 64 de Windows Server 2008 R2.
  • Una vez instalado este paquete acumulativo, Hyper-V sólo utilizará el proveedor de VSS del sistema dentro de la máquina virtual al realizar una copia de seguridad de nivel de host.

Requisito de reinicio

Debe reiniciar el equipo después de aplicar este hotfix.

Información acerca de la sustitución de la revisión

Este hotfix no sustituye a ningún otro hotfix.

Información de archivo

La versión en inglés de este hotfix tiene los atributos de archivo (o atributos de último archivo) mostrados en la siguiente tabla. Las fechas y horas de estos archivos se muestran en hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para encontrar la diferencia entre la UTC y la hora local, utilice la ficha zona horaria en la fecha y hora elemento del panel de control.
Nota de información de archivo de Windows Server 2008 R2 y Windows 7

Los archivos MANIFEST (.manifest) y los MUM (.mum) que se instala para cada entorno está listed separately. MUM y MANIFEST archivos y los archivos de catálogo (.cat) de seguridad asociado, son esenciales para el mantenimiento del estado del componente actualizado. Los archivos del catálogo de seguridad (atributos no enumerados) están firmados con una firma digital de Microsoft.
Para todas las versiones de 86 de Windows 7 x

Nombre de archivoArchivo VersiónTamaño de archivoFechaTiempoPlataforma
75dfb225-e2e4-4 d 39-9ac9-ffaff65ddf06.xmlNo aplicable2,77610-Jun-200921: 47No aplicable
Eventcls.dll6.1.7600.1638516.89614-Jul-200901: 15x 86
Vssapi.dll6.1.7600.205411,124,35205-Oct-200905: 51x 86
Vsstrace.dll6.1.7600.2054156,32005-Oct-200905: 51x 86
Para todas las versiones de 64 de Windows Server 2008 R2 y de Windows7 x

Nombre de archivoArchivo VersiónTamaño de archivoFechaTiempoPlataforma
Windows5.x-hypervintegrationservices-x64.msiNo aplicable1,456,64006-Oct-200906: 46No aplicable
Windows6.0-hypervintegrationservices-x64.cabNo aplicable448,50706-Oct-200907: 15No aplicable
Windows6.1-hypervintegrationservices-x64.cabNo aplicable448,01906-Oct-200907: 27No aplicable
Vmms.exe6.1.7600.205424,499,96806-Oct-200905: 03x 64
75dfb225-e2e4-4 d 39-9ac9-ffaff65ddf06.xmlNo aplicable2,77610-Jun-200921: 08No aplicable
Eventcls.dll6.1.7600.1638516.38414-Jul-200901: 40x 64
Vssapi.dll6.1.7600.205421,746,94406-Oct-200906: 34x 64
Vsstrace.dll6.1.7600.2054276,80006-Oct-200906: 34x 64
Eventcls.dll6.1.7600.1638516.89614-Jul-200901: 15x 86
Vssapi.dll6.1.7600.205421,124,35206-Oct-200906: 07x 86
Vsstrace.dll6.1.7600.2054256,32006-Oct-200906: 07x 86
Para todas las versiones basadas en Itanium de Windows Server 2008 R2

Nombre de archivoArchivo VersiónTamaño de archivoFechaTiempoPlataformaTipo de servicio
75dfb225-e2e4-4 d 39-9ac9-ffaff65ddf06.xmlNo aplicable2,77610-Jun-200921: 14No aplicableNo aplicable
Eventcls.dll6.1.7600.1638531,23214-Jul-200901: 46IA-64No aplicable
Vssapi.dll6.1.7600.205412,506,75205-Oct-200904: 57IA-64No aplicable
Vsstrace.dll6.1.7600.20541123,90405-Oct-200904: 57IA-64No aplicable
Eventcls.dll6.1.7600.1638516.89614-Jul-200901: 15x 86GUAU
Vssapi.dll6.1.7600.205411,124,35205-Oct-200905: 51x 86GUAU
Vsstrace.dll6.1.7600.2054156,32005-Oct-200905: 51x 86GUAU


Estado
Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a:".
Más información
Para obtener más información acerca de la terminología relativa a las actualizaciones de software, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
824684Descripción de la terminología estándar utilizada para describir las actualizaciones de software de Microsoft

Archivos adicionales para todas las versiones de 86 de Windows 7 x


Nombre de archivoArchivo VersiónTamaño de archivoFechaTiempoPlataforma
Package_for_kb975354_rtm ~ 31bf3856ad364e35 ~ x 86 ~ ~ 6.1.1.0.mumNo aplicable1,94705-Oct-200908: 39No aplicable
X86_microsoft-ventanas-vssapi_31bf3856ad364e35_6.1.7600.20541_none_d56e11acfc160890.manifestNo aplicable12,38905-Oct-200908: 44No aplicable

Archivos adicionales para todas las versiones de 64 de Windows Server 2008 R2 y de Windows 7 x


Nombre de archivoArchivo VersiónTamaño de archivoFechaTiempoPlataforma
Amd64_microsoft-hyper-v-g..aller-win5x-package_31bf3856ad364e35_6.1.7600.20542_none_2ed3f910bd050e3b.manifestNo aplicable2,27306-Oct-200907: 09No aplicable
Amd64_microsoft-hyper-v-g..aller-win60-package_31bf3856ad364e35_6.1.7600.20542_none_951fd644ee15dd34.manifestNo aplicable3,36906-Oct-200907: 28No aplicable
Amd64_microsoft-hyper-v-vstack-vmms_31bf3856ad364e35_6.1.7600.20542_none_933cd6ca919d9d8b.manifestNo aplicable316,00206-Oct-200907: 00No aplicable
Amd64_microsoft-ventanas-vssapi_31bf3856ad364e35_6.1.7600.20542_none_318dad7ab472931d.manifestNo aplicable12,39306-Oct-200916: 08No aplicable
Package_for_kb975354_rtm ~ 31bf3856ad364e35 ~ amd64 ~ ~ 6.1.2.0.mumNo aplicable2,94506-Oct-200916: 08No aplicable
Wow64_microsoft-ventanas-vssapi_31bf3856ad364e35_6.1.7600.20542_none_3be257cce8d35518.manifestNo aplicable11,45306-Oct-200916: 08No aplicable

Archivos adicionales para todas compatibles las versiones basadas en Itanium de Windows Server 2008 R2


Nombre de archivoArchivo VersiónTamaño de archivoFechaTiempoPlataforma
Ia64_microsoft-ventanas-vssapi_31bf3856ad364e35_6.1.7600.20541_none_d56fb5a2fc14118c.manifestNo aplicable12,39105-Oct-200908: 39No aplicable
Package_for_kb975354_rtm ~ 31bf3856ad364e35 ~ ia64 ~ ~ 6.1.1.0.mumNo aplicable1,95805-Oct-200908: 39No aplicable
Wow64_microsoft-ventanas-vssapi_31bf3856ad364e35_6.1.7600.20541_none_3be15782e8d43bc1.manifestNo aplicable11,45305-Oct-200908: 39No aplicable
Referencias
Para obtener más información acerca del clúster volúmenes compartidos, visite el siguiente sitio Web:
Autor: stevenxu; jeffpatt
Escritor: v-stxu
Revisor técnico: msteinh soumyadb jeffpatt; stevenxu
Editor: v-lynan

Advertencia: este artículo se tradujo automáticamente

Propiedades

Id. de artículo: 975354 - Última revisión: 11/10/2009 08:00:51 - Revisión: 1.1

Windows Server 2008 R2 Datacenter, Windows Server 2008 R2 Enterprise, Windows Server 2008 R2 Standard, Windows 7 Enterprise, Windows 7 Home Basic, Windows 7 Home Premium, Windows 7 Professional, Windows 7 Starter, Windows 7 Ultimate

  • kbmt kbqfe kbhotfixserver kbsurveynew kbautohotfix kbexpertiseinter kbbug kbfix KB975354 KbMtes
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