BUSCARX (función BUSCARX)

Use la función BUSCARX cuando necesite encontrar elementos en una tabla o en un rango por filas. Por ejemplo, puede buscar el precio de una pieza de automóvil por el número de pieza o buscar un nombre de empleado en función de su ID. de empleado. Con BUSCARX, puede buscar en una columna un término de búsqueda y devolver un resultado de la misma fila en otra columna, independientemente de en qué lado se encuentre la columna devuelta.

Lograr un gran impacto con Anuncios

Nota: Esta función está actualmente disponible para los suscriptores Microsoft 365 en el canal actual. Estará disponible para los suscriptores de Microsoft 365 en un canal empresarial semianual a partir del 2020 de julio. Para obtener más información sobre cómo se implementan las características para los suscriptores de Microsoft 365, consulte ¿Cuándo puedo obtener las características más recientes para Microsoft 365.

La función BUSCARX busca un rango o una matriz y devuelve un elemento que corresponde a la primera coincidencia que encuentra. Si no hay ninguna coincidencia, BUSCARX puede devolver la coincidencia más cercana (aproximada). 

=BUSCARX(valor_buscado; matriz_buscada; matriz_devuelta; [si_no_se_encuentra]; [modo_de_coincidencia]; [modo_de_búsqueda]) 

argumento

Descripción

valor_buscado

Requerido

El valor buscado

matriz_buscada

Requerido

La matriz o rango para buscar

matriz_devuelta

Requerido

La matriz o rango para devolver

[si_no_se_encuentra]

Opcional

Si no se encuentra una coincidencia válida, devolver el texto [if_not_found] que proporcione.

Si no se encuentra una coincidencia válida y no hay [if_not_found], se devolverá #N/A.

[modo_de_coincidencia]

Opcional

Especifique el tipo de coincidencia:

0: coincidencia exacta. Si no se encuentra ninguno, devolver #N/A. Este valor es el predeterminado.

-1: coincidencia exacta. Si no se encuentra ninguna, devolver el siguiente elemento más pequeño.

1: coincidencia exacta. Si no se encuentra ninguna, devolver el siguiente elemento más grande.

2: una coincidencia comodín donde *, ? y ~ tienen significado especial.

[modo_de_búsqueda]

Opcional

Especifique el modo de búsqueda que se usará:

1: realizar una búsqueda empezando por el primer elemento. Este valor es el predeterminado.

-1: realizar una búsqueda inversa empezando por el último elemento.

2: realizar una búsqueda binaria que se base en que lookup_array se ordene en orden ascendente. Si no está ordenada, se devolverán resultados no válidos.

-2: realizar una búsqueda binaria que se base en que lookup_array se ordene en orden descendente. Si no está ordenada, se devolverán resultados no válidos.

Ejemplos

Ejemplo 1

Este ejemplo se encuentra en el vídeo anterior y usa una función BUSCARX sencilla para buscar un nombre de país y devolver el prefijo telefónico del país. Solo se incluyen los argumentos lookup_value (celda F2), lookup_array (rango B2:B11) y return_array (rango D2:D11). No incluye el argumento match_mode, ya que de forma predeterminada BUSCARX usa una coincidencia exacta.

Ejemplo de uso de la función BUSCARX para devolver un nombre de empleado y un departamento basándose en el ID. de empleado. La fórmula es =BUSCARX(B2;B5:B14;C5:C14).

Nota: BUSCARX se diferencia de BUSCARV en que usa matrices de búsqueda y devolución distintas, mientras que BUSCARV usa una sola matriz de tablas seguida de un número de índice de la columna. La fórmula equivalente de BUSCARV en este caso sería: =BUSCARV(F2;B2:D11;3;FALSE)

Ejemplo 2

En este ejemplo, estamos buscando información de un empleado basada en un número de identificación de empleado. Al contrario que BUSCARV, BUSCARX puede devolver una matriz con varios elementos, lo que permite que una sola fórmula devuelva tanto el nombre del empleado como el de un departamento de las celdas C5:D14.

Ejemplo de uso de la función BUSCARX para devolver un nombre de empleado y un departamento basándose en el ID. de empleado. La fórmula es =BUSCARX(B2;B5:B14;C5:D14;0;1)

Ejemplo 3

Este ejemplo agrega el argumento if_not_found al ejemplo anterior.

Ejemplo de uso de la función BUSCARX para devolver un nombre de empleado y un departamento basándose en el ID. de empleado con el argumento if_not_found. La fórmula es =BUSCARX(B2;B5:B14;C5:D14;0;1;"Empleado no encontrado")

Ejemplo 4

En el ejemplo siguiente se busca en la columna C los ingresos personales especificados en la celda E2 y se encuentra un tipo impositivo coincidente en la columna B. Establece el argumento if-not_found para devolver 0 si no se encuentra nada. El argumento match_mode está establecido en 1, lo que significa que la función buscará una coincidencia exacta y, si no encuentra una, devolverá el siguiente elemento más grande. Por último, el argumento search_mode está establecido en 1, lo que significa que la función buscará desde el primer elemento hasta el último.

Imagen de la función BUSCARX usada para devolver un tipo impositivo basado en los ingresos máximos. Esta es una coincidencia aproximada. La fórmula es: =BUSCARX(E2;C2:C7;B2:B7;1;1)

Nota: Al contrario que BUSCARV, la columna lookup_array se encuentra a la derecha de la columna return_array, donde BUSCARV solo puede buscar de izquierda a derecha.

Ejemplo 5

Luego, usaremos una función anidada BUSCARX para realizar una coincidencia vertical y otra horizontal. En este caso buscará, en primer lugar, Ingresos brutos en la columna B y después buscará Trim1 en la fila superior de la tabla (rango C5:F5) y devolverá el valor en la intersección de los dos. Esto es similar a usar las funciones INDICE y COINCIDIR conjuntamente. También puede usar BUSCARX para reemplazar la función BUSCARH.

Imagen de la función BUSCARX usada para devolver datos horizontales de una tabla anidando 2 funciones BUSCARX. La fórmula es: : =BUSCARX (D2;$B6:$B17;BUSCARX ($C3;$C5:$G5;$C6:$G17))

La fórmula en las celdas D3:F3 es: =BUSCARX(D2;$B6:$B17;BUSCARX($C3;$C5:$G5;$C6:$G17)).

Ejemplo 6

Este ejemplo usa la función SUMA y dos funciones BUSCARX anidadas para sumar todos los valores entre dos rangos. En este caso, queremos sumar los valores de uvas, plátanos e incluir peras, que están entre ambos.

Uso de BUSCARX con SUMA para sumar un intervalo de valores entre dos selecciones

La fórmula de la celda E3 es: =SUMA(BUSCARX(B3;B6:B10;E6:E10):BUSCARX(C3;B6:B10;E6:E10))

¿Cómo funciona? BUSCARX devuelve un rango, por lo que, cuando se calcula, la fórmula tiene un aspecto similar al siguiente: =SUMA($E$7:$E$9). Puede ver cómo funciona por su cuenta. Para ello, seleccione una celda con una fórmula BUSCARX similar a esta, vaya a Fórmulas > Auditoría de fórmulas > Evaluar fórmula y presione el botón Evaluar para avanzar por el cálculo.

Nota: Gracias a Microsoft Excel MVP, Bill Jelen, por sugerir este ejemplo.

¿Necesitas más ayuda?

Siempre puede preguntar a un experto en Excel Tech Community, obtener soporte técnico en la Comunidad de respuestas o sugerir una característica nueva o mejora en el UserVoice de Excel.

Vea también

Función COINCIDIRX

Funciones de Excel (por orden alfabético)

Funciones de Excel (por categoría)

Nota:  Esta página se ha traducido mediante un sistema automático y es posible que contenga imprecisiones o errores gramaticales. Nuestro objetivo es que este contenido le resulte útil. ¿Podría decirnos si la información le resultó útil? Aquí puede consultar el artículo en inglés.

Ampliar sus conocimientos de Office
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×