Cómo corregir un error #¡VALOR! en la función SUMAPRODUCTO

Nota: Nos gustaría proporcionarle el contenido de ayuda actual lo más rápido posible en su idioma. Esta página se ha traducido mediante un sistema automático y es posible que contenga imprecisiones o errores gramaticales. Nuestro objetivo es que este contenido sea útil para usted. ¿Puede informarnos sobre si la información le ha sido útil al final de la página? Aquí tiene el artículo en inglés para que pueda consultarlo fácilmente.

En este tema, se tratan los escenarios comunes del error #¡VALOR! al trabajar en la función SUMAPRODUCTO.

Problema: Los argumentos de matriz no tienen la misma dimensión

Todos los argumentos de matriz deben tener la misma dimensión. Si no la tienen, obtendrá un error #¡VALOR!. Por ejemplo, si la matriz 1 hace referencia a un rango de 3 filas y 2 columnas, entonces la matriz 2 debe también referirse al mismo rango.

La fórmula SUMAPRODUCTO que provoca un error es =SUMAPRODUCTO(D2:D13,E2:E10): E10 necesita cambiarse a E13 para que coincida con el primer rango.
  • =SUMAPRODUCTO(D2:D13,E2:E10)

Producirá un error ya que los rangos a los que se hace referencia no tienen el mismo número de filas (13 en el primer rango pero solo 10 en el segundo).

Solución: Cambie la fórmula a:

  • =SUMAPRODUCTO(D2:D13,E2:E13)

De esta manera, los dos rangos tienen el mismo número de filas de inicio y final, y puede volver a probar la fórmula.

Resolver el error #¡VALOR! en los datos para resolver el error de SUMAPRODUCTO

Problema: Una o más celdas del rango contienen texto

Si una o más celdas del rango al que se hace referencia contiene texto o tiene el formato de un tipo de datos Texto, obtendrá el error #¡VALOR!. El texto puede ser el resultado de un cálculo de otra fórmula, o quizás la celda simplemente no tiene el formato correcto.

La fórmula de la celda E15 muestra un error #¡VALOR! porque existe un error #¡VALOR! en la columna E.

Solución: Compruebe todas las celdas que contienen texto o que tienen formato de texto y establezca el tipo de datos correcto.

¿Tiene alguna pregunta específica acerca de la función?

Publique una pregunta en el foro de la comunidad de Excel

Ayudarnos a mejorar Excel

¿Tiene alguna sugerencia sobre cómo podemos mejorar la próxima versión de Excel? Si es así, vea los temas en el sitio de UserVoice de Excel

Vea también

Corregir un error #¡VALOR!

Función SUMAPRODUCTO

Información general sobre fórmulas en Excel

Cómo evitar la ruptura de las fórmulas

Detectar errores en fórmulas

Todas las funciones de Excel (por orden alfabético)

Funciones de Excel (por categoría)

¿Necesita más ayuda?

Ampliar sus conocimientos de Office
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×