Cómo corregir un error #¡VALOR! en las funciones PROMEDIO o SUMA

Si promedio o suma hacen referencia a celdas que contienen #VALUE! errores, las fórmulas se convertirán en un #VALUE. .

Error #¡VALOR! en la función PROMEDIO

Para omitir los valores de error, crearemos una fórmula que ignora los errores en el rango de referencia mientras calcula el promedio con los valores "normales" restantes.

Para trabajar en este escenario, usamos una combinación de PROMEDIO junto con SI y ESERROR para determinar si existe un error en el rango especificado. Este escenario concreto necesita una fórmula de matriz:

=PROMEDIO(SI(ESERROR(B2:D2),"",B2:D2))

Esta es una fórmula de matriz. Por tanto, debe presionar entrar (solo si está usando Microsoft 365 ) o Ctrl + Mayús + entrar en la fórmula.

Nota: Si tiene una versión actual de Microsoft 365, simplemente puede escribir la fórmula en la celda de salida y, a continuación, presionar entrar para confirmar la fórmula como una fórmula de matriz dinámica. En caso contrario, la fórmula debe especificarse como una fórmula de matriz heredada, seleccionando primero la celda de salida, especificando la fórmula en la celda de salida y, a continuación, presionando Ctrl + Mayús + entrar para confirmarla. Excel insertará llaves al principio y al final de la fórmula. Para obtener más información sobre las fórmulas de matriz, vea Directrices y ejemplos de fórmulas de matriz.

Función array en promedio para resolver el #VALUE. error

Nota: La función anterior no solo funcionará para el error #¡VALOR!, sino también para #N/A, #NULL y #¡DIV/0! entre otros.

También puede usar SUMA de la misma manera:

=SUMA(SI(ESERROR(B2:D2),"",B2:D2))

¿Tiene alguna pregunta sobre una función específica?

Publique una pregunta en el foro de la comunidad de Excel

¿Necesitas más ayuda?

Siempre puede preguntar a un experto en Excel Tech Community, obtenga soporte en la Comunidad de respuestas.

Vea también

Corregir un error #¡VALOR! error

Función PROMEDIO

Función SUMA

Información general sobre fórmulas en Excel

Detectar errores en fórmulas

Todas las funciones de Excel (orden alfabéticos)

Todas las funciones de Excel (por categoría)

¿Necesita más ayuda?

Ampliar sus conocimientos de Office
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×