Cómo corregir un error #¡VALOR! error en la función sumar.Si/SUMAr. Si. conjunto

En este tema, se enumeran las causas más comunes del error #¡VALOR! en las funciones SUMAR.SI y SUMAR.SI.CONJUNTO, y cómo resolverlo.

Problema: La fórmula hace referencia a celdas de un libro cerrado

Las funciones sumar.Si o SUMAr. Si, que hacen referencia a una celda o rango de un libro cerrado, darán como resultado un #VALUE. .

Nota: Este es un problema conocido de varias funciones de Excel como CONTAR.SI, CONTAR.SI.CONJUNTO y CONTAR.BLANCO por nombrar algunas. Vea las funciones SUMAR.SI, CONTAR.SI y CONTAR.BLANCO devuelven un error "#¡VALOR!" Artículo Error para obtener más información.

Solución: Abra el libro indicado en la fórmula y presione F9 para actualizar la fórmula.

También puede evitar este problema con las funciones suma y si juntas en una fórmula de matriz. Consulte las funciones sumar.Si, contar.Si y contar. blanco devuelven #VALUE! error para obtener más información.

Problema: La cadena de criterios tiene más de 255 caracteres

Las funciones SUMAR.SI y SUMAR.SI.CONJUNTO devuelven resultados incorrectos cuando intenta hacer coincidir cadenas de más de 255 caracteres.

Solución: Acorte la cadena si es posible. Si no puede, use la función CONCATENAR o el operador de Y comercial (&) para desglosar el valor en varias cadenas. Por ejemplo:

=SUMAR.SI(B2:B12,"cadena larga"&"otra cadena larga")

Problema: En SUMAR.SI.CONJUNTO, el argumento rango_criterios no es coherente con el argumento rango_suma.

En SUMAR.SI.CONJUNTO los argumentos de rango siempre deben ser iguales. Eso significa que los argumentos rango_criterios y rango_suma deben hacer referencia al mismo número de filas y columnas.

En el ejemplo siguiente, se supone que la fórmula devolverá la suma de las ventas diarias de manzanas en Bellevue. El argumento sum_range (C2: C10) no se corresponde con el mismo número de filas y columnas de los argumentos criteria_range (A2: A12 & B2: -o). Si usa la sintaxis = SUMAr. Si. #VALUE conjunto (C2: C10,a2: A12, A14,B2: .

La fórmula incorrecta es =SUMAR.SI.CONJUNTO(C2:C10,A2:A12,A14,B2:B12,B14), donde C2:C10 necesita ser C2:C12

Solución: Siguiendo este ejemplo, cambie el argumento rango_suma a C2:C12 y vuelva a intentar la fórmula.

Nota:  SUMAR.SI puede usar diferentes rangos de tamaño.

¿Tiene alguna pregunta sobre una función específica?

Publique una pregunta en el foro de la comunidad de Excel

Ayudarnos a mejorar Excel

¿Tiene alguna sugerencia sobre cómo podemos mejorar la siguiente versión de Excel? Si es así, consulte los temas en Excel User Voice.

Vea también

Corregir un error #¡VALOR! error

SUMAR.SI (función SUMAR.SI)

Función SUMAR.SI.CONJUNTO

Vídeos de la función si avanzada

Información general sobre fórmulas en Excel

Cómo evitar la ruptura de las fórmulas

Detectar errores en fórmulas

Todas las funciones de Excel (orden alfabéticos)

Todas las funciones de Excel (por categoría)

¿Necesita más ayuda?

Ampliar sus conocimientos de Office
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×