Contar caracteres de las celdas

Cuando necesite contar los caracteres de las celdas, use la función Len, que cuenta letras, números, caracteres y todos los espacios. Por ejemplo, la longitud de "Hace más de 36 grados hoy, así que vamos a nadar" (excluyendo las comillas) es de 42 caracteres —31 letras, 2 números, 8 espacios, una coma y las comillas.

Para usar la función, escriba = Len (celda) en la barra de fórmulas y, a continuación, presione Entrar en el teclado.

Varias celdas: Para aplicar la misma fórmula a varias celdas, introduzca la fórmula en la primera celda y, a continuación, arrastre el controlador de relleno hacia abajo (o al lado) del rango de celdas.

Especificación de varias funciones LARGO en una hoja de cálculo

Para obtener un recuento total de todos los caracteres de varias celdas, use las funciones suma , junto con largo. En este ejemplo, la función LEN cuenta los caracteres de cada celda y la función suma suma los números:

= Suma ((Len (Cell1 ), Len ( cell2 ), (Len ( cell3 ))))).

Inténtelo

A continuación se muestran algunos ejemplos que muestran cómo usar la función largo.

Copie la tabla siguiente y péguela en la celda a1 de una hoja de cálculo de Excel. Arrastre la fórmula de B2 a B4 para ver la longitud del texto en todas las celdas de la columna A.

Cadenas de texto

Fórmulas

El veloz murciélago Fox.

=LARGO(A2)

El veloz murciélago Fox comía.

El veloz murciélago hindú comía feliz cardillo y kiwi.

Contar caracteres en una celda

  1. Haga clic en la celda B2.

  2. Escriba = largo (a2).

La fórmula cuenta los caracteres de la celda a2, que totales es 27, que incluye todos los espacios y el punto al final de la oración.

Nota: LARGO cuenta los espacios después del último carácter.
 

Contar caracteres en varias celdas

  1. Haga clic en la celda B2.

  2. Presione Ctrl + C para copiar la celda B2, seleccione las celdas B3 y B4 y, a continuación, presione Ctrl + V para pegar su fórmula en las celdas B3: B4.

Esto copiará la fórmula en las celdas B3 y B4, y la función contará los caracteres de cada celda (20, 27 y 45).

Contar un número total de caracteres

  1. En el libro de ejemplo, haga clic en la celda B6.

  2. En la celda, escriba =SUMA(LARGO(A2),LARGO(A3),LARGO(A4)) y presione Enter.

Esto cuenta los caracteres de cada una de las tres celdas y los suma (92).

¿Necesita más ayuda?

Ampliar sus conocimientos de Office
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×