Crear, cargar o editar una consulta en Excel (Power Query)

Crear, cargar o editar una consulta en Excel (Power Query)

Power Query ofrece varias formas de crear y cargar consultas de Power en el libro. También puede establecer la configuración de carga de consulta predeterminada en la ventana Opciones de consulta.   

Sugerencia      Para saber si los datos de una hoja de cálculo tienen la forma de Power Query, seleccione una celda de datos y, si aparece la pestaña de la cinta de opciones Contexto de consulta, los datos se cargaron desde Power Query. 

Seleccionar una celda de una consulta para mostrar la pestaña Consulta

Saber en qué entorno se encuentra Power Query está bien integrado en la interfaz de usuario de Excel, especialmente cuando importa datos, trabaja con conexiones y edita tablas dinámicas, tablas de Excel y rangos con nombre. Para evitar confusiones, es importante saber en qué entorno se encuentra actualmente, Excel o Power Query, en cualquier momento.

La conocida hoja de cálculo de Excel, la cinta de opciones y la cuadrícula

La cinta de opciones del Editor de Power Query y la vista previa de datos 

Una hoja de cálculo típica de Excel Una vista típica del Editor de Power Query

Por ejemplo, manipular datos en una hoja de cálculo de Excel es fundamentalmente diferente de Power Query. Además, los datos conectados que ve en una hoja de cálculo de Excel pueden o no tener Power Query trabajando en segundo plano para dar forma a los datos. Esto solo se produce cuando se cargan los datos en una hoja de cálculo o en un modelo de datos desde Power Query.

Cambiar el nombre de las pestañas de la hoja de cálculo    Es una buena idea cambiar el nombre de las pestañas de la hoja de cálculo de forma significativa, especialmente si tiene una gran cantidad de ellas. Es especialmente importante aclarar la diferencia entre una hoja de cálculo de datos y una hoja de cálculo cargada desde el Editor de Power Query. Incluso si solo tiene dos hojas de cálculo, una con una tabla de Excel, denominada Hoja1,y la otra una consulta creada importando esa tabla de Excel, denominada Tabla1,es fácil confundirse. Siempre es una buena práctica cambiar los nombres predeterminados de las pestañas de hoja de cálculo a nombres que le den más sentido. Por ejemplo, cambie el nombre de Hoja1 a Tabla de datos y Tabla1 a Tabla consulta. Ahora está claro qué pestaña tiene los datos y qué pestaña tiene la consulta.

Puede crear una consulta a partir de datos importados o crear una consulta en blanco.

Crear una consulta a partir de datos importados

Esta es la forma más común de crear una consulta.

  1. Importar algunos datos. Para obtener más información, vea Importar datos de orígenes de datos externos.

  2. Seleccione una celda de los datos y, a continuación, seleccione Consulta > Editar.

Crear una consulta en blanco

Es posible que quiera empezar desde cero. Puede realizar esto de dos maneras:

  • Seleccione Datos> Obtener datos > de otros orígenes > consulta en blanco.

  • Seleccione Datos > Obtener datos > Iniciar el Editor de Power Query.

En este punto, puede agregar manualmente pasos y fórmulas si conoce bien el idioma de la fórmula M de Power Query.

O bien, puede seleccionar Inicio y, a continuación, seleccionar un comando en el grupo Nueva consulta. Siga uno de estos procedimientos:

  • Seleccione Nuevo origen para agregar un origen de datos. Este comando es igual que el comando Obtener > datos de la cinta de Excel.

  • Seleccione Orígenes recientes para seleccionar de un origen de datos con el que ha estado trabajando. Este comando es igual que el comando Data > Recent Sources de la cinta de Excel.

  • Seleccione Escribir datos para escribir manualmente los datos. Puede elegir este comando para probar el Editor de Power Query independientemente de un origen de datos externo.

Suponiendo que la consulta sea válida y no tenga errores, puede cargarla de nuevo en una hoja de cálculo o en un modelo de datos.

Cargar una consulta desde el Editor de Power Query

En el Editor de Power Query, realice una de las siguientes acciones:

  • Para cargar en una hoja de cálculo, seleccione Inicio > Cerrar & cargar > cerrar& cargar.

  • Para cargar en un modelo de datos, seleccione Inicio > Cerrar & Cargar > cerrar& Cargar en.

    En el cuadro de diálogo Importar datos, seleccione Agregar estos datos al modelo de datos.

Sugerencia   A veces, el comando Cargar a está atenuado o deshabilitado. Esto puede ocurrir la primera vez que cree una consulta en un libro. Si esto ocurre, seleccione Cerrar & Cargar, en la nueva hoja de cálculo, seleccione Consultas de datos > & Pestaña Consultas de Connections >, haga clic con el botón derecho en la consulta y, a continuación, seleccione Cargaren . Como alternativa, en la cinta editor de Power Query, seleccione Consulta > Cargar en.

Cargar una consulta desde el panel Consultas y conexiones 

En Excel, es posible que desee cargar una consulta en otra hoja de cálculo o modelo de datos.

  1. En Excel, seleccione Datos > consultas & Connectionsy, a continuación, seleccione la pestaña Consultas.

  2. En la lista de consultas, busque la consulta, haga clic con el botón derecho en la consulta y, a continuación, seleccione Cargar en. Aparecerá el cuadro de diálogo Importar datos.

  3. Decida cómo desea importar los datos y, a continuación, seleccione Aceptar. Para obtener más información sobre el uso de este cuadro de diálogo, seleccione el signo de interrogación (?).

Hay varias formas de editar una consulta cargada en una hoja de cálculo.

Editar una consulta a partir de datos en una hoja de cálculo de Excel

  • Para editar una consulta, busque una cargada previamente desde el Editor de Power Query, seleccione una celda de los datos y, a continuación, seleccione Consulta> Editar.

Editar una consulta desde el panel Consultas & Connections

Es posible que el panel Consultas & Connections sea más cómodo de usar cuando tiene muchas consultas en un libro y desea encontrar rápidamente una.

  1. En Excel, seleccione Datos > consultas & Connectionsy, a continuación, seleccione la pestaña Consultas.

  2. En la lista de consultas, busque la consulta, haga clic con el botón derecho en la consulta y, después, seleccione Editar.

Editar una consulta desde el cuadro de diálogo Propiedades de la consulta

  • En Excel, seleccione Datos> Datos & pestaña Conexiones > Consultas, haga clic con el botón derecho en la consulta y seleccione Propiedades,seleccione la pestaña Definición en el cuadro de diálogo Propiedades y, a continuación, seleccione Editar consulta.

Sugerencia    Si se encuentra en una hoja de cálculo con una consulta, seleccione Propiedades de >, seleccione la pestaña Definición en el cuadro de diálogo Propiedades y, a continuación, seleccione Editar consulta. 

Un modelo de datos normalmente contiene varias tablas organizadas en una relación. Para cargar una consulta en un modelo de datos, use el comando Cargar a para mostrar el cuadro de diálogo Importar datos y, después, active la casilla Agregar estos datos al modo dedatos l. Para obtener más información sobre los modelos de datos, vea Averiguar qué orígenes de datos se usan en un modelo de datos de libro,Crear un modelo de datos en Excely Usar varias tablas para crear una tabla dinámica.

  1. Para abrir el modelo de datos, seleccione Power Pivot > Administrar.

  2. En la parte inferior de la ventana de Power Pivot, seleccione la pestaña hoja de cálculo de la tabla que desee.

    Confirme que se muestra la tabla correcta. Un modelo de datos puede tener muchas tablas.

  3. Anote el nombre de la tabla.

  4. Para cerrar la ventana de Power Pivot, seleccione Archivo> Cerrar. Es posible que tarde unos segundos en recuperar memoria.

  5. Seleccione Data > Connections & Properties > Pestaña Consultas, haga clic con el botón derecho en la consulta y, a continuación, seleccione Editar.

  6. Cuando termine de realizar cambios en el Editor de Power Query, seleccione Archivo > Cerrar & cargar.

Resultado

La consulta de la hoja de cálculo y la tabla del modelo de datos se actualizan.

Si observa que cargar una consulta en un modelo de datos tarda mucho más que cargarse en una hoja de cálculo, compruebe los pasos de Power Query para ver si está filtrando una columna de texto o una columna estructurada de lista con un operador Contains. Esta acción hace que Excel vuelva a enumerar todo el conjunto de datos de cada fila. Además, Excel no puede usar de forma eficaz la ejecución multiproceso. Como solución alternativa, intente usar un operador diferente, como Igual o Comienza con.

Microsoft es consciente de este problema y está en investigación.

Puede cargar una Power Query:

  • A una hoja de cálculo. En el Editor de Power Query, seleccione Inicio > Cerrar & cargar > cerrar & cargar.

  • A un modelo de datos. En el Editor de Power Query, seleccione Inicio > Cerrar & Cargar > cerrar& Cargar en.

    De forma predeterminada, Power Query carga consultas en una nueva hoja de cálculo al cargar una sola consulta y carga varias consultas al mismo tiempo en el modelo de datos.  Puede cambiar el comportamiento predeterminado de todos los libros o solo del libro actual. Al establecer estas opciones, Power Query no cambia los resultados de la consulta en la hoja de cálculo ni en los datos y anotaciones del modelo de datos.

    También puede invalidar dinámicamente la configuración predeterminada de una consulta mediante el cuadro de diálogo Importar que se muestra después de seleccionar Cerrar & Cargar en. 

Configuración global que se aplica a todos los libros

  1. En el Editor de Power Query, seleccione Opciones de> opciones de > opciones de consulta.

  2. En el cuadro de diálogo Opciones de consulta, en el lado izquierdo, en la sección GLOBAL,seleccione Carga de  datos.

  3. En la sección Configuración de carga de consulta predeterminada, haga lo siguiente:

    • Seleccione Usar la configuración de carga estándar

    • Seleccione Especificar la configuración de cargapredeterminada personalizada y, a continuación, seleccione o desactive Cargar en la hoja de cálculo o Cargar en el modelo de   datos.

Sugerencia    En la parte inferior del cuadro de diálogo, puede seleccionar Restaurar valores predeterminados para volver cómodamente a la configuración predeterminada.

Configuración del libro que solo se aplica al libro actual

  1. En el cuadro de diálogo Opciones de consulta, en el lado izquierdo, en la sección LIBRO ACTUAL, seleccione Carga de datos.

  2. Siga uno o varios de estos procedimientos:

    • En Detección de tipo, seleccione o desactive Detectar tipos de columna y encabezados para orígenes no estructurados.

      El comportamiento predeterminado es detectarlos. Desactive esta opción si prefiere dar forma a los datos usted mismo.

    • En Relaciones ,seleccione o desactive Crear relaciones entre tablas al agregar al modelo de datos por primera vez.

      Antes de cargar en el modelo de datos, el comportamiento predeterminado es buscar relaciones existentes entre tablas, como las claves externas en una base de datos relacional e importarlas con los datos. Desactive esta opción si prefiere hacerlo por su cuenta.

    • En Relaciones ,seleccione o desactive Actualizar relaciones al actualizar consultas cargadas en el modelo de datos.

      El comportamiento predeterminado es no actualizar relaciones. Al actualizar consultas que ya están cargadas en el modelo de datos, Power Query busca las relaciones existentes entre tablas como las claves externas en una base de datos relacional y las actualiza. Esto podría quitar las relaciones creadas manualmente después de importar los datos o introducir nuevas relaciones. Sin embargo, si quiere hacerlo, seleccione la opción.

    • En Datos de fondo, seleccione o desactive Permitir que las vistas previas de datos se descarguen en segundo plano.

      El comportamiento predeterminado es descargar las vistas previas de datos en segundo plano. Desactive esta opción si desea ver todos los datos inmediatamente.

Vea también

Ayuda de Power Query para Excel

Administrar consultas en Excel

¿Necesita más ayuda?

Ampliar sus conocimientos de Office
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×