Crear y ejecutar una consulta de eliminación

Crear y ejecutar una consulta de eliminación

Cuando desea eliminar rápidamente una gran cantidad de datos o eliminar un conjunto de datos de forma periódica en una base de datos de escritorio de Access, una consulta de eliminación o actualización puede ser útil porque las consultas hacen posible especificar criterios para buscar y eliminar rápidamente los datos. Usar una consulta también puede ser un timesaver porque puede volver a usar una consulta guardada.

Nota: Antes eliminar ningún dato o ejecutar una consulta de eliminación, asegúrese de que tiene una copia de seguridad de la base de datos de escritorio de Access.

Si solo desea eliminar algunos registros, no necesita una consulta. Solo tiene que abrir la tabla en la vista Hoja de datos, seleccionar los campos (columnas) o registros (filas) que desea eliminar y, a continuación, presione SUPRIMIR.

Importante: La información de este artículo está pensada para usarse solo con bases de datos de escritorio. No puede usar las consultas de eliminación o actualización en las aplicaciones web de Access.

En este artí­culo

Elegir un tipo de consulta

Puede usar una consulta de actualización o una consulta de eliminación para eliminar datos de la base de datos. Seleccione una consulta en función de los detalles de la tabla siguiente:

Tipo de consulta

Cuándo usarla

Resultados

Usar una consulta de eliminación

Para quitar registros completos (filas) de una tabla o de dos tablas relacionadas simultáneamente.

Nota: Si los registros residen en el lado "uno" de una relación uno a varios, es posible que tenga que cambiar la relación antes de ejecutar la consulta de eliminación. Vea la sección sobre cómo eliminar datos de tablas relacionadas.

Eliminar consultas quita todos los datos de cada campo, incluido el valor de clave que hace que un registro sea único

Usar una consulta de actualización

Para eliminar valores de campo individuales de una tabla.

Facilita la eliminación de valores actualizando los valores existentes a un valor nulo (es decir, sin datos) o a una cadena de longitud cero (un par de comillas dobles sin espacio entre ellos).

Volver al principio

Cosas que debe comprobar antes de usar una consulta para eliminar los datos

  • Asegúrese de que el archivo no es un archivo de solo lectura:

    1. Haga clic con el botón derecho en Inicio y haga clic en Abrir el Explorador de Windows.

    2. Haga clic con el botón derecho en el archivo de base de datos y haga clic en Propiedades.

    3. Vea si el atributo de solo lectura está seleccionado.

  • Compruebe que tiene los permisos necesarios para eliminar registros de la base de datos. Si no está seguro, póngase en contacto con el administrador del sistema o con el diseñador de bases de datos.

  • Asegúrese de que ha habilitado contenido en la base de datos. De forma predeterminada, Access bloquea todas las consultas de acción (consultas de eliminación, actualización y creación de tablas) a menos que primero confíe en la base de datos. Para obtener información sobre cómo confiar en una base de datos, vea la sección Detener el modo deshabilitado de bloquear una consulta.

  • Pida a otros usuarios de la base de datos que cierren todas las tablas, formularios, consultas e informes que usan los datos que desea eliminar. Esto ayuda a evitar infracciones de bloqueo.

  • Antes de editar o eliminar registros, hacer una copia de seguridad de la base de datos es una buena idea en caso de que quiera invertir los cambios.

Sugerencia: Si un gran número de usuarios se conectan a la base de datos, es posible que tenga que cerrar la base de datos y volver a abrirla en modo exclusivo.

Para abrir una base de datos en modo exclusivo

  1. Haga clic en La pestaña Archivo > Abrir.

  2. Busque y seleccione la base de datos, haga clic en la flecha situada junto al botón Abrir y, a continuación, haga clic en Abrir exclusivo.

    Abrir un archivo en modo exclusivo

Hacer una copia de seguridad de la base de datos

  1. Haga clic en la pestaña Archivo y seleccione Guardar como.

  2. Haga clic en Guardar base de datos como, haga clic en Copia de seguridad de la base de datos. Access cierra el archivo original, crea una copia de seguridad y, a continuación, vuelve a abrir el archivo original.

  3. Haga clic en Guardar como, especifique un nombre y una ubicación para la copia de seguridad y haga clic en Guardar.

Nota: Si usa una base de datos de solo lectura o creada en la versión anterior de Access, es posible que reciba un mensaje de que no es posible crear una copia de seguridad de la base de datos.

Para revertir a una copia de seguridad, cierre el archivo original y cambie su nombre, de modo que se pueda usar el nombre de la versión original para la copia de seguridad. Asigne el nombre de la versión original a la copia de seguridad y, después, ábrala con el nombre cambiado en Access.

Usar una consulta de eliminación

Para crear una consulta de eliminación, haga clic en la pestaña Crear, en el grupo Consultas, haga clic en Diseño de consulta. Haga doble clic en cada tabla de la que desea eliminar registros y, a continuación, haga clic en Cerrar.

La tabla aparece como una ventana en la sección superior de la cuadrícula de diseño de la consulta. En la lista de campos, haga doble clic en el asterisco (*) para agregar todos los campos de la tabla a la cuadrícula de diseño.

Usar un criterio específico en una consulta de eliminación

Importante: Use criterios para devolver solo los registros que desea eliminar. En caso contrario, la consulta de eliminación quita todos los registros de la tabla.

Haga doble clic en el campo que desea especificar como criterios de eliminación, escriba uno de los criterios en la fila Criterios del diseñador de consultas y desactive la casilla Mostrar para cada campo de criterios.

Un ejemplo de cuándo puede querer usar esta opción: Supongamos que desea quitar todos los pedidos pendientes de un cliente. Para buscar solo esos registros, agregaría los campos Id. de cliente y Fecha de pedido a la cuadrícula de diseño de la consulta y, a continuación, escriba el número de id. del cliente y la fecha en la que los pedidos de ese cliente se convirtieron en no válidos.

  1. En la pestaña Diseño, haga clic en Vista > Vista Hoja de datos.

  2. Compruebe que la consulta devuelve los registros que desea eliminar y, después, presione CTRL+S para guardar la consulta.

  3. Para ejecutar la consulta, haga doble clic en la consulta en el panel de navegación.

Principio de página

Usar una consulta de actualización

Nota: No puede usar la opción de consulta de actualización en una aplicación web de Access.

En esta sección se explica cómo usar una consulta de actualización para eliminar campos individuales de tablas. Recuerde que al ejecutar una consulta de actualización para eliminar datos, los valores existentes se cambiarán a NULL o a una cadena de longitud cero (un par de comillas dobles sin espacio entre medias), dependiendo de los criterios que especifique.

  1. Haga clic en la pestaña Crear y, en el grupo Consultas, haga clic en Diseño de consulta.

  2. Seleccione la tabla que tiene los datos que desea eliminar (si la tabla está relacionada, seleccione la tabla en el lado "uno" de la relación), haga clic en Agregar y, a continuación, haga clic en Cerrar.

    La tabla aparece como una ventana en la sección superior de la cuadrícula de diseño de la consulta. La ventana enumera todos los campos de la tabla seleccionada.

  3. Haga doble clic en el asterisco (*) para agregar todos los campos de la tabla a la cuadrícula de diseño. Al agregar todos los campos de tabla, la consulta de eliminación puede quitar registros (filas) completos de la tabla.

    Opcionalmente, puede escribir criterios para uno o varios campos en la fila Criterios del diseñador y, después, desmarque la casilla Mostrar para cada campo de criterios. Para obtener más información sobre el uso de criterios, vea la tabla Criterios de ejemplo para consultas de selección.

    Nota: Use criterios para devolver solo los registros que desea cambiar. En caso contrario, la consulta de actualización establece en NULL cada registro de cada uno de los campos de la consulta.

  4. En el grupo Resultados de la pestaña Diseño, haga clic en Ver y, después, en Vista Hoja de datos.

  5. Compruebe que la consulta devuelve los registros que desea establecer en NULL o una cadena de longitud cero (un par de comillas dobles sin espacio entre ellos ("").

  6. Según sea necesario, repita los pasos 3 a 5 y cambie los campos o criterios hasta que la consulta devuelva solo los datos que desea eliminar y, después, presione CTRL+S para guardar la consulta.

  7. Para ejecutar la consulta, haga doble clic en la consulta en el panel de navegación.

Volver al principio

Información adicional

Eliminar datos de tablas relacionadas

Si desea eliminar datos de varias tablas relacionadas, debe habilitar las opciones Integridad referencial y Eliminar en cascada registros relacionados para cada relación. Esto permite a la consulta eliminar datos de las tablas de los lados "uno" y "varios" de la relación. Preparar la eliminación de datos relacionados requiere la verificación de lo siguiente:

  • Determine qué registros residen en el lado "uno" de la relación y cuáles se encuentran en el lado "varios".

  • Si necesita eliminar registros en el lado "uno" de la relación y los registros relacionados en el lado "varios", habilitará un conjunto de reglas denominado Integridad referencial y habilitará las eliminaciones en cascada. Los pasos de esta sección explican la integridad referencial y cómo realizar ambas tareas.

  • Si necesita eliminar registros solo en el lado "uno" de la relación, primero elimine esa relación y, después, elimine los datos.

Si necesita quitar datos solo en el lado "varios" de la relación, puede crear y ejecutar la consulta de eliminación sin tener que cambiar la relación.

Para averiguar qué registros residen en los lados "uno" y "varios" de una relación, en la pestaña Herramientas de base de datos, en el grupo Relaciones, haga clic en Relaciones. La pestaña Relaciones muestra las tablas de la base de datos y las relaciones. Cada relación se representa como una línea que conecta tablas entre campos.

En la siguiente ilustración se muestra una relación típica. La mayoría, si no todas, de las relaciones de una base de datos tienen un lado "uno" y un lado "varios". El diagrama de relaciones indica el lado "uno" con el numeral (1) y el lado "varios" con el símbolo infinito ().

Relación entre dos tablas

Al eliminar registros en el lado "uno" de la relación, también se eliminan todos los registros relacionados en el lado "varios" de la relación. Sin embargo, al eliminar registros en el lado "varios" de una relación, normalmente no se eliminan registros en el lado "uno".

Además, Access aplica automáticamente un conjunto de reglas denominadas integridad referencial. Estas reglas garantizan que las claves externas de una base de datos contengan los valores correctos. Una clave externa es una columna cuyos valores coinciden con los valores de la columna de clave principal de otra tabla.

Editar la relación

Siga estos pasos solo cuando necesite eliminar datos en los lados "uno" y "varios" de una relación.

  1. En la pestaña Herramientas de base de datos, en el grupo Relaciones, haga clic en Relaciones.

  2. Haga clic con el botón derecho en la relación (la línea) que conecta las tablas involucradas en la operación de eliminación y, a continuación, haga clic en Editar relación en el menú contextual.

  3. En el cuadro de diálogo Editar relaciones, asegúrese de que la casilla Exigir integridad referencial está activada.

  4. Active la casilla Eliminar en cascada los registros relacionados.

    Nota: Hasta que vuelva a deshabilitar esta propiedad, al eliminar un registro en el lado "uno" de la relación, se eliminarán todos los registros relacionados en el lado "varios" de la relación.

  5. Haga clic en Aceptar,cierre el panel Relaciones y, a continuación, vaya al siguiente conjunto de pasos.

Eliminar una relación

  1. Si aún no lo ha hecho, abra el panel Relaciones.

  2. En la pestaña Herramientas de base de datos, en el grupo Relaciones, haga clic en Relaciones.

    Anote los campos implicados en la relación para que pueda restaurar la relación después de eliminar los datos.

  3. Haga clic con el botón derecho en la relación (la línea) que conecta las tablas involucradas en la operación de eliminación y, a continuación, haga clic en Eliminar en el menú contextual.

Nota: Para restaurar la relación, siga los pasos anteriores para abrir el panel Relaciones y, después, arrastre el campo de clave principal de la tabla "uno" y suéltelo en el campo de clave externa de la tabla "varios". Aparecerá el cuadro de diálogo Editar relación. Si la antigua relación exigió integridad referencial, seleccione Exigir integridad referencialy, a continuación, haga clic en Crear. En caso contrario, haga clic en Crear.

Volver al principio

Criterios de ejemplo para consultas de selección

En la tabla siguiente se enumeran algunos criterios de ejemplo que puede usar en consultas de selección cuando desea asegurarse de eliminar solo los datos que desea eliminar. Algunos de estos ejemplos usan caracteres comodín.

Criterios

Efecto

> 234

Devuelve todos los números mayores que 234. Para buscar todos los números menores que 234, use < 234.

>= "Cajhen"

Devuelve todos los registros desde Díaz hasta el final del alfabeto.

Entre #2/2/2010# Y #12/1/2010 #

Devuelve fechas del 2-feb-2010 al 1-dic-2010 (ANSI-89). Si la base de datos usa los caracteres comodín ANSI-92, use comillas simples (') en vez de signos de almohadilla (#). Ejemplo: Entre "2/2/2010" y "12/1/2010".

Sin "Alemania"

Encuentra todos los registros en los que el contenido exacto del campo no es exactamente igual a "Alemania". El criterio devolverá registros que contienen caracteres además de "Alemania," como "Alemania (euro)" o "Europa (Alemania)".

Sin "T*"

Busca todos los registros, salvo los que empiezan por T. Si la base de datos usa los caracteres comodín ANSI-92, use el signo de porcentaje (%) en vez del asterisco (*).

Sin "*t"

Busca todos los registros que no terminen en t. Si la base de datos utiliza el juego de caracteres comodín ANSI-92, use el signo de porcentaje (%) en vez del asterisco (*).

En(Canadá,Reino Unido)

En una lista, busca todos los registros que contengan Canadá o Reino Unido.

Como "[A-D]*"

En un campo Texto, busca todos los registros que comienzan con las letras A a D. Si la base de datos usa el juego de caracteres comodín ANSI-92, use el signo de porcentaje (%) en lugar del asterisco (*).

Como "*ar*"

Busca todos los registros que incluyan la secuencia de letras "ar". Si la base de datos usa el juego de caracteres comodín ANSI-92, use el signo de porcentaje (%) en vez del asterisco (*).

Como "Casa Dewe?"

Busca todos los registros que empiecen por "Casa" y contengan una segunda cadena de 5 letras, cuyas cuatro primeras letras son "Dewe" y cuya última letra se desconoce. Si la base de datos usa el juego de caracteres comodín ANSI-92, use el carácter de subrayado (_) en vez del signo de interrogación (?).

#2/2/2010 #

Busca todos los registros del 2 de febrero de 2010. Si la base de datos usa el juego de caracteres comodín ANSI-92, rodee la fecha entre comillas simples en lugar de signos de libra ('2/2/2010').

< Fecha() - 30

Usa la función Fecha para devolver todas las fechas con una antigüedad de más de 30 días.

Fecha()

Usa la función Fecha para devolver todos los registros que contienen la fecha actual.

Entre Fecha() Y AgregFecha("M", 3, Fecha())

Usa las funciones Fecha y Agregar fecha para devolver todos los registros entre la fecha actual y tres meses a partir de la fecha actual.

Es Nulo

Devuelve todos los registros que contengan un valor nulo (en blanco o sin definir).

No es Nulo

Devuelve todos los registros que contienen cualquier valor (que no son nulos).

""

Devuelve todos los registros que contienen una cadena de longitud cero. Use cadenas de longitud cero cuando necesite agregar un valor a un campo obligatorio, pero aún no sabe cuál es el valor real. Por ejemplo, un campo puede requerir un número de fax, pero puede que algunos clientes no tengan fax. En ese caso, en lugar de escribir un número, escriba un par de comillas dobles sin espacio entre ellas ("").

Volver al principio

Sugerencias para la solución de problemas

¿Por qué aparece este mensaje de error y cómo se soluciona?

Si crea una consulta de eliminación con varias tablas y la propiedad Registros únicos de la consulta se establece en No,Access muestra el mensaje de error; No se pudo eliminar de las tablas especificadas al ejecutar la consulta.

Para solucionar este problema, establezca el valor de la propiedad Registros únicos de la consulta en .

  1. Abra la consulta de eliminación en la vista Diseño.

  2. Si la hoja de propiedades de la consulta no está abierta, presione F4 para abrirla.

  3. Haga clic en el diseñador de consultas para mostrar las propiedades de la consulta (en vez de las propiedades de campo).

  4. En la hoja de propiedades de la consulta, busque la propiedad Registros únicos y establezca su valor en .

Evitar que el modo deshabilitado bloquee una consulta

De forma predeterminada, si abre una base de datos de escritorio en la que no ha elegido confiar o que no reside en una ubicación de confianza, Access impide que se ejecuten todas las consultas de acción.

Si trata de ejecutar una consulta de acción y parece que no ocurre nada, compruebe si en la barra de estado de Access aparece el siguiente mensaje:

El modo deshabilitado ha bloqueado la acción o el evento.

Cuando vea ese mensaje, haga lo siguiente para habilitar el contenido bloqueado:

  • En la barra de mensajes de advertencia de seguridad, haga clic en Habilitarcontenido y vuelva a ejecutar la consulta.

Volver al principio

¿Necesita más ayuda?

Ampliar sus conocimientos de Office
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×