Eliminación de registros duplicados con una consulta

Eliminación de registros duplicados con una consulta

Los datos duplicados a menudo se arrastran cuando varios usuarios agregan datos a la base de datos al mismo tiempo o si la base de datos no estaba diseñada para buscar duplicados. Es más fácil usar una consulta cuando desea eliminar una gran cantidad de datos duplicados. El primer paso es buscar registros duplicados con una consulta en la base de datos.

Nota: Los métodos descritos en este artículo no se aplican a las aplicaciones web de Access.

Antes de eliminar los datos

No puede deshacer eliminaciones de datos, así que asegúrese de que la base de datos está lista antes de intentar eliminar registros duplicados:

  • Asegúrese de que el archivo no es de solo lectura.

  • Si comparte la base de datos con otros usuarios, pídales que cierren los objetos con los que desea trabajar para evitar posibles conflictos de datos.

  • Si tiene permisos para abrir la base de datos en modo exclusivo: haga clic en Archivo >Abrir y seleccione la base de datos. Haga clic en la flecha situada junto a Abrir y haga clic en Abrir exclusivo.

  • Lo más importante es que recuerde hacer una copia de seguridad de la base de datos. La única forma de recuperar registros eliminados es restaurarlos a partir de una copia de seguridad. Una operación de eliminación también puede eliminar registros en tablas relacionadas.

Nota:  Para restaurar desde una copia de seguridad, cierre y cambie el nombre del archivo original para que la copia de seguridad pueda usar el nombre de la versión original. Asigne el nombre de la versión original a la copia de seguridad y ábrala en Access.

Crear y ejecutar una consulta de eliminación

  1. Haga clic en la pestaña Crear > de consulta y haga doble clic en la tabla desde la que desea eliminar registros.

  2. Haga doble clic en el asterisco (*) para agregar todos los campos de tabla al diseñador de consultas.

  3. Agregue los campos que usará para identificar los registros para su eliminación. Por ejemplo, supongamos que un cliente se va de la empresa y necesita eliminar todos los pedidos pendientes para ese cliente. Para buscar solo esos registros, puede agregar los campos Id. de cliente y Fecha de pedido a la cuadrícula de diseño.

  4. También puede agregar criterios en la fila Criterios. Por ejemplo, puede agregar el Id. de cliente del cliente que salió de la empresa y la fecha después de la cual los pedidos de ese cliente no son válidos.

  5. Desactive la casilla Mostrar para cada campo de criterios.

  6. En la pestaña Diseño, haga clic en Ejecutar. Compruebe que la consulta devuelve los registros que desea eliminar.

  7. Haga clic en Vista Diseño y, en la pestaña Diseño, haga clic en Eliminar. Access cambia la consulta de selección a una consulta de eliminación, oculta la fila Mostrar en la sección inferior de la cuadrícula de diseño y agrega la fila Eliminar.

  8. Una comprobación más antes de ejecutar la consulta de eliminación: Asegúrese de que la fila Eliminar de la columna * (todos los campos) muestra Desde y Dónde debería aparecer en cualquiera de las columnas de criterios.

  9. En la pestaña Diseño, haga clic en Ejecutar > .

Para obtener más información, vea Comparar dos tablas y buscar registros sin coincidencias.

Volver al principio

¿Necesita más ayuda?

Ampliar sus conocimientos de Office
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×