Esquematizar (agrupar) datos en una hoja de cálculo

Si tiene una lista de datos que desea agrupar y resumir, puede crear un esquema de hasta ocho niveles. Cada nivel interno, que está representado por un número superior de símbolos del esquema, muestra datos de detalle del nivel externo anterior, representado por un número inferior de símbolos de esquema. Use un esquema para mostrar rápidamente filas o columnas de resumen, o bien para mostrar los datos de detalle de cada grupo. Puede crear un esquema de filas (como se ilustra en el ejemplo siguiente), un esquema de columnas o un esquema de filas y columnas.

Datos con un esquema de tres niveles

1. Para mostrar filas para un nivel, haga clic en el símbolo uno dos tres esquema.

2.  El nivel 1 contiene las ventas totales de todas las filas de detalle.

3.  El nivel 2 contiene las ventas totales para cada mes en cada región.

4. El nivel 3 contiene filas de detalle, en este caso, las filas 17 a 20.

5. Para expandir o contraer datos en el esquema, haga clic en los símbolos de esquema más y menos , o presione ALT+MAYÚS+= para expandir y ALT+MAYÚS+- para contraer.

  1. Asegúrese de que cada columna de los datos que desea esquematear tiene una etiqueta en la primera fila (por ejemplo, Región), contiene datos similares en cada columna y que el rango que desea esquema no tiene filas ni columnas en blanco.

  2. Si lo desea, las filas de detalles agrupadas pueden tener una fila de resumen correspondiente: un subtotal. Para crear estos elementos, realice una de las siguientes acciones:

    • Insertar filas de resumen utilizando el comando Subtotal    

      Use el comando Subtotal que inserta la función SUBTOTAL inmediatamente debajo o encima de cada grupo de filas de detalle y crea automáticamente el esquema. Para más información sobre la función SUBTOTAL, vea Función SUBTOTAL.

    • Insertar sus propias filas de resumen    

      Inserte sus propias filas de resumen, con las fórmulas, inmediatamente encima o debajo de cada grupo de filas de detalle. Por ejemplo, debajo (o encima) de las filas de datos de ventas de marzo y abril, use SUMA (función SUMA) para obtener el subtotal de las ventas para esos meses. En la tabla que aparece más adelante en este tema se muestra un ejemplo.

  3. De forma predeterminada, Excel busca filas de resumen debajo de los detalles que resumen, pero es posible crearlas encima de las filas de detalle. Si creó las filas de resumen debajo de los detalles, vaya al paso siguiente (paso 4). Si creó las filas de resumen encima de las filas de detalle, en la pestaña Datos, en el grupo Esquema, haga clic en el selector de cuadro de diálogo.

    En el grupo Esquema, haga clic en el selector de cuadro de diálogo

    Se abrirá el cuadro de diálogo Configuración.

    Cuadro de diálogo Configuración de esquemas

    A continuación, en el cuadro de diálogo Configuración, desactive la casilla Filas de resumen debajo del detalle y, a continuación, haga clic en Aceptar.

  4. Aplique un esquema a los datos. Siga uno de los procedimientos siguientes:

    Aplicar un esquema a los datos automáticamente

    1. Seleccione una celda en el rango de celdas que desea esquematear.

    2. En el grupo Esquema de la pestaña Datos, haga clic en la flecha de Agrupar y, a continuación, haga clic en Autoesquema.

      Haga clic en la flecha situada debajo de Grupo y en Esquema automático

    Aplicar un esquema a los datos manualmente

    Importante: Cuando agrupe manualmente niveles de esquema, es mejor tener todos los datos mostrados para evitar agrupar las filas incorrectamente.

    1. Para esquematear el grupo externo (nivel 1), seleccione todas las filas que contendrá el grupo externo (es decir, las filas de detalle y, si las agregó, sus filas de resumen).

      Una selección de datos lista para crear un grupo externo

      1. La primera fila contiene etiquetas y no está seleccionada.

      2. Puesto que este es el grupo externo, seleccione todas las filas con subtotales y detalles.

      3. No seleccione el total general.

    2. En la pestaña Datos, en el grupo Esquema, haga clic en Agrupar. A continuación, en el cuadro de diálogo Grupo, haga clic en Filasy, a continuación, haga clic en Aceptar.

      Sugerencia: Si selecciona filas completas en lugar de solo las celdas, Excel agrupa automáticamente por fila: el cuadro de diálogo Grupo ni siquiera se abre.

      Haga clic en Filas y en Aceptar

      Los símbolos del esquema aparecen en la pantalla al lado del grupo.

    3. Opcionalmente, aplique un esquema a un grupo interno anidado: las filas de detalle de una sección determinada de los datos.

      Nota: Si no necesita crear ningún grupo interno, vaya al paso f, a continuación.

      Para grupo interno anidado, seleccione las filas de detalle adyacentes a la fila que contiene la fila de resumen.

      Datos seleccionados para agrupar en el nivel 2 de una jerarquía.

      1. Puede crear varios grupos en cada nivel interno. Aquí, dos secciones ya están agrupadas en el nivel 2.

      2. Esta sección está seleccionada y lista para agruparse.

      3. No seleccione la fila de resumen de los datos que está agrupando.

    4. En la pestaña Datos, en el grupo Esquema, haga clic en Agrupar.

      Haga clic en Agrupar en la pestaña Datos

      A continuación, en el cuadro de diálogo Grupo, haga clic en Filasy, a continuación, haga clic en Aceptar. Los símbolos del esquema aparecen en la pantalla al lado del grupo.

      Sugerencia: Si selecciona filas completas en lugar de solo las celdas, Excel agrupa automáticamente por fila: el cuadro de diálogo Grupo ni siquiera se abre.

    5. Siga seleccionando y agrupando filas internas hasta que haya creado todos los niveles que desee en el esquema.

    6. Si desea desagrupar filas, selecciónelas y, a continuación, en el grupo Esquema de la pestaña Datos, haga clic en Desagrupar.

      También puede desagrupar secciones del esquema sin quitar todo el nivel. Mantenga presionada la tecla MAYÚS mientras hace clic en cuadro Signo o cuadro Signo - para el grupo y, a continuación, en la pestaña Datos, en el grupo Esquema, haga clic en Desagrupar.

      Importante: Si desagrupa un esquema mientras los datos de detalle están ocultos, las filas de detalle permanecen ocultas. Para mostrar los datos, desplácese por los números de fila visibles adyacentes a las filas ocultas. A continuación, en la pestaña Inicio, en el grupo Celdas, haga clic en Formato,seleccione Ocultar & Mostrary, a continuación, haga clic en Mostrar filas.

  1. Asegúrese de que cada fila de los datos a los que desea aplicar un esquema tiene una etiqueta en la primera fila, contiene datos similares en cada columna y el rango no tiene filas ni columnas en blanco.

  2. Inserte sus propias columnas resumidas con fórmulas inmediatamente a la derecha o a la izquierda de cada grupo de columnas de detalle. La tabla mostrada en el paso 4 siguiente le muestra un ejemplo.

    Nota: Para trazar esquemas de los datos por columnas, debe tener columnas de resumen que contengan fórmulas que hagan referencias a las celdas de cada una de las columnas de detalle para dicho grupo.

  3. Si la columna de resumen está a la izquierda de las columnas de detalles, en la pestaña Datos, en el grupo Esquema, haga clic en el iniciador del cuadro de diálogo.

    En el grupo Esquema, haga clic en el selector de cuadro de diálogo

    Se abrirá el cuadro de diálogo Configuración.

    Cuadro de diálogo Configuración de esquemas

    A continuación, en el cuadro de diálogo Configuración, desactive la casilla Columnas de resumen a la derecha del detalle y haga clic en Aceptar.

  4. Para aplicar un esquema a los datos, siga uno de estos procedimientos:

    Aplicar un esquema a los datos automáticamente

    1. Seleccione una celda del rango.

    2. En el grupo Esquema de la pestaña Datos, haga clic en la flecha de Agrupar y en Autoesquema.

    Aplicar un esquema a los datos manualmente

    Importante: Cuando agrupe manualmente niveles de esquema, es mejor tener todos los datos mostrados para evitar agrupar las columnas incorrectamente.

    1. Para esquematear el grupo externo (nivel 1), seleccione todas las columnas de resumen subordinadas, así como sus datos de detalle relacionados.

      Datos organizados en columnas que se agruparán

      1. La columna A contiene etiquetas.

      2. Seleccione todas las columnas de detalles y subtotales. Tenga en cuenta que si no selecciona columnas completas, al hacer clic en Agrupar (en la pestaña Datos del grupo Esquema) se abrirá el cuadro de diálogo Grupo y le pedirá que elija Filas oColumnas.

      3. No seleccione la columna total general.

    2. En la pestaña Datos, en el grupo Esquema, haga clic en Agrupar.

      Haga clic en Agrupar en la pestaña Datos

      El símbolo de esquema aparece encima del grupo.

    3. Para esbozar un grupo interno anidado de columnas de detalle (nivel 2 o superior), seleccione las columnas de detalle adyacentes a la columna que contiene la columna de resumen.

      Datos agrupados en columnas

      1. Puede crear varios grupos en cada nivel interno. Aquí, dos secciones ya están agrupadas en el nivel 2.

      2. Estas columnas están seleccionadas y listas para agruparse. Tenga en cuenta que si no selecciona columnas completas, al hacer clic en Agrupar (en la pestaña Datos del grupo Esquema) se abrirá el cuadro de diálogo Grupo y le pedirá que elija Filas oColumnas.

      3. No seleccione la columna de resumen de los datos que está agrupando.

    4. En la pestaña Datos, en el grupo Esquema, haga clic en Agrupar.

      Haga clic en Agrupar en la pestaña Datos

      Los símbolos del esquema aparecen en la pantalla al lado del grupo.

  5. Siga seleccionando y agrupando columnas internas hasta que haya creado todos los niveles que desee en el esquema.

  6. Si desea desagrupar columnas, selecciónelas y, a continuación, en el grupo Esquema de la pestaña Datos, haga clic en Desagrupar.

En la pestaña Datos, haga clic en Desagrupar

También puede desagrupar secciones del esquema sin quitar todo el nivel. Mantenga presionada la tecla MAYÚS mientras hace clic en cuadro Signo o cuadro Signo - para el grupo y, a continuación, en la pestaña Datos, en el grupo Esquema, haga clic en Desagrupar.

Si desagrupa un esquema mientras los datos de detalle están ocultos, las columnas de detalle permanecen ocultas. Para mostrar los datos, desplácese por las letras de columna visibles adyacentes a las columnas ocultas. En el grupo Celdas de la pestaña Inicio, haga clic en Formato, elija Ocultar y mostrar y, después, haga clic en Mostrar columnas.

  1. Si no ve los símbolos de esquema uno dos tres , más y menos , vaya a Archivo > Opciones > Avanzadas y,a continuación, en la sección Mostrar opciones para esta hoja de cálculo, active la casilla Mostrar símbolos de esquema si se aplica un esquema y, a continuación, haga clic en Aceptar.

  2. Siga uno o varios de estos procedimientos:

    • Mostrar u ocultar los datos de detalle de un grupo    

      Para mostrar los datos detallados dentro de un grupo, haga clic en el botón más para el grupo o presione ALT+MAYÚS+=.

    • Para ocultar los datos de detalle de un grupo, haga clic en el botón menos para el grupo o presione ALT+MAYÚS+-.

    • Expandir o contraer todo el esquema hasta un nivel determinado    

      En el uno dos tres de esquema, haga clic en el número del nivel que desee. Los datos de detalle de los niveles inferiores se ocultan.

      Por ejemplo, si un esquema tiene cuatro niveles, puede ocultar el cuarto y mostrar los restantes haciendo clic en tres .

    • Mostrar u ocultar todos los datos de detalle del esquema    

      Para mostrar todos los datos de detalle, haga clic en el nivel más bajo de uno dos tres símbolos de esquema. Por ejemplo, si existen tres niveles, haga clic en tres .

    • Para ocultar todos los datos de detalle, haga clic en uno .

En el caso de las filas del esquema, Microsoft Excel usa estilos como NivelFila_1 y NivelFila_2. Con respecto a las columnas del esquema, Excel usa estilos como NivelCol_1 y NivelCol_2. Estos estilos emplean la negrita, la cursiva y otros formatos de texto para diferenciar las filas o columnas de resumen en los datos. Si se cambia la forma en que están definidos estos estilos, se pueden aplicar distintos formatos de texto y celda para personalizar el aspecto del esquema. Puede aplicar un estilo a un esquema al crear el esquema o después de crearlo.

Realice uno o varios de los siguientes procedimientos:

Aplicar automáticamente un estilo a nuevas filas o columnas de resumen    

  1. En la pestaña Datos, en el grupo Esquema, haga clic en el selector de cuadro de diálogo.

    En el grupo Esquema, haga clic en el selector de cuadro de diálogo

    Se abrirá el cuadro de diálogo Configuración.

    Cuadro de diálogo Configuración de esquemas

  2. Active la casilla de verificación Estilos automáticos.

Aplicar un estilo a una columna o fila resumen existente    

  1. Seleccione las celdas a las que desea aplicar un estilo.

  2. En la pestaña Datos, en el grupo Esquema, haga clic en el selector de cuadro de diálogo.

    En el grupo Esquema, haga clic en el selector de cuadro de diálogo

    Se abrirá el cuadro de diálogo Configuración.

    Cuadro de diálogo Configuración de esquemas

  3. Active la casilla Estilos automáticos y, a continuación, haga clic en Aplicar estilos.

    Cuadro de diálogo Configuración con estilos automáticos seleccionados

Asimismo, puede usar los formatos automáticos para dar formato a los datos esquematizados.

  1. Si no ve los símbolos de esquema uno dos tres , más y menos , vaya a Opciones de archivo > >Avanzadasy, a continuación, en la sección Mostrar opciones para esta hoja de cálculo, active la casilla Mostrar símbolos de esquema si se aplica un esquema.

  2. Use los símbolos de esquema uno dos tres , menos y más para ocultar los datos de detalle que no desea copiar.

    Para más información, vea la sección, Mostrar u ocultar datos de esquemas.

  3. Seleccione el rango de filas de resumen.

  4. En la pestaña Inicio, en el grupo Modificar, haga clic en Buscar y seleccionar y, a continuación, haga clic en Ir a.

    Haga clic en Buscar & Seleccionar y, después, haga clic en Ir a

  5. Haga clic en Ir a Especial.

  6. Haga clic en Solo celdas visibles.

  7. Haga clic en Aceptar y, a continuación, copie los datos.

Nota: No se eliminan los datos al ocultar o quitar un esquema.

Ocultar un esquema

  • Vaya aOpciones > archivo > Avanzadasy, a continuación, en la sección Mostrar opciones de esta hoja de cálculo, desactive la casilla Mostrar símbolos de esquema si se aplica un esquema.

Quitar un esquema

  1. Haga clic en la hoja de cálculo.

  2. En el grupo Esquema de la pestaña Datos, haga clic en Desagrupar y en Borrar esquema.

    Haga clic en Desagrupar y en Borrar esquema

    Importante: Si quita un esquema mientras los datos de detalle están ocultos, las columnas o filas de detalle permanecen ocultas. Para mostrar los datos, desplácese por los números de fila o letras de columna visibles adyacentes a las columnas o filas ocultas. En el grupo Celdas de la pestaña Inicio, haga clic en Formato, elija Ocultar y mostrar y, a continuación, haga clic en Mostrar filas o en Mostrar columnas.

Supongamos que desea crear un informe resumido de los datos que solo muestra los totales acompañados de un gráfico de dichos totales. En general, puede hacer lo siguiente:

  1. Crear un informe de resumen

    1. Aplicar un esquema a los datos.

      Para obtener más información, vea las secciones, Crear un esquema de filas o Crear un esquema de columnas.

    2. Oculte el detalle haciendo clic en los símbolos de esquema uno dos tres , más y menos para mostrar solo los totales como se muestra en el siguiente ejemplo de esquema de fila:

      Lista esquematizada que muestra solo las filas de totales

    3. Para más información, vea la sección, Mostrar u ocultar datos de esquemas.

  2. Gráfico del informe de resumen

    1. Seleccione los datos de resumen que desea representar.

      Por ejemplo, para trazar solo los totales de Buchanan y Davolio, pero no los totales general, seleccione las celdas A1 a C19 como se muestra en el ejemplo anterior.

    2. Haga clic en Insertar > gráficos > gráficosrecomendados y, a continuación, haga clic en la pestaña Todos los gráficos y elija el tipo de gráfico.

      Cuadro de diálogo Insertar gráfico

      Por ejemplo, si elige la opción Columna agrupada, el gráfico tendría este aspecto:

      Gráfico creado a partir de datos de subtotales

      Si muestra u oculta los detalles de la lista esquematizada de datos, el gráfico también se actualiza para mostrar u ocultar los datos.

Puede agrupar filas y columnas (o esquema) en Excel para la Web.

Nota: Aunque puede agregar filas o columnas de resumen a los datos (mediante funciones como SUMA o SUBTOTAL), no puede aplicar estilos ni establecer una posición para filas y columnas de resumen en Excel para la Web.

Crear un esquema de filas o columnas

Esquema de filas en Excel Online

Esquema de columnas en Excel Online

Esquema de filas en Excel Online

  1. La primera columna contiene etiquetas.

  2. Las filas de detalle y las filas de resumen se agrupan en el esquema.

  3. El total general no se agrupa en el esquema.

Esquema de columnas en Excel Online

  1. La primera fila contiene etiquetas.

  2. Las columnas de detalle y las columnas de resumen se agrupan en el esquema.

  3. El total general no se agrupa en el esquema.

  1. Asegúrese de que cada columna (o fila) de los datos que desea esquematear tenga una etiqueta en la primera fila (o columna), que contenga datos similares en cada columna (o fila) y que el rango no tenga filas o columnas en blanco.

  2. Seleccione los datos (incluidas las filas o columnas de resumen).

  3. En la pestaña Datos, en el grupo Esquema, haga clic en Agrupar > filas de grupo o Columnas de grupo.

  4. Opcionalmente, si desea esquematear un grupo interno anidado, seleccione las filas o columnas dentro del rango de datos esquemateados y repita el paso 3.

  5. Continúe seleccionando y agrupando filas o columnas internas hasta que haya creado todos los niveles que desee en el esquema.

Desagrupar filas o columnas

  • Para desagrupar, seleccione las filas o columnas y, a continuación, en la pestaña Datos, en el grupo Esquema, haga clic en Desagrupar y seleccione Desagrupar filas o Desagrupar columnas.

Mostrar u ocultar datos de esquemas

Siga uno o varios de estos procedimientos:

Mostrar u ocultar los datos de detalle de un grupo    

  • Para mostrar los datos de detalle dentro de un grupo, haga clic en la más para el grupo o presione ALT+MAYÚS+=.

  • Para ocultar los datos detallados de un grupo, haga clic en la menos para el grupo o presione ALT+MAYÚS+-.

Expandir o contraer todo el esquema hasta un nivel determinado    

  • En el uno dos tres de esquema, haga clic en el número del nivel que desee. Los datos de detalle de los niveles inferiores se ocultan.

  • Por ejemplo, si un esquema tiene cuatro niveles, puede ocultar el cuarto y mostrar los restantes haciendo clic en tres .

Mostrar u ocultar todos los datos de detalle del esquema    

  • Para mostrar todos los datos de detalle, haga clic en el nivel más bajo de uno dos tres símbolos de esquema. Por ejemplo, si existen tres niveles, haga clic en tres .

  • Para ocultar todos los datos de detalle, haga clic en uno .

¿Necesitas más ayuda?

Siempre puede preguntar a un experto en la Excel Tech Community u obtener soporte técnico en la Comunidad de respuestas.

Vea también

Agrupar o desagrupar datos en una tabla dinámica

¿Necesita más ayuda?

Ampliar sus conocimientos de Office
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

×