Función BUSCARV

Sugerencia: Pruebe a usar la nueva función BUSCARX, una versión mejorada de BUSCARV que funciona en cualquier dirección y devuelve coincidencias exactas de forma predeterminada, lo que hace que sea más fácil y cómodo de usar que su predecesora.

Use BUSCARV cuando necesite buscar cosas en una tabla o en un rango por fila. Por ejemplo, busque un precio de una pieza de automoción por el número de pieza o busque un nombre de empleado en función de su id. de empleado.

Sugerencia: Consulte estos vídeos de YouTube de Microsoft Creators para obtener más ayuda con BUSCARV.

En su forma más simple, la función BUSCARV indica lo siguiente:

=BUSCARV(Qué desea buscar, dónde desea buscarlo, el número de columna del rango que contiene el valor que se va a devolver, devolver una coincidencia aproximada o exacta, que se indica como 1/VERDADERO o 0/FALSO).

Su explorador no admite vídeo.

Sugerencia: El secreto de BUSCARV es organizar los datos de forma que el valor que busque (fruta) esté a la izquierda del valor devuelto (cantidad) que desea encontrar.

Use la función BUSCARV para buscar un valor en una tabla.

Sintaxis

BUSCARV (valor_buscado, matriz_buscar_en, indicador_columnas, [ordenado])

Por ejemplo:

  • =BUSCARV(A2;A10:C20;2;VERDADERO)

  • =BUSCARV("López",B2:E7,2,FALSO)

  • =BUSCARV(A2;'Detalles del cliente'! A:F,3,FALSO)

Nombre del argumento

Descripción

valor_buscado    (requerido)

El valor que desea buscar. El valor que desea buscar debe estar en la primera columna del rango de celdas que especifique en el table_array argumento.

Por ejemplo, si la matriz de tabla abarca las celdas B2:D7, el lookup_value debe estar en la columna B.

valor_buscado puede ser un valor o una referencia a una celda.

matriz_tabla    (obligatorio)

El rango de celdas en las que BUSCARV buscará valor_buscado y el valor devuelto. Puede usar un rango con nombre o una tabla y puede usar nombres en el argumento en lugar de referencias de celda. 

La primera columna del rango de celdas debe contener el lookup_value. El rango de celdas también debe incluir el valor devuelto que desea buscar.

Obtenga información sobre cómo seleccionar rangos en una hoja.

indicador_columnas    (requerido)

El número de columna (empezando por 1 para la columna más izquierda de table_array)que contiene el valor devuelto.

intervalo_buscar   (opcional)

Un valor lógico que especifica si desea que BUSCARV busque una coincidencia exacta o aproximada:

  • Coincidencia aproximada: 1/VERDADERO asume que la primera columna de la tabla se ordena numérica o alfabéticamente y, a continuación, buscará el valor más próximo. Este es el método predeterminado si no especifica uno. Por ejemplo, =BUSCARV(90;A1:B100;2;VERDADERO).

  • Coincidencia exacta: 0/FALSO busca el valor exacto en la primera columna. Por ejemplo, =BUSCARV("Smith",A1:B100,2,FALSO).

Primeros pasos

Hay cuatro partes de la información que necesita para crear la sintaxis de BUSCARV:

  1. El valor que desea buscar, también conocido como el valor de búsqueda.

  2. El rango donde se encuentra el valor de búsqueda. Recuerde que el valor de búsqueda debe estar siempre en la primera columna del rango para que BUSCARV funcione correctamente. Por ejemplo, si el valor de la búsqueda está en la celda C2, su rango debería empezar con C.

  3. El número de columna del rango que contiene el valor devuelto. Por ejemplo, si especifica B2:D11 como rango, debe contar B como la primera columna, C como la segunda, y así sucesivamente.

  4. Opcionalmente, puede especificar VERDADERO si desea una coincidencia aproximada o FALSO si desea una coincidencia exacta del valor devuelto. Si no especifica nada, el valor predeterminado siempre será VERDADERO o la coincidencia aproximada.

Ahora coloque todas las respuestas anteriores de la siguiente forma:

=BUSCARV(valor de búsqueda, rango que contiene el valor de búsqueda, el número de columna del rango que contiene el valor devuelto, Coincidencia aproximada (VERDADERO) o Coincidencia exacta (FALSO)).

Ejemplos

Estos son algunos ejemplos de BUSCARV:

Ejemplo 1

Ejemplo 1 de BUSCARV

Ejemplo 2

Ejemplo 2 de BUSCARV

Ejemplo 3

Ejemplo 3 de BUSCARV

Ejemplo 4

Ejemplo 4 de BUSCARV

Ejemplo 5

Ejemplo 5 de BUSCARV

Puede usar BUSCARV para combinar varias tablas en una, siempre que una de las tablas tenga campos en común con todas las demás. Esto puede ser especialmente útil si necesita compartir un libro con personas que tienen versiones anteriores de Excel que no admiten características de datos con varias tablas como orígenes de datos: combinando los orígenes en una tabla y cambiando el origen de datos de la característica de datos a la nueva tabla, la característica de datos se puede usar en versiones anteriores de Excel (siempre que la característica de datos sea compatible con la versión anterior).

Una hoja de cálculo con columnas que usan BUSCARV para obtener datos de otras tablas

Aquí, las columnas A-F y H tienen valores o fórmulas que solo usan valores en la hoja de cálculo y el resto de las columnas usan BUSCARV y los valores de las columnas A (Código de cliente) y B (Abogado) para obtener datos de otras tablas.

  1. Copie la tabla que tiene los campos comunes en una nueva hoja de cálculo y asízcále un nombre.

  2. Haga clic en Herramientas > datos > relaciones para abrir el cuadro de diálogo Administrar relaciones.

    Cuadro de diálogo Administrar relaciones
  3. Para cada relación enumerada, tenga en cuenta lo siguiente:

    • El campo que vincula las tablas (enumeradas entre paréntesis en el cuadro de diálogo). Esta es la lookup_value de la fórmula BUSCARV.

    • El nombre de tabla de búsqueda relacionada. Esta es la table_array en la fórmula BUSCARV.

    • El campo (columna) de la tabla de búsqueda relacionada que tiene los datos que desea en la nueva columna. Esta información no se muestra en el cuadro de diálogo Administrar relaciones: tendrá que ver la tabla de búsqueda relacionada para ver qué campo desea recuperar. Desea tener en cuenta el número de columna (A=1): esta es la col_index_num en la fórmula.

  4. Para agregar un campo a la nueva tabla, escriba la fórmula BUSCARV en la primera columna vacía con la información recopilada en el paso 3.

    En nuestro ejemplo, la columna G usa Abogado (el lookup_value) para obtener los datos de tasa de facturación de la cuarta columna (col_index_num = 4) de la tabla de hoja de cálculo Abogados, tblAttorneys (el table_array),con la fórmula =BUSCARV([@Attorney],tbl_Attorneys,4,FALSO).

    La fórmula también podría usar una referencia de celda y una referencia de rango. En nuestro ejemplo, sería =BUSCARV(A2;'Abogados'! A:D,4,FALSO).

  5. Siga agregando campos hasta que tenga todos los campos que necesita. Si está intentando preparar un libro que contiene características de datos que usan varias tablas, cambie el origen de datos de la característica de datos a la nueva tabla.

Problema

Qué ha fallado

Valor devuelto incorrecto

Si ordenado es VERDADERO o se omite, es necesario ordenar la primera columna alfabéticamente o numéricamente. Si la primera columna no está ordenada, el valor devuelto puede ser algo inesperado. Puede ordenar la primera columna o usar FALSO para obtener una coincidencia exacta.

#N/A en la celda

  • Si ordenado es VERDADERO y el valor en valor_buscado es más pequeño que el valor más pequeño de la primera columna de la matriz_buscar_en, el valor de resultado será #N/A.

  • Si ordenado es FALSO, el valor de error #N/A indica que no se ha encontrado el número exacto.

Para obtener más información sobre cómo resolver los errores # n/a en BUSCARV, vea Cómo corregir un error #N/A en la función BUSCARV.

#¡REF! en la celda

Si indicador_columnas es mayor que el número de columnas en matriz_buscar_en, el valor devuelto será un error #¡REF! #¡VALOR!

Para obtener más información sobre cómo resolver los errores #REF! en BUSCARV, vea Cómo corregir un error #REF!..

#¡VALOR! en la celda

Si matriz_buscar_en es menos de 1, el valor devuelto será un error #¡VALOR! #¡VALOR!

Para obtener más información sobre cómo resolver los errores #VALUE! en BUSCARV, vea Cómo corregir un error #VALUE! en la función BUSCARV.

#¿NOMBRE? en la celda

El valor de error #¿NOMBRE? normalmente significa que en la fórmula faltan comillas. Para buscar el nombre de una persona, asegúrese de que el nombre aparece entre comillas en la fórmula. Por ejemplo, escriba el nombre como "López" en =BUSCARV( "López",B2:E7,2,FALSO).

Para obtener más información, vea Cómo corregir un error #NAME!..

Errores #SPILL! en la celda

Este error #SPILL! normalmente significa que la fórmula se basa en la intersección implícita para el valor de búsqueda y en usar una columna completa como referencia. Por ejemplo, =BUSCARV( A:A,A:C,2,FALSO). Puede resolver el problema anclando la referencia de búsqueda con el operador @ como este: =BUSCARV(@A:A,A:C,2,FALSO). Como alternativa, puede usar el método tradicional BUSCARV y hacer referencia a una sola celda en lugar de a una columna completa: =BUSCARV(A2,A:C,2,FALSO).

Realice este procedimiento

¿Por qué?

Use referencias absolutas para ordenado.

Las referencias absolutas le permiten rellenar hacia abajo una fórmula, de manera que siempre se busca en el mismo rango de búsqueda.

Aprenda a usar referencias de celda absolutas.

No almacene valores de fechas o números como texto.

Al buscar valores de fechas o números, asegúrese de que los datos de la primera columna de matriz_buscar_en no se almacenen como valores de texto. De ser así, BUSCARV puede devolver un valor incorrecto o inesperado.

Ordene la primera columna.

Ordene la primera columna de la matriz_tabla antes de usar BUSCARV cuando ordenado sea VERDADERO.

Use caracteres comodín.

Si ordenado es FALSO y valor_buscado es un texto, se pueden usar los caracteres comodín de signo de interrogación (?) y asterisco (*) en valor_buscado. El signo de interrogación reemplaza cualquier carácter individual. El asterisco reemplaza cualquier secuencia de caracteres. Si lo que desea buscar es un signo de interrogación o un asterisco, escriba una tilde (~) antes del carácter.

Por ejemplo, =BUSCARV("Fontan?",B2:E7,2,FALSO) buscará todas las instancias de Fontana con una última letra que podría variar.

Asegúrese de que los datos no contienen caracteres incorrectos.

Al buscar valores de texto en la primera columna, asegúrese de que los datos de la primera columna no contienen espacios al principio ni al final, de que no haya un uso incoherente de las comillas rectas (' o ") ni tipográficas (‘ o “) y de que no haya caracteres no imprimibles. En estos casos, BUSCARV puede devolver un valor inesperado o incorrecto.

Para obtener resultados, pruebe a usar la función LIMPIAR o la función ESPACIOS para eliminar los espacios finales detrás de los valores de tabal en una celda.

¿Necesitas más ayuda?

Siempre puede preguntar a un experto en Excel Tech Community, obtener soporte técnico en la Comunidad de respuestas o sugerir una característica nueva o mejora en el UserVoice de Excel.

Vea también

Tarjeta de referencia rápida: actualizador de BUSCARV
Tarjeta de referencia rápida: Sugerencias de solución de problemas de BUSCARV
YouTube: Vídeos de BUSCARV de Microsoft Creators
Cómo corregir un error #VALUE! en la función BUSCARV
Cómo corregir un error #N/A en la función BUSCARV
Información general sobre fórmulas en Excel
Cómo evitar la ruptura de las fórmulas
Detectar errores en las fórmulas
Funciones de Excel (por orden alfabético)
Funciones de Excel (por categoría)
BUSCARV (vista previa gratuita)

¿Necesita más ayuda?

Ampliar sus conocimientos de Office
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

×