En este artículo se describen la sintaxis de la fórmula y el uso de la función TIPO.DE.ERROR en Microsoft Excel.

Descripción

Devuelve un número que corresponde a uno de los valores de error de Microsoft Excel o devuelve el error #N/A si no existe ningún otro. Use TIPO.DE.ERROR en una función SI para probar un valor de error y devolver en su lugar una cadena de texto, como un mensaje.

Sintaxis

TIPO.DE.ERROR(valor_de_error)

La sintaxis de la función TIPO.DE.ERROR tiene los siguientes argumentos:

  • Valor_de_error    Obligatorio. Es el valor de error cuyo número identificador desea buscar. Aunque valor_de_error puede ser un valor de error real, por lo general es una referencia a una celda que contiene la fórmula que desea probar.

Si error_val es

TIPO.DE.ERROR devuelve

#¡NULO!

1

#¡DIV/0!

2

#¡VALOR!

3

#¡REF!

4

#¿NOMBRE?

5

#¡NUM!

6

#N/A

7

#OBTENIENDO_DATOS

8

Otro valor

#N/A

Ejemplo

Copie los datos de ejemplo en la tabla siguiente y péguelos en la celda A1 de una hoja de cálculo nueva de Excel. Para que las fórmulas muestren los resultados, selecciónelas, presione F2 y luego ENTRAR. Si lo necesita, puede ajustar el ancho de las columnas para ver todos los datos.

Datos

#¡NULO!

#¡DIV/0!

Fórmula

Descripción

Resultado

=TIPO.DE.ERROR(A2)

Número de la #NULL! Error(1).

1

=SI(TIPO.DE.ERROR(A3)<3;ELEGIR(TIPO.DE.ERROR(A3);"Los rangos no se intersecan";"El divisor es cero"))

Comprueba la celda A3 para ver si la celda contiene el #NULL! o el valor #DIV/0! valor de error. Si lo hace, el número del valor de error se usa en la función ELEGIR hoja de cálculo para mostrar uno de dos mensajes; de lo contrario, se devuelve #N de error de #N/A.

El divisor es cero

¿Necesita más ayuda?

Ampliar sus conocimientos
Explorar los cursos
Obtener nuevas características primero
Unirse a Microsoft Insider

¿Le ha sido útil esta información?

¿Cómo de satisfecho está con la calidad de la traducción?
¿Qué ha afectado a tu experiencia?

¡Gracias por sus comentarios!

×