Guía para diseñar informes

Access le proporciona una serie de herramientas que le ayudan a crear informes atractivos y fáciles de leer rápidamente que presentan los datos de la manera que mejor se adapte a las necesidades de sus usuarios. Puede usar los comandos de la pestaña Crear para crear un informe sencillo con un solo clic. Puede usar el Asistente para informes para crear un informe más complicado o puede crear un informe agregando todos los datos y elementos de formato usted mismo. Independientemente del método que elija, es probable que realice al menos algunos cambios en el diseño del informe para que muestre los datos de la forma que desee. En este artículo se describe el proceso general de diseño de un informe y, a continuación, se muestra cómo agregar elementos de diseño específicos al informe.

En este artículo

Decidir cómo crear el informe

Al diseñar un informe, primero debe tener en cuenta cómo desea organizar los datos en la página y cómo se almacenan los datos en la base de datos. Durante el proceso de diseño, es posible que incluso descubra que la disposición de los datos en las tablas no le permitirá crear el informe que desee. Esto puede indicar que las tablas no están normalizadas, lo que significa que los datos no se almacenan de la manera más eficiente.

Crear un boceto del informe

Este paso no es necesario: es posible que el Asistente para informes de Access o la herramienta Informe (ambos disponibles en la pestaña Crear, en el grupo Informes) proporcionen un diseño inicial suficiente para el informe. Sin embargo, si decide diseñar el informe sin usar estas herramientas, es posible que le sea útil realizar un boceto aproximado del informe en un fragmento de papel dibujando un cuadro donde vaya cada campo y escribiendo el nombre del campo en cada cuadro. Como alternativa, puede usar programas como Word o Visio para crear una maqueta del informe. Sea cual sea el método que use, asegúrese de incluir filas suficientes para indicar cómo se repiten los datos.

Formulario completado que se superpone sobre un boceto preliminar

Por ejemplo, puede usar una fila para la información del producto, después varias filas que se repiten para las ventas de ese producto y, por último, una fila de totales de ventas para el producto. A continuación, la secuencia se repite para el siguiente producto y así sucesivamente hasta el final del informe. O bien, quizás el informe sea una simple lista de los datos de la tabla, en cuyo caso el boceto puede contener solo una serie de filas y columnas.

Nota: Esta técnica también es muy útil si está diseñando un informe para otra persona. En este caso, la otra persona puede dibujar el boceto antes de comenzar el trabajo.

Después de crear el boceto, determine qué tabla o tablas contienen los datos que desea mostrar en el informe. Si todos los datos están contenidos en una sola tabla, puede basar el informe directamente en esa tabla. Más a menudo, los datos que desea se almacenan en varias tablas que debe reunir en una consulta para poder mostrarla en el informe. La consulta se puede incrustar en la propiedad RecordSource del informe, o bien puede crear una consulta independiente guardada y basar el informe en eso.

Decidir qué datos colocar en cada sección de informe

Cada informe tiene una o más secciones de informe. La única sección que está presente en cada informe es la sección Detalles. Esta sección se repite una vez para cada registro de la tabla o consulta en la que se basa el informe. Otras secciones son opcionales y se repiten con menos frecuencia y normalmente se usan para mostrar información que es común a un grupo de registros, una página del informe o todo el informe.

En la tabla siguiente se describe dónde se encuentra cada sección y cómo se usa normalmente la sección.

Sección

Ubicación

Contenido típico

Sección encabezado del informe

Aparece solo una vez, en la parte superior de la primera página del informe.

  • Título del informe

  • Logotipo

  • Fecha actual

Sección Pie de página del informe

Aparece después de la última línea de datos, encima de la sección Pie de página de la última página del informe.

Informes de totales (sumas, recuentos, promedios, y así sucesivamente)

Sección encabezado de página

Aparece en la parte superior de cada página del informe.

  • Título del informe

  • Número de página

Sección pie de página

Aparece en la parte inferior de cada página del informe.

  • Fecha actual

  • Número de página

Sección encabezado de grupo

Aparece justo antes de un grupo de registros.

El campo en el que se agrupa

Sección pie de página de grupo

Aparece justo después de un grupo de registros.

Totales de grupo (sumas, recuentos, promedios, y así sucesivamente)

Para obtener información sobre cómo agregar o quitar secciones de encabezado y pie de página del informe o secciones de encabezado y pie de página, vea la sección Agregar o quitar secciones de informe o encabezado de página y pie de página en este artículo. Puede agregar secciones de encabezado y pie de página de grupo mediante el panel Agrupar, Ordenar y Total en la vista Diseño o en la vista Diseño.

Decidir cómo organizar los datos detallados

La mayoría de los informes se organizan en un diseño tabular o apilado, pero Access le ofrece la flexibilidad de usar casi cualquier disposición de registros y campos que desee.

Diseño tabular    Un diseño tabular es similar a una hoja de cálculo. Las etiquetas están en la parte superior y los datos se alinean en columnas debajo de las etiquetas. Tabular hace referencia a la apariencia de tabla de los datos. Este es el tipo de informe que Access al hacer clic en Informe en el grupo Informes de la pestaña Crear. El diseño tabular es un buen uso si el informe tiene un número relativamente pequeño de campos que desea mostrar en un formato de lista simple. En la ilustración siguiente se muestra un informe de empleado que se creó con un diseño tabular.

Informe de empleados con formato de tabla

Diseño apilado    Un diseño apilado se parece a un formulario que rellena al abrir una cuenta bancaria o realizar una compra en un distribuidor en línea. Cada fragmento de datos se etiqueta y los campos se apilan uno encima del otro. Este diseño es bueno para los informes que contienen demasiados campos para mostrar en un formato tabular, es decir, el ancho de las columnas superaría el ancho del informe. En la ilustración siguiente se muestra un informe de empleado que se creó con un diseño apilado.

Informe de empleados con formato apilado

Nota: En el Asistente para informes, este diseño se conoce como diseño de columnas.

Diseño mixto    Puede mezclar elementos de diseños tabulares y apilados. Por ejemplo, para cada registro, puede organizar algunos de los campos de una fila horizontal en la parte superior de la sección Detalle y organizar otros campos del mismo registro en uno o varios diseños apilados debajo de la fila superior. En la ilustración siguiente se muestra un informe de empleado que se creó con un diseño mixto. Los campos Id., Apellido y Nombre se organizan en un diseño de control tabular y los campos Puesto de trabajo y Teléfono empresarial se organizan en un diseño apilado. En este ejemplo, las líneas de cuadrícula se usan para proporcionar una separación visual de campos para cada empleado.

Informe de empleados con formato mixto

Diseño justificado    Si usa el Asistente para informes para crear el informe, puede elegir usar un diseño justificado. Este diseño usa el ancho completo de la página para mostrar los registros lo más compacta posible. Por supuesto, puede lograr los mismos resultados sin usar el Asistente para informes, pero puede ser un proceso esmerado para alinear los campos exactamente. En la ilustración siguiente se muestra un informe de empleado que se creó con el diseño justificado del Asistente para informes.

Informe de empleados con formato justificado

El diseño justificado es un buen diseño para usar si se muestra un gran número de campos en el informe. En el ejemplo anterior, si usa un diseño tabular para mostrar los mismos datos, los campos se extienden fuera del borde de la página. Si usa un diseño apilado, cada registro ocupa mucho más espacio vertical, lo que desperdicia papel y hace que el informe sea más difícil de leer.

Principio de página

Usar diseños de control para alinear los datos

Los diseños de control son guías que puede agregar a un informe mientras está abierto en la vista Diseño o en la vista Diseño. Access diseños de control automáticamente al usar el Asistente para informes para crear un informe o al crear un informe haciendo clic en Informe en el grupo Informes de la pestaña Crear. Un diseño de control es como una tabla, cuya celda puede contener una etiqueta, un cuadro de texto o cualquier otro tipo de control. En la ilustración siguiente se muestra un diseño de control tabular en un informe.

Diseño básico de controles en tabla

Las líneas naranjas indican las filas y columnas del diseño de control y solo son visibles cuando el informe está abierto en la vista Diseño o en la vista Diseño. Los diseños de control le ayudan a lograr una alineación uniforme de los datos en filas y columnas, y facilitan la adición, el tamaño o la eliminación de campos. Con las herramientas de los grupos Tabla y Posición de la pestaña Organizar (disponible en la vista Diseño o en la vista Diseño), puede cambiar un tipo de diseño de control a otro y puede quitar controles de los diseños para que pueda colocar los controles donde quiera en el informe.

Principio de página

Agregar o quitar secciones de informe o encabezado de página y pie de página

Como se mencionó anteriormente en este artículo, los encabezados y pies de página son secciones de informe que puede usar para mostrar información que es común a todo el informe o a cada página de un informe. Por ejemplo, puede agregar una sección Pie de página para mostrar un número de página en la parte inferior de cada página, o puede agregar una sección encabezado de informe para mostrar un título para todo el informe.

Agregar secciones de informe o encabezado de página y pie de página

  1. En el panel de navegación, haga clic con el botón derecho en el informe que desea cambiar y, a continuación, haga clic en Vista Diseño en el menú contextual.

  2. Compruebe qué secciones ya están en el informe. Las secciones están separadas por barras horizontales sombreadas denominadas selectores de sección. La etiqueta de cada selector de sección indica cuál es la sección directamente debajo de ella.

    Informe en la vista Diseño

    Cada informe tiene una sección Detalle y también puede contener secciones Encabezado de informe, Encabezado de página, Pie de página y Pie de página de informe. Además, si hay niveles de agrupación en el informe, es posible que vea encabezados de grupo o pies de página (como el archivo como encabezado que se muestra en la ilustración anterior). De forma predeterminada, los encabezados y pies de página de grupo se denominan mediante el nombre de campo o la expresión que es la base del grupo. En este caso, el nombre del campo de agrupación es "Archivo como".

  3. Para agregar secciones de encabezado y pie de página o secciones de encabezado y pie de página de informe al informe, haga clic con el botón derecho en cualquier selector de sección y, a continuación, haga clic en Encabezado o pie de página de página o Encabezado o pie de página del informe en el menú contextual.

    Precaución: Si la sección ya está presente en el informe, Access le advertirá de que eliminará la sección existente y los controles que contiene.

    Ahora puede mover controles existentes o agregar nuevos controles a las nuevas secciones.

Access siempre agrega secciones de página e informe de encabezado y pie de página en pares. Es decir, no puede agregar una sección de encabezado de página o informe sin agregar también la sección de pie de página correspondiente. Si no necesita ambas secciones, no puede eliminar una sección, pero puede cambiar el tamaño de la sección sin usar a un alto de cero (0) para evitar agregar espaciado vertical adicional al informe. Coloque el puntero en la parte inferior de la sección sin usar hasta que se convierta en una flecha de dos puntas texto alternativo y, después, arrastre hacia arriba hasta que la sección esté oculta. Si hay controles en la sección, debe eliminarlos antes de poder ocultar completamente la sección.

Quitar secciones de informe o encabezado de página y pie de página

  1. En el panel de navegación, haga clic con el botón derecho en el informe que desea cambiar y, a continuación, haga clic en Vista Diseño en el menú contextual.

  2. Haga clic con el botón derecho en cualquier selector de sección y, a continuación, haga clic en Encabezado o pie de página de página o Encabezado o pie de página del informe en el menú contextual.

Si quita un par de encabezados y pies de página y esas secciones contienen controles, Access le advierte de que al eliminar las secciones también se eliminarán los controles y que no podrá deshacer la acción. Haga clic en Sí para quitar las secciones y eliminar los controles, o haga clic en No para cancelar la operación.

Principio de página

Sugerencias para dar formato a diferentes tipos de datos

Al crear un informe con la herramienta Informe (disponible en la pestaña Crear, en el grupo Informes) o con el Asistente para informes, Access agrega los campos al informe por usted y crea el control más adecuado para mostrar cada campo, según el tipo de datos del campo. Si va a agregar campos a un informe usted mismo, el método preferido es arrastrar cada campo de la lista de campos al informe. Al igual que con el Asistente para informes o la herramienta Informe, Access crea el control más adecuado para cada campo, según el tipo de datos del campo. Para la mayoría de los tipos de datos, el control (predeterminado) más apropiado para usar es el cuadro de texto.

En las secciones siguientes se proporcionan sugerencias sobre cómo dar formato a algunos de los tipos de datos de mayúsculas y minúsculas especiales.

Campos multivalor    El control predeterminado para un campo multivalor es un cuadro combinado. Esto puede parecer una opción extraña para un control en un informe, ya que no puede hacer clic en la flecha de un cuadro combinado de un informe. Sin embargo, en el contexto de un informe, un cuadro combinado se comporta como un cuadro de texto. La flecha solo está visible en la vista Diseño.

Si el campo contiene varios valores, esos valores se separan por comas. Si el cuadro combinado no es lo suficientemente ancho para mostrar todos los valores de una línea y la propiedad CanCrear del cuadro combinado se establece en Sí,los valores se ajustarán a la línea siguiente. En caso contrario, los valores se truncan. Para establecer la propiedad CanGrow para un control, abra el informe en la vista Diseño o en la vista Diseño, haga clic en el control y, después, presione F4 para mostrar la hoja de propiedades del control. La propiedad CanGrow se encuentra en la pestaña Formato y en la pestaña Todo de la hoja de propiedades del control.

Campos de texto enriquecido    El control predeterminado para un campo de texto enriquecido es un cuadro de texto. Si el cuadro de texto no es lo suficientemente ancho como para mostrar todos los valores de una línea y la propiedad CanCrear del cuadro de texto se establece en Sí,los valores se ajustarán a la línea siguiente. En caso contrario, los valores se truncan. Para establecer la propiedad CanGrow para un control, abra el informe en la vista Diseño o en la vista Diseño, haga clic en el control y, después, presione F4 para mostrar la hoja de propiedades del control. La propiedad CanGrow se encuentra en la pestaña Formato y en la pestaña Todo de la hoja de propiedades del control.

Un campo de texto enriquecido le ayuda a dar formato al texto de varias maneras. Por ejemplo, varias palabras de un campo se pueden subrayar y otras palabras del mismo campo pueden estar en cursiva. Sin embargo, puede establecer un estilo de formato general para el cuadro de texto que contiene el texto enriquecido. El formato del cuadro de texto solo se aplica al texto que no se ha dado formato específicamente mediante el formato de texto enriquecido.

Establecer estilos de formato para un cuadro de texto que muestra un campo de texto enriquecido

  1. Haga clic con el botón derecho en el informe en el panel de navegación y, a continuación, haga clic en Vista Presentación en el menú contextual.

  2. Haga clic en el cuadro de texto que muestra el campo de texto enriquecido y, a continuación, en la pestaña Formato, en el grupo Fuente, haga clic en el estilo de formato que desee aplicar.

    Access aplica el formato a todo el texto del campo de texto enriquecido que aún no haya aplicado ese tipo de formato (pero no el valor) en una vista que admita la entrada de datos, como la vista Hoja de datos para una tabla o consulta, o la vista Formulario de un formulario. Por ejemplo, si una parte del texto del campo tiene formato con un color de fuente rojo y aplica un color de fuente azul al cuadro de texto, Access convierte todo el texto en azul, excepto el que se ha formatado individualmente como rojo. Como otro ejemplo, si una parte del texto del campo tiene formato con un tamaño de fuente de 11 puntos y aplica un tamaño de fuente de 14 puntos al cuadro de texto, Access aplica el tamaño de fuente de 14 puntos a todo el texto, excepto al que tenía formato individual en 11 puntos.

    Campos de datos adjuntos    Los campos de datos adjuntos usan un control especial que no se usa para ningún otro tipo de datos. Puede adjuntar varios archivos a un registro mediante un único campo Datos adjuntos, pero el campo solo puede mostrar información sobre datos adjuntos de uno en uno. De forma predeterminada, el control de datos adjuntos muestra un icono o una imagen, según el tipo de archivo de los datos adjuntos que muestra actualmente el control. Si lo desea, puede establecer las propiedades del control de datos adjuntos para que todos los archivos adjuntos se muestren como iconos, o para que el campo simplemente muestre un icono de clip de papel y el número de datos adjuntos. Suponiendo que ya usa un control de datos adjuntos en el informe, puede usar el procedimiento siguiente para ajustar las propiedades del control para distintos usos del control.

Establecer las propiedades de visualización de un campo Datos adjuntos

  1. Haga clic con el botón derecho en el informe en el panel de navegación y, a continuación, haga clic en Vista Presentación en el menú contextual.

  2. Haga clic en el control de datos adjuntos. Si no se muestra la Hoja de propiedades, presione F4 para mostrarla. En la hoja de propiedades, haga clic en la pestaña Formato.

    Use la tabla siguiente como guía para establecer las propiedades del control de datos adjuntos.

    Propiedad

    Valor

    Mostrar como

    • Imagen/icono muestra gráficos como imágenes y todos los demás archivos como iconos. Esta es la opción predeterminada.

    • Icono muestra todos los archivos como iconos.

    • El clip muestra un icono de clip de papel seguido del número de datos adjuntos entre paréntesis.

    Imagen predeterminada

    Para que una imagen predeterminada aparezca en el control de datos adjuntos cuando no haya archivos adjuntos, haga clic en Botón Generador en el cuadro de propiedades, busque la imagen que desee y, a continuación, haga clic en Abrir.

    Nota: La imagen predeterminada no se muestra si la propiedad Mostrar como está establecida en Clip de papel.

    Alineación de imágenes

    Seleccione la alineación que desee de la lista. La configuración predeterminada es Centro. Ajustar esta configuración puede producir resultados inesperados, dependiendo de la configuración de la propiedad Modo de tamaño de imagen.

    Modo tamaño de imagen

    Esta configuración solo está disponible si la propiedad Mostrar como está establecida en Imagen/Icono.

    • Clip muestra la imagen en su tamaño real. La imagen se recorta si es demasiado grande para caber dentro del control.

    • Estirar extiende la imagen para que rellene todo el control.

      Nota: A menos que el control de datos adjuntos tenga el mismo tamaño exacto que la imagen, con esta configuración se distorsionará la imagen, lo que hará que aparezca estirada vertical u horizontalmente.

    • Zoom muestra la imagen lo más grande posible sin recortar ni distorsionar la imagen. Esta es la opción predeterminada.

  3. Si usa el control para mostrar gráficos, ajuste el tamaño del control de datos adjuntos para que pueda ver la cantidad de detalles que desee.

Principio de página

¿Necesita más ayuda?

Ampliar sus conocimientos de Office
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×