A veces necesita datos que se almacenan fuera de Excel, como un archivo local o una base de datos. En este caso, puede conectar con el origen de datos externo para trabajar con los datos.

Para obtener más información sobre el uso de Power Query (también denominado Obtener & transformar), vea Importar datos en Excel para Mac (Power Query).

  1. Abra el Excel libro.

  2. Si recibe una advertencia de seguridad sobre las conexiones de datos externos deshabilitadas, seleccione Habilitar contenido.

  3. Si aparece el cuadro de diálogo Conceder acceso a archivos, seleccione Seleccionary, a continuación, seleccione Conceder acceso a la carpeta de nivel superior que contiene los archivos de origen de datos.

  4. Seleccione Datos> Desde texto (heredado). Aparecerá el cuadrode diálogo Entrada F.

  5. Busque el .txt o .csv y seleccione Abrir. Aparecerá el Asistente para importación de texto.

    Sugerencia     Compruebe repetidamente la vista previa del panel de datos seleccionados para confirmar las opciones.

  6. En la primera página, haga lo siguiente:

    Tipo de archivo    Para elegir el tipo de archivo de texto, seleccione Delimitado o Ancho fijo.

    Número de fila    En Iniciar importación en fila,seleccione un número de fila para especificar la primera fila de datos que desea importar.

    Juego de caracteres     En Origen del archivo,seleccione el juego de caracteres que se usa en el archivo de texto. En la mayoría de los casos, puede dejar esta configuración en su valor predeterminado.

  7. En la segunda página, haga lo siguiente:

    Delimitado

    Si eligió Delimitado en la primera página, en Delimitadores, seleccione el carácter delimitador o use la casilla Otros para escribir uno que no aparece en la lista.

    Seleccione Tratar delimitadores consecutivos como uno si los datos contienen un delimitador de más de un carácter entre campos de datos o si los datos contienen varios delimitadores personalizados.

    En Calificador de texto,seleccione el carácter que encierra valores en el archivo de texto, que suele ser el carácter de comillas (").

    Ancho fijo

    Si eligió Ancho fijo en la primera página, siga las instrucciones para crear, eliminar o mover una línea de salto en el cuadro Vista previa de datos seleccionados.

  8. En la tercera página, haga lo siguiente:

    Para cada columna en Vista previa de los datosseleccionados, selecciónelo y cámbielo a otro formato de columna si lo desea. Puede establecer aún más el formato de fecha y seleccionar Avanzadas para cambiar la configuración de datos numéricos. También puede convertir los datos después de importarlos.

    Seleccione Finalizar. Aparecerá el cuadro de diálogo Importar datos.

  9. Elija dónde desea agregar los datos: ya sea en la hoja existente, en una hoja nueva o en una tabla dinámica.

  10. Seleccione Aceptar.

    Para asegurarse de que la conexión funciona, escriba algunos datos y, a continuación, seleccione Conexiones > Actualizar.

  1. Seleccione Data > FromSQL Server ODBC.  Aparece el cuadro de diálogo Conectar a origen de datos ODBC de SQL Server.

    El SQL Server de diálogo para escribir el servidor, la base de datos y las credenciales

  2. Escriba el servidor en el cuadro Nombre del servidor y, opcionalmente, escriba la base de datos en el cuadro Nombre de base de datos.

    Obtenga esta información del administrador de la base de datos.

  3. En Autenticación, seleccione un método de la lista: Nombre de usuario/contraseña,Kerberoso NTLM.

  4. Escriba las credenciales en los cuadros Nombre de usuario y Contraseña.

  5. Seleccione Conectar. Aparecerá el cuadro de diálogo Navegador.

  6. En el panel izquierdo, vaya a la tabla que desee y, a continuación, selecciónelo.

  7. Confirme la SQL en el panel derecho. Puede cambiar la instrucción SQL que le parezca conveniente.

  8. Para obtener una vista previa de los datos, seleccione Ejecutar.

  9. Cuando esté listo, seleccione Devolver datos. Aparecerá el cuadro de diálogo Importar datos. 

    Cuadro de diálogo Importar datos usado para localizar los datos

  10. Elija dónde desea agregar los datos: ya sea en la hoja existente, en una hoja nueva o en una tabla dinámica.

  11. Para establecer las propiedades de conexión en las pestañas Uso y Definición del cuadro de diálogo Propiedades, seleccione Propiedades. Después de importar los datos, también puede seleccionar Datos> Connectionsy, a continuación, en el cuadro de diálogo Propiedades de conexión, seleccione Propiedades.

  12. Seleccione Aceptar.

  13. Para asegurarse de que la conexión funciona, escriba algunos datos y, a continuación, seleccione Datos > Actualizar todo.

Si desea usar un origen externo que no sea un SQL Database (por ejemplo, FileMaker Pro), puede usar un controlador odbc (Open Database Connectivity) instalado en su Mac. En esta página web tiene información disponible sobre los controladores. Una vez instalado el controlador del origen de datos, siga estos pasos:

  1. Seleccione Datos> desde la base de datos (Microsoft Query).

  2. Agregue el origen de datos de la base de datos y, a continuación, seleccione Aceptar.

  3. En el SQL Server credenciales, escriba el método de autenticación, el nombre de usuario y la contraseña.

    texto alternativo

  4. A la izquierda, seleccione la flecha situada junto al servidor para ver las bases de datos.

  5. Seleccione la flecha situada junto a la base de datos que desee.

  6. Seleccione la tabla que desee.

  7. Para obtener una vista previa de los datos, seleccione Ejecutar.

  8. Cuando esté listo, seleccione Devolver datos.

  9. En el cuadro de diálogo Importar datos, elija dónde desea que se encuentran los datos: ya sea en la hoja existente, en una hoja nueva o en una tabla dinámica.

  10. Seleccione Aceptar.

  11. Para asegurarse de que la conexión funciona, escriba algunos datos y, a continuación, seleccione Datos > Actualizar todo.

Si sus permisos no funcionan, es posible que no los borre primero y, después, inicie sesión.

  1. Seleccione Datos > Connections. Aparecerá el cuadro de diálogo Conexiones del libro.

  2. Seleccione la conexión que desee en la lista y, a continuación, seleccione Borrar permisos.

    Quitar credenciales guardadas para una conexión de datos en Mac

Vea también

Controladores ODBC compatibles con Excel para Mac

Crear una tabla dinámica para analizar datos de una hoja de cálculo

Para importar datos de una base de datos, como Microsoft SQL Server, debe tener un controlador ODBC compatible con Microsoft Query instalado en el equipo. Los controladores ODBC compatibles están disponibles de proveedores de terceros. Para obtener más información, vea Controladores ODBC compatibles con Excel para Mac. Para obtener más información sobre la instalación de controladores ODBC, vea Ayuda de Microsoft Query.

  1. En el menú Datos, seleccione Obtener datos externosy, a continuación, haga clic en Nueva consulta de base de datos.

  2. Use Microsoft Query para conectarse a un origen de datos y crear una consulta. Cuando haya terminado, haga clic en Devolver datos para importar los datos a Excel.

    Para obtener más información sobre cómo conectarse a un origen de datos y usar Microsoft Query, vea Ayuda de Microsoft Query.

  3. En el cuadro de diálogo Devolver datos externos a Microsoft Excel, haga lo siguiente:

Para

Haga lo siguiente

Elegir opciones de definición de consulta, control de actualización y diseño de datos

Haga clic en Propiedades.

Cambiar la configuración de una consulta de parámetros

Haga clic en Parámetros.

Devolver los datos externos a la hoja activa

Haga clic en Hoja existente. En la hoja, haga clic en la celda donde desea colocar la esquina superior izquierda del rango de datos externo y, después, haga clic en Aceptar.

Devolver los datos externos a una hoja nueva

Haga clic en Nueva hojay, a continuación, haga clic en Aceptar.

Excel agrega una hoja nueva al libro y pega automáticamente el rango de datos externos en la esquina superior izquierda de la nueva hoja.

Crear una tabla dinámica con los datos externos

Haga clic en Tabladinámica y, a continuación, haga clic en Aceptar.

Notas: 

  • Excel 2011 para Mac no se pueden importar datos de ole db o orígenes de datos OLAP.

  • De forma predeterminada, Excel para Mac tablas para importar datos. Para desactivar las tablas al importar datos, en el cuadro de diálogo Devolver datos externos a Microsoft Excel, haga clic en Propiedades y desactive la casilla Usar tabla.

  • Si el origen de datos externo al que desea obtener acceso no está en su equipo local, es posible que tenga que ponerse en contacto con el administrador de la base de datos para obtener una contraseña, permiso de usuario u otra información de conexión.

Vea también

Importar datos de un archivo CSV, HTML o de texto

¿Necesita más ayuda?

Ampliar sus conocimientos
Explorar los cursos
Obtener nuevas características primero
Unirse a Microsoft Office Usuarios de Insider

¿Le ha sido útil esta información?

¿Cuál es tu grado de satisfacción con la calidad del lenguaje?
¿Qué ha afectado a tu experiencia?

¡Gracias por sus comentarios!

×