Sign in with Microsoft
New to Microsoft? Create an account.

Excel para Mac incorpora Power Query tecnología (también denominada Obtener & Transformar) para proporcionar una mayor capacidad al importar, actualizar y autenticar orígenes de datos, administrar Power Query orígenes de datos, borrar credenciales, cambiar la ubicación de orígenes de datos basados en archivos y dar forma a los datos en una tabla que se ajuste a sus requisitos.  También puede crear una consulta de Power Query con VBA. 

Importante: Los siguientes orígenes de datos solo se pueden importar en la vista previa del canal actual: XML, JSON, lista de SharePoint Online, OData, tabla en blanco, consulta en blanco. El origen de datos SQL Server Database solo se puede importar en la versión beta de Insider.

  1. Seleccione Datos > Obtener datos.

    El botón principal y el menú para obtener datos

  2. Para seleccionar el origen de datos deseado, seleccione Obtener datos (Power Query).

  3. En el cuadro de diálogo Elegir origen de datos , seleccione uno de los orígenes de datos disponibles. 

    Ejemplo de orígenes de datos para seleccionar en el cuadro de diálogo

  4. Conectarse al origen de datos. Para obtener más información sobre cómo conectarse a cada origen de datos, vea Importar datos de orígenes de datos.

  5. Elija los datos que desea importar.

  6. Cargue los datos haciendo clic en el botón Cargar .

Resultado

Los datos importados aparecen en una hoja nueva.

Resultados típicos de una consulta

Pasos siguientes

Para dar forma a los datos y transformarlos con la Editor de Power Query, seleccione Transformar datos. Para obtener más información, vea Modelar datos con Editor de Power Query.

Importante: Esta característica está disponible para los participantes de Insider que usen la versión preliminar del canal actual o el Canal beta, ejecutando la versión 16.64 (compilación 22072501) o una versión posterior de Excel para Mac.  Anteriormente solo estaba disponible para los participantes de Insider en el Canal beta que se han unido al programa Office Insider. Si es suscriptor de Microsoft 365, asegúrese de tener la versión más reciente de Office.

Puede importar datos a Excel con Power Query de una amplia variedad de orígenes de datos: Libro de Excel, Texto/CSV, XML, JSON, Base de datos de SQL Server, Lista de SharePoint Online, OData, Tabla en blanco y Consulta en blanco.

Procedimiento

  1. Seleccione Datos > Obtener datos (Power Query).

  2. Para abrir la Editor de Power Query, selecciona Iniciar Editor de Power Query.

    Menú de comandos Obtener datos (Power Query)

    Sugerencia: También puede acceder a la Editor de Power Query seleccionando Obtener datos (Power Query), eligiendo un origen de datos y, a continuación, haciendo clic en Siguiente.

  3. Modele y transforme los datos con la Editor de Power Query como lo haría en Excel para Windows.



    La Editor de Power Query Para obtener más información, vea Power Query para la Ayuda de Excel.

  4. Cuando haya terminado, seleccione Inicio > Cerrar & Cargar.

Resultado

Los datos recién importados aparecen en una hoja nueva.

Resultados típicos de una consulta

Puede actualizar los siguientes orígenes de datos: archivos de SharePoint, listas de SharePoint, carpetas de SharePoint, OData, archivos de texto o CSV, libros de Excel (.xlsx), archivos XML y JSON, tablas y rangos locales, y una base de datos de Microsoft SQL Server.

Actualizar la primera vez

La primera vez que intente actualizar orígenes de datos basados en archivos en las consultas del libro, es posible que deba actualizar la ruta de acceso del archivo.

  1. Seleccione Datos,  la flecha situada junto a Obtener datos y, después, Configuración del origen de datos. Aparecerá el cuadro de diálogo Configuración del origen de datos .

  2. Seleccione una conexión y, a continuación, seleccione Cambiar ruta de acceso del archivo.

  3. En el cuadro de diálogo Ruta de acceso del archivo , seleccione una nueva ubicación y, a continuación, seleccione Obtener datos.

  4. Seleccione Cerrar.

Actualizar las horas posteriores

Para actualizar:

  • Todos los orígenes de datos del libro, seleccione Datos > Actualizar todo.

  • Un origen de datos específico, haga clic con el botón derecho en una tabla de consulta de una hoja y, a continuación, seleccione Actualizar.

  • Una tabla dinámica, seleccione una celda de la tabla dinámica y, a continuación, seleccione Analizar tabla dinámica > Actualizar datos.

La primera vez que acceda a SharePoint, SQL Server, OData u otros orígenes de datos que requieran permiso, debe proporcionar las credenciales adecuadas. También puede borrar las credenciales para introducir otras nuevas.

Introducir credenciales

Al actualizar una consulta por primera vez, es posible que se le pida que inicie sesión. Seleccione el método de autenticación y especifique las credenciales de inicio de sesión para conectarse al origen de datos y continuar con la actualización.

Si es necesario iniciar sesión, aparece el cuadro de diálogo Escribir credenciales .

Por ejemplo:

  • Credenciales de SharePoint:

    Solicitud de credenciales de SharePoint en Mac

  • SQL Server credenciales:

    El cuadro de diálogo SQL Server para especificar el servidor, la base de datos y las credenciales

Borrar credenciales

  1. Seleccione Datos > Obtener datos > Configuración del origen de datos.

  2. En el cuadro de diálogo Configuración de origen de datos, seleccione la conexión que desee.

  3. En la parte inferior, seleccione Borrar Permissions.

  4. Confirme que es lo que quiere hacer y, a continuación, seleccione Eliminar.

Aunque la creación en la Editor de Power Query no está disponible en Excel para Mac, VBA admite Power Query creación. Transferir un módulo de código VBA en un archivo de Excel para Windows a Excel para Mac es un proceso de dos pasos. Al final de esta sección se proporciona un programa de ejemplo.

Paso 1: Excel para Windows

  1. En Excel Windows, desarrolle consultas con VBA. El código VBA que usa las siguientes entidades en el modelo de objetos de Excel también funciona en Excel para Mac: objeto Queries, objeto WorkbookQuery, Workbook.Queries (propiedad).Para obtener más información, vea Referencia de VBA de Excel.

  2. En Excel, asegúrese de que el Editor de Visual Basic está abierto presionando ALT+F11.

  3. Haga clic con el botón derecho en el módulo y, a continuación, seleccione Exportar archivo. Aparecerá el cuadro de diálogo Exportar .

  4. Escribe un nombre de archivo, asegúrate de que la extensión de archivo sea .bas y, a continuación, selecciona Guardar.

  5. Cargue el archivo VBA en un servicio en línea para que el archivo sea accesible desde el Mac.

    Puede usar Microsoft OneDrive. Para obtener más información, vea Sincronizar archivos con OneDrive en Mac OS X.

Paso 2: Excel para Mac

  1. Descargue el archivo VBA en un archivo local, el archivo de VBA que guardó en "Paso uno: Excel para Windows" y cargó en un servicio en línea.

  2. En Excel para Mac, seleccione Herramientas > Macro > Editor de Visual Basic. Aparece la ventana editor de Visual Basic .

  3. Haga clic con el botón derecho en un objeto de la ventana de Project y, a continuación, seleccione Importar archivo. Aparecerá el cuadro de diálogo Importar archivo .

  4. Busque el archivo VBA y, a continuación, seleccione Abrir.

Código de ejemplo

Este es un código básico que puedes adaptar y usar. Esta es una consulta de ejemplo que crea una lista con valores del 1 al 100.

Sub CreateSampleList()
    ActiveWorkbook.Queries.Add Name:="SampleList", Formula:= _
        "let" & vbCr & vbLf & _
            "Source = {1..100}," & vbCr & vbLf & _
            "ConvertedToTable = Table.FromList(Source, Splitter.SplitByNothing(), null, null, ExtraValues.Error)," & vbCr & vbLf & _
            "RenamedColumns = Table.RenameColumns(ConvertedToTable,{{""Column1"", ""ListValues""}})" & vbCr & vbLf & _
        "in" & vbCr & vbLf & _
            "RenamedColumns"
    ActiveWorkbook.Worksheets.Add
    With ActiveSheet.ListObjects.Add(SourceType:=0, Source:= _
        "OLEDB;Provider=Microsoft.Mashup.OleDb.1;Data Source=$Workbook$;Location=SampleList;Extended Properties=""""" _
        , Destination:=Range("$A$1")).QueryTable
        .CommandType = xlCmdSql
        .CommandText = Array("SELECT * FROM [SampleList]")
        .RowNumbers = False
        .FillAdjacentFormulas = False
        .PreserveFormatting = True
        .RefreshOnFileOpen = False
        .BackgroundQuery = True
        .RefreshStyle = xlInsertDeleteCells
        .SavePassword = False
        .SaveData = True
        .AdjustColumnWidth = True
        .RefreshPeriod = 0
        .PreserveColumnInfo = True
        .ListObject.DisplayName = "SampleList"
        .Refresh BackgroundQuery:=False
    End With
End Sub

  1. Abra el libro de Excel.

  2. Si recibes una advertencia de seguridad sobre las conexiones de datos externos deshabilitadas, selecciona Habilitar contenido.

  3. Si aparece el cuadro de diálogo Conceder acceso a archivos, seleccione Seleccionar y, a continuación, seleccione Conceder acceso a la carpeta de nivel superior que contiene los archivos de origen de datos.

  4. Seleccione Datos > del texto (heredado). Aparecerá el cuadro de diálogo Entrada F.

  5. Busque la .txt o .csv archivo y seleccione Abrir. Aparecerá el Asistente para importar texto .

    Propina     Compruebe repetidamente la Vista previa de los datos seleccionados para confirmar las opciones.

  6. En la primera página, haga lo siguiente:

    Tipo de archivo    Para elegir el tipo de archivo de texto, seleccione Delimitado o Ancho fijo.

    Número de fila    En Iniciar importación en fila, seleccione un número de fila para especificar la primera fila de datos que desea importar.

    Juego de caracteres     En Origen del archivo, seleccione el juego de caracteres que se usa en el archivo de texto. En la mayoría de los casos, puede dejar esta configuración en su valor predeterminado.

  7. En la segunda página, haga lo siguiente:

    Delimitado

    Si eligió Delimitado en la primera página, en Delimitadores, seleccione el carácter delimitador o use la casilla Otros para escribir uno no enumerado.

    Seleccione Tratar delimitadores consecutivos como uno si los datos contienen un delimitador de más de un carácter entre campos de datos o si los datos contienen varios delimitadores personalizados.

    En Cualificador de texto, seleccione el carácter que encierra valores en el archivo de texto, que suele ser el carácter de comillas (").

    Ancho

    fijo Si eligió Ancho fijo en la primera página, siga las instrucciones para crear, eliminar o mover una línea de salto en el cuadro Vista previa de los datos seleccionados .

  8. En la tercera página, haga lo siguiente:

    Para cada columna en Vista previa de los datos seleccionados, selecciónela y cámbiela a un formato de columna diferente si lo desea. Puedes establecer aún más el formato de fecha y seleccionar Avanzadas para cambiar la configuración de datos numéricos. También puede convertir los datos después de importarlos.

    Selecciona Finalizar. Aparecerá el cuadro de diálogo Importar datos .

  9. Elija dónde desea que se agreguen los datos: en la hoja existente, en una hoja nueva o en una tabla dinámica.

  10. Seleccione Aceptar.

    Para asegurarse de que la conexión funciona, escriba algunos datos y, después, seleccione Conexiones > Actualizar.

  1. Seleccione Datos > DeSQL Server ODBC.  Aparece el cuadro de diálogo Conectar a origen de datos ODBC de SQL Server.

    El cuadro de diálogo SQL Server para especificar el servidor, la base de datos y las credenciales

  2. Escriba el servidor en el cuadro Nombre del servidor y, opcionalmente, escriba la base de datos en el cuadro Nombre de la base de datos .

    Obtenga esta información del administrador de la base de datos.

  3. En Autenticación, seleccione un método de la lista: Nombre de usuario/Contraseña, Kerberos o NTLM.

  4. Escriba las credenciales en los cuadros Nombre de usuario y Contraseña.

  5. Selecciona Conectar. Aparecerá el cuadro de diálogo Navegador.

  6. En el panel izquierdo, vaya a la tabla que desee y selecciónela.

  7. Confirme la instrucción SQL en el panel derecho. Puede cambiar la instrucción SQL como considere conveniente.

  8. Para obtener una vista previa de los datos, seleccione Ejecutar.

  9. Cuando esté listo, seleccione Devolver datos. Aparecerá el cuadro de diálogo Importar datos

    El cuadro de diálogo Importar datos usado para localizar los datos

  10. Elija dónde desea que se agreguen los datos: en la hoja existente, en una hoja nueva o en una tabla dinámica.

  11. Para establecer las propiedades de conexión en las pestañas Uso y Definición del cuadro de diálogo Propiedades , seleccione Propiedades. Después de importar los datos, también puede seleccionar Conexiones > datos y, a continuación, en el cuadro de diálogo Propiedades de conexión, seleccione Propiedades.

  12. Seleccione Aceptar.

  13. Para asegurarse de que la conexión funciona, escriba algunos datos y, después, seleccione Datos > Actualizar todo.

Si desea usar un origen externo que no sea un SQL Database (por ejemplo, FileMaker Pro), puede usar un controlador odbc (conectividad abierta de bases de datos) instalado en su Mac. En esta página web tiene información disponible sobre los controladores. Una vez instalado el controlador del origen de datos, sigue estos pasos:

  1. Seleccione Datos > de base de datos (Microsoft Query).

  2. Agregue el origen de datos de la base de datos y, después, seleccione Aceptar.

  3. En el SQL Server petición de credenciales, escriba el método de autenticación, el nombre de usuario y la contraseña.

    texto alternativo

  4. A la izquierda, seleccione la flecha situada junto al servidor para ver las bases de datos.

  5. Seleccione la flecha situada junto a la base de datos que desee.

  6. Seleccione la tabla que desee.

  7. Para obtener una vista previa de los datos, seleccione Ejecutar.

  8. Cuando esté listo, seleccione Devolver datos.

  9. En el cuadro de diálogo Importar datos , elija dónde desea que se encuentren los datos: en la hoja existente, en una hoja nueva o en una tabla dinámica.

  10. Seleccione Aceptar.

  11. Para asegurarse de que la conexión funciona, escriba algunos datos y, después, seleccione Datos > Actualizar todo.

Si los permisos no funcionan, es posible que no los borre primero y, a continuación, inicie sesión.

  1. Seleccione Conexiones de > de datos. Aparecerá el cuadro de diálogo Conexiones del libro .

  2. Seleccione la conexión que desee en la lista y, a continuación, seleccione Borrar permisos.

    Quitar credenciales guardadas para una conexión de datos en Mac

Vea también

Ayuda de Power Query para Excel

Controladores ODBC compatibles con Excel para Mac

Crear una tabla dinámica para analizar datos de una hoja de cálculo

¿Necesita más ayuda?

Ampliar sus conocimientos
Explorar los cursos
Obtener nuevas características primero
Unirse a Microsoft Office Usuarios de Insider

¿Le ha sido útil esta información?

¿Cuál es tu grado de satisfacción con la calidad del lenguaje?
¿Qué ha afectado a tu experiencia?

¡Gracias por sus comentarios!

×