Insertar un objeto en una hoja de cálculo de Excel

Nota: Nos gustaría proporcionarle el contenido de ayuda actual lo más rápido posible en su idioma. Esta página se ha traducido mediante un sistema automático y es posible que contenga imprecisiones o errores gramaticales. Nuestro objetivo es que este contenido sea útil para usted. ¿Puede informarnos sobre si la información le ha sido útil al final de la página? Aquí tiene el artículo en inglés para que pueda consultarlo fácilmente.

Puede usar la vinculación e incrustación de objetos (OLE) para incluir contenido de otros programas, como Word o Excel.

OLE es compatible con muchos programas diferentes, y se usa OLE para hacer que el contenido creado en un programa esté disponible en otro programa. Por ejemplo, puede insertar un documento de Office Word en un libro de Office Excel. Para ver qué tipos de contenido puede insertar, haga clic en objeto en el grupo texto de la pestaña Insertar . Solo los programas que estén instalados en el equipo y que admitan objetos OLE aparecerán en el cuadro tipo de objeto .

Si copia información entre Excel o cualquier programa que admita OLE, como Word, puede copiar la información como un objeto vinculado o un objeto incrustado. Las principales diferencias entre los objetos vinculados y los objetos incrustados son el lugar donde se almacenan los datos y cómo se actualiza el objeto después de colocarlo en el archivo de destino. Los objetos incrustados se almacenan en el libro en el que están insertados y no se actualizan. Los objetos vinculados permanecen como archivos independientes y se pueden actualizar.

Objetos vinculados e incrustados en un documento

Objetos vinculados e incrustados en un documento de Office para Windows

1. un objeto incrustado no tiene conexión al archivo de origen.

2. un objeto vinculado está vinculado al archivo de origen.

3. el archivo de código fuente actualiza el objeto vinculado.

Cuándo usar objetos vinculados

Si desea que la información de su archivo de destino se actualice cuando cambien los datos de la archivo de origen, use objetos vinculados.

Con un objeto vinculado, la información original permanece almacenada en el archivo de origen. El archivo de destino muestra una representación de la información vinculada pero solo almacena la ubicación de los datos originales (y el tamaño si el objeto es un objeto de gráfico de Excel). El archivo de origen debe permanecer disponible en el equipo o en la red para mantener el vínculo a los datos originales.

La información vinculada se puede actualizar automáticamente si cambia los datos originales en el archivo de origen. Por ejemplo, si selecciona un párrafo en un documento de Word y, a continuación, pega el párrafo como un objeto vinculado en un libro de Excel, la información se puede actualizar en Excel si cambia la información en el documento de Word.

Cuándo usar objetos incrustados

Si no desea actualizar los datos copiados cuando cambia en el archivo de origen, use un objeto incrustado. La versión de la fuente de la fuente está totalmente incrustada en el libro. Si copia información como un objeto incrustado, el archivo de destino requiere más espacio en disco que si se vincula la información.

Cuando un usuario abre el archivo en otro equipo, puede ver el objeto incrustado sin tener acceso a los datos originales. Dado que un objeto incrustado no tiene vínculos al archivo de origen, el objeto no se actualizará si cambia los datos originales. Para cambiar un objeto incrustado, haga doble clic en el objeto para abrirlo y editarlo en el programa de origen. El programa de origen (u otro programa capaz de modificar el objeto) debe estar instalado en el equipo.

Cambiar la forma en que se muestra un objeto OLE

Puede mostrar un objeto vinculado o objeto incrustado en un libro exactamente como aparece en el programa origen o como un icono. Si el libro se va a ver en línea y no tiene previsto imprimir el libro, puede mostrar el objeto como un icono. Esto minimiza la cantidad de espacio de visualización que ocupa el objeto. Los visores que deseen Mostrar la información pueden hacer doble clic en el icono.

Insertar un objeto en una hoja de cálculo

  1. Haga clic en la celda de la hoja de cálculo donde quiere insertar el objeto.

  2. En la pestaña Insertar , en el grupo texto , haga clic en el Icono de objeto en la cinta de opciones del objeto .
    Insertar objeto

  3. En el cuadro de diálogo objeto , haga clic en la pestaña crear desde archivo .

  4. Haga clic en Examinar y seleccione el archivo que quiere insertar.

  5. Si quiere insertar un icono en la hoja de cálculo en lugar de mostrar el contenido del archivo, active la casilla Mostrar como icono. Si no activa ninguna casilla, Excel muestra la primera página del archivo. En ambos casos, al hacer doble clic se abre el archivo completado. Haga clic en Aceptar.

    Nota: Después de agregar el icono o el archivo, puede arrastrarlo y colocarlo en cualquier lugar de la hoja de cálculo. También puede cambiar el tamaño del icono o el archivo mediante los controladores de tamaño. Para buscar los controladores, haga clic una vez en el archivo o el icono.

Insertar un vínculo a un archivo

Es posible que quiera agregar un vínculo al objeto en lugar de incrustarlo completamente. Puede hacerlo si el libro y el objeto que quiere agregar están almacenados en un sitio de SharePoint, una unidad de red compartida o una ubicación similar, y la ubicación de los archivos no va a cambiar. Esto resulta útil si se modifica el objeto vinculado, porque el vínculo siempre abre el documento más reciente.

Nota: Si mueve el archivo vinculado a otra ubicación, el vínculo deja de funcionar.

  1. Haga clic en la celda de la hoja de cálculo donde quiere insertar el objeto.

  2. En la pestaña Insertar , en el grupo texto , haga clic en el Icono de objeto en la cinta de opciones del objeto.
    Insertar objeto

  3. Haga clic en la pestaña crear desde archivo .

  4. Haga clic en Examinar y seleccione el archivo que quiere vincular.

  5. Active la casilla Vincular a archivo y haga clic en Aceptar.

Crear un nuevo objeto desde dentro de Excel

Puede crear un objeto completamente nuevo basado en otro programa sin salir de su libro. Por ejemplo, si quiere agregar una explicación más detallada a un gráfico o tabla, puede crear un documento incrustado, como un archivo de Word o PowerPoint, en Excel. Puede establecer el objeto para que se muestre directamente en una hoja de cálculo o agregar un icono que abre el archivo.

Este objeto incrustado es un documento de Word.
  1. Haga clic en la celda de la hoja de cálculo donde quiere insertar el objeto.

  2. En la pestaña Insertar , en el grupo texto , haga clic en el Icono de objeto en la cinta de opciones del objeto.
    Insertar objeto

  3. En la pestaña Crear nuevo, seleccione el tipo de objeto que quiere insertar de la lista. Si quiere insertar un icono en la hoja de cálculo en lugar del objeto en sí, active la casilla Mostrar como icono.

  4. Haga clic en Aceptar. Según el tipo de archivo que se va a insertar, se abre una nueva ventana de programa o bien aparece una ventana de edición dentro de Excel.

  5. Cree el nuevo objeto que quiere insertar.

    Cuando haya terminado, si Excel abrió una nueva ventana del programa en el que se creó el objeto, puede trabajar directamente en ella.

    Puede editar el documento de Word incrustado directamente en Excel.

    Cuando haya terminado de trabajar en la ventana, puede realizar otras tareas sin guardar el objeto incrustado. Cuando se cierra el libro, los objetos nuevos se guardarán automáticamente.

    Nota: Después de agregar el objeto, puede arrastrarlo y colocarlo en cualquier lugar de la hoja de cálculo de Excel. También puede cambiar el tamaño del objeto mediante los controladores de tamaño. Para buscar los controladores, haga clic una vez en el objeto.

Insertar un objeto en una hoja de cálculo

  1. Haga clic en la celda de la hoja de cálculo donde quiere insertar el objeto.

  2. En la pestaña Insertar, en el grupo Texto, haga clic en Objeto.

    La opción Objeto está en la pestaña Insertar.
  3. Haga clic en la pestaña Crear desde archivo.

    La pestaña "Crear de un archivo" en el cuadro de diálogo Objeto.
  4. Haga clic en Examinar y seleccione el archivo que quiere insertar.

  5. Si quiere insertar un icono en la hoja de cálculo en lugar de mostrar el contenido del archivo, active la casilla Mostrar como icono. Si no activa ninguna casilla, Excel muestra la primera página del archivo. En ambos casos, al hacer doble clic se abre el archivo completado. Haga clic en Aceptar.

    Nota: Después de agregar el icono o el archivo, puede arrastrarlo y colocarlo en cualquier lugar de la hoja de cálculo. También puede cambiar el tamaño del icono o el archivo mediante los controladores de tamaño. Para buscar los controladores, haga clic una vez en el archivo o el icono.

Insertar un vínculo a un archivo

Es posible que quiera agregar un vínculo al objeto en lugar de incrustarlo completamente. Puede hacerlo si el libro y el objeto que quiere agregar están almacenados en un sitio de SharePoint, una unidad de red compartida o una ubicación similar, y la ubicación de los archivos no va a cambiar. Esto resulta útil si se modifica el objeto vinculado, porque el vínculo siempre abre el documento más reciente.

Nota: Si mueve el archivo vinculado a otra ubicación, el vínculo deja de funcionar.

  1. Haga clic en la celda de la hoja de cálculo donde quiere insertar el objeto.

  2. En la pestaña Insertar, en el grupo Texto, haga clic en Objeto.

    La opción Objeto está en la pestaña Insertar.
  3. Haga clic en la pestaña Crear desde archivo.

  4. Haga clic en Examinar y seleccione el archivo que quiere vincular.

  5. Active la casilla Vincular a archivo y haga clic en Aceptar.

    En la pestaña "Crear de un archivo", seleccione "Vincular al archivo".

Crear un nuevo objeto desde dentro de Excel

Puede crear un objeto completamente nuevo basado en otro programa sin salir de su libro. Por ejemplo, si quiere agregar una explicación más detallada a un gráfico o tabla, puede crear un documento incrustado, como un archivo de Word o PowerPoint, en Excel. Puede establecer el objeto para que se muestre directamente en una hoja de cálculo o agregar un icono que abre el archivo.

Este objeto incrustado es un documento de Word.
  1. Haga clic en la celda de la hoja de cálculo donde quiere insertar el objeto.

  2. En la pestaña Insertar, en el grupo Texto, haga clic en Objeto.

    La opción Objeto está en la pestaña Insertar.
  3. En la pestaña Crear nuevo, seleccione el tipo de objeto que quiere insertar de la lista. Si quiere insertar un icono en la hoja de cálculo en lugar del objeto en sí, active la casilla Mostrar como icono.

    La pestaña Crear nuevo en el cuadro de diálogo Objeto.
  4. Haga clic en Aceptar. Según el tipo de archivo que se va a insertar, se abre una nueva ventana de programa o bien aparece una ventana de edición dentro de Excel.

  5. Cree el nuevo objeto que quiere insertar.

    Cuando haya terminado, si Excel abrió una nueva ventana del programa en el que se creó el objeto, puede trabajar directamente en ella.

    Puede editar el documento de Word incrustado directamente en Excel.

    Cuando haya terminado de trabajar en la ventana, puede realizar otras tareas sin guardar el objeto incrustado. Cuando se cierra el libro, los objetos nuevos se guardarán automáticamente.

    Nota: Después de agregar el objeto, puede arrastrarlo y colocarlo en cualquier lugar de la hoja de cálculo de Excel. También puede cambiar el tamaño del objeto mediante los controladores de tamaño. Para buscar los controladores, haga clic una vez en el objeto.

Vincular o incrustar contenido de otro programa mediante OLE

Puede vincular o incrustar todo el contenido de otro programa o parte de él.

Crear un vínculo a contenido de otro programa

  1. Haga clic en la hoja de cálculo en la que desea colocar el objeto vinculado.

  2. En la pestaña Insertar, en el grupo Texto, haga clic en Objeto.

    Imagen de la cinta de Excel

  3. Haga clic en la pestaña Crear desde archivo.

  4. En el cuadro nombre de archivo , escriba el nombre del archivo o haga clic en examinar para seleccionarlo de una lista.

  5. Active la casilla vincular al archivo .

  6. Siga uno de estos procedimientos:

    • Para mostrar el contenido, desactive la casilla Mostrar como icono .

    • Para mostrar un icono, active la casilla Mostrar como icono . De manera opcional, para cambiar la imagen o etiqueta de icono predeterminada, haga clic en Cambiar iconoy, a continuación, haga clic en el icono que desee de la lista de iconos o escriba una etiqueta en el cuadro título .

    Nota: No puede usar el comando objeto para insertar gráficos y determinados tipos de archivos. Para insertar un gráfico o archivo, en la pestaña Insertar , en el grupo ilustraciones , haga clic en imagen.

Insertar contenido de otro programa

  1. Haga clic en la hoja de cálculo en la que desea colocar el objeto incrustado.

  2. En la pestaña Insertar, en el grupo Texto, haga clic en Objeto.

    Imagen de la cinta de Excel

  3. Si el documento aún no existe, haga clic en la pestaña crear nuevo . En el cuadro tipo de objeto , haga clic en el tipo de objeto que desea crear.

    Si el documento ya existe, haga clic en la pestaña crear desde archivo . En el cuadro nombre de archivo , escriba el nombre del archivo o haga clic en examinar para seleccionarlo de una lista.

  4. Desactive la casilla vincular al archivo .

  5. Siga uno de estos procedimientos:

    • Para mostrar el contenido, desactive la casilla Mostrar como icono .

    • Para mostrar un icono, active la casilla Mostrar como icono . Para cambiar la imagen o etiqueta predeterminada del icono, haga clic en Cambiar iconoy, a continuación, haga clic en el icono que desee de la lista de iconos o escriba una etiqueta en el cuadro título .

Vincular o incrustar contenido parcial de otro programa

  1. Desde un programa que no sea Excel, seleccione la información que desea copiar como vinculada o objeto incrustado.

  2. En el grupo Portapapeles de la pestaña Inicio, haga clic en Copiar.

    Imagen de la cinta de Excel

  3. Cambie a la hoja de cálculo en la que desea colocar la información y, a continuación, haga clic en el lugar donde desea que aparezca la información.

  4. En el grupo Portapapeles de la pestaña Inicio, haga clic en la flecha situada debajo de Pegar y en Pegado especial.

  5. Siga uno de estos procedimientos:

    • Para pegar la información como un objeto vinculado, haga clic en pegar vínculo.

    • Para pegar la información como un objeto incrustado, haga clic en pegar. En el cuadro como , haga clic en la entrada con la palabra "objeto" en el nombre. Por ejemplo, si ha copiado la información de un documento de Word, haga clic en objeto de documento de Microsoft Word.

Cambiar la forma en que se muestra un objeto OLE

  1. Haga clic con el botón secundario en el icono o el objeto, seleccioneobjeto de tipo de objeto(por ejemplo, objeto documento) y haga clic en convertir.

  2. Siga uno de estos procedimientos:

    • Para mostrar el contenido, desactive la casilla Mostrar como icono .

    • Para mostrar un icono, active la casilla Mostrar como icono . De manera opcional, puede cambiar la imagen o etiqueta predeterminada del icono. Para ello, haga clic en Cambiar iconoy, a continuación, haga clic en el icono que desee de la lista de iconos o escriba una etiqueta en el cuadro título .

Controlar las actualizaciones de objetos vinculados

Puede configurar los vínculos a otros programas para que se actualicen de las siguientes maneras: automáticamente, al abrir la archivo de destino; de forma manual, cuando desee ver los datos anteriores antes de actualizarlos con los nuevos datos de la archivo de origen; o cuando solicite específicamente la actualización, independientemente de si la actualización automática o manual está activada.

Establecer un vínculo a otro programa para que se actualice manualmente

  1. En el grupo Conexiones de la pestaña Datos, haga clic en Modificar vínculos.

    Imagen de la cinta de Excel

    Nota: El comando modificar vínculos no está disponible si el archivo no contiene vínculos a otros archivos.

  2. En la lista Origen, haga clic en el objeto vinculado que desee actualizar. Una A en la columna Actualizar significa que el vínculo es automático y una M en la columna Actualizar significa que el vínculo se establece en actualización manual .

    Sugerencia: Para seleccionar varios objetos vinculados, mantenga presionada la tecla Ctrl y haga clic en cada objeto vinculado. Para seleccionar todos los objetos vinculados, presione CTRL + e.

  3. Para actualizar un objeto vinculado al hacer clic en actualizar valores, haga clic en manual.

Establecer un vínculo a otro programa para que se actualice automáticamente

  1. En el grupo Conexiones de la pestaña Datos, haga clic en Modificar vínculos.

    Imagen de la cinta de Excel

    Nota: El comando modificar vínculos no está disponible si el archivo no contiene vínculos a otros archivos.

  2. En la lista Origen, haga clic en el objeto vinculado que desee actualizar. Una A en la columna Actualizar significa que el vínculo se actualizará automáticamente y una M en la columna Actualizar significa que el vínculo debe actualizarse manualmente.

    Sugerencia: Para seleccionar varios objetos vinculados, mantenga presionada la tecla Ctrl y haga clic en cada objeto vinculado. Para seleccionar todos los objetos vinculados, presione CTRL + e.

  3. Haga clic en Aceptar.

Problema: no puedo actualizar los vínculos automáticos en mi hoja de cálculo

La opción automática puede ser reemplazada por la opción de Excel actualizar vínculos a otros documentos .

Para asegurarse de que los vínculos automáticos a objetos OLE pueden actualizarse automáticamente:

  1. Haga clic en el botón Microsoft Office Imagen del botón de Microsoft Office , haga clic en Opciones de Excely, a continuación, haga clic en la categoría avanzadas .

  2. En al calcular este libro, asegúrese de que la casilla de verificación actualizar vínculos a otros documentos está activada.

Actualizar un vínculo a otro programa ahora

  1. En el grupo Conexiones de la pestaña Datos, haga clic en Modificar vínculos.

    Imagen de la cinta de Excel

    Nota: El comando Modificar vínculos no está disponible si el archivo no contiene vínculos a otros archivos.

  2. En la lista Origen, haga clic en el objeto vinculado que desee actualizar.

    Sugerencia: Para seleccionar varios objetos vinculados, mantenga presionada la tecla Ctrl y haga clic en cada objeto vinculado. Para seleccionar todos los objetos vinculados, presione CTRL + e.

  3. Haga clic en Actualizar valores.

Editar el contenido de un programa OLE

Mientras está en Excel, puede cambiar el contenido vinculado o incrustado de otro programa.

Modificar un objeto vinculado en el programa de origen

  1. En el grupo Conexiones de la pestaña Datos, haga clic en Modificar vínculos.

    Imagen de la cinta de Excel

    Nota: El comando Modificar vínculos no está disponible si el archivo no contiene vínculos a otros archivos.

  2. En la lista archivo de origen , haga clic en el origen de la objeto vinculado y, a continuación, haga clic en Abrir origen.

  3. Realice los cambios que desee en el objeto vinculado.

  4. Salga de programa origen para volver al archivo de destino.

Editar un objeto incrustado en el programa de origen

  1. Haga doble clic en el objeto incrustado para abrirlo.

  2. Realice los cambios que desee en el objeto.

  3. Si está editando el objeto en su lugar dentro del programa abierto, haga clic en cualquier lugar fuera del objeto para volver a la archivo de destino.

    Si modifica el objeto incrustado en el programa de origen en una ventana independiente, salga del programa de origen para volver al archivo de destino.

Nota: Al hacer doble clic en determinados objetos incrustados, como clips de audio y vídeo, se reproduce el objeto en lugar de abrir un programa. Para modificar uno de estos objetos incrustados, haga clic con el botón derecho en el icono o el objeto, elijaobjeto de tipo de objeto(por ejemplo, objeto de clip multimedia) y, a continuación, haga clic en Editar.

Editar un objeto incrustado en un programa distinto del programa de origen

  1. Seleccione el objeto incrustado que desea editar.

  2. Haga clic con el botón secundario en el icono o el objeto, seleccioneobjeto de tipo de objeto(por ejemplo, objeto documento) y haga clic en convertir.

  3. Siga uno de estos procedimientos:

    • Para convertir el objeto incrustado al tipo que especifique en la lista, haga clic en convertiren.

    • Para abrir el objeto incrustado como el tipo que especifique en la lista sin cambiar el tipo de objeto incrustado, haga clic en Activar.

Seleccionar un objeto OLE mediante el teclado

  1. Presione CTRL + G para mostrar el cuadro de diálogo ir a .

  2. Haga clic en especial, seleccione objetosy, a continuación, haga clic en Aceptar.

  3. Presione la tecla TAB hasta seleccionar el objeto que quiera.

  4. Presione Mayús + F10.

  5. Elija objeto u objeto de gráficoy, a continuación, haga clic en Editar.

Problema: al hacer doble clic en un objeto vinculado o incrustado, aparece el mensaje "no se puede modificar"

Este mensaje aparece cuando archivo de origen o programa origen no se pueden abrir.

Asegúrese de que el programa de origen esté disponible     Si el programa de origen no está instalado en el equipo, convierta el objeto al formato de archivo de un programa que haya instalado.

Asegurarse de que la memoria sea adecuada     Asegúrese de que tiene suficiente memoria para ejecutar el programa de origen. Cierre otros programas para liberar memoria, si es necesario.

Cerrar todos los cuadros de diálogo     Si el programa de origen se está ejecutando, asegúrese de que no tiene ningún cuadro de diálogo abierto. Cambie al programa de origen y cierre todos los cuadros de diálogo abiertos.

Cerrar el archivo de origen     Si el archivo de origen es un objeto vinculado, asegúrese de que otro usuario no lo tiene abierto.

Asegúrese de que el nombre del archivo de origen no ha cambiado     Si el archivo de origen que desea editar es un objeto vinculado, asegúrese de que tiene el mismo nombre que tenía cuando creó el vínculo y que no se ha movido. Seleccione el objeto vinculado y, a continuación, haga clic en el comando modificar vínculos en el grupo conexiones de la pestaña datos para ver el nombre del archivo de origen. Si el archivo de origen ha cambiado de nombre o se ha movido, use el botón cambiar fuente en el cuadro de diálogo modificar vínculos para localizar el archivo de origen y volver a conectar el vínculo.

¿Necesita más ayuda?

Siempre puede preguntar a un experto en Excel Tech Community, obtener soporte técnico en la Comunidad de respuestas o sugerir una característica nueva o mejora en el UserVoice de Excel.

Ampliar sus conocimientos de Office
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×