Insertar un selector de fecha

Se aplica a
InfoPath 2010 InfoPath 2013

Importante

El soporte técnico para Microsoft InfoPath 2013 finalizó el 14 de julio de 2026. Recomendamos migrar los formularios y flujos de trabajo existentes de InfoPath a soluciones de Microsoft 365 compatibles. Obtenga más información sobre la retirada de InfoPath.

Un selector de fecha es un control que permite a los usuarios especificar rápidamente las fechas en un formulario de InfoPath de Microsoft Office haciendo clic en un pequeño calendario emergente. Por ejemplo, puede usar un selector de fecha para recopilar fechas de nacimiento de personas en un formulario de seguro. También puedes usar un selector de fecha para mostrar fechas preestablecidas, como la fecha actual.

En este artículo

Cuándo usar un selector de fecha

Use un selector de fecha cuando quiera:

  • Permitir que los usuarios especifiquen las fechas que prefieran en un formulario, como las fechas de inicio y finalización de un proyecto determinado.
  • Use las funciones hoy y ahora para mostrar la fecha y hora de hoy en un formulario.
  • Muestra las fechas de un origen de datos externo, como las fechas de facturación y envío de una base de datos de pedidos de clientes.

En la siguiente ilustración, se usa un selector de fecha en una plantilla de formulario de solicitud de viaje para recopilar la fecha de salida de un vuelo.

Campo de fecha de salida con un botón selector de fecha

Puede personalizar el selector de fecha para que se adapte a sus necesidades haciendo doble clic en el control de la plantilla de formulario y cambiando sus propiedades. Por ejemplo, puede especificar una fecha predeterminada o cambiar la forma en que la fecha se muestra en el formulario.

Principio de página

La experiencia de usuario

Los selectores de fecha parecen cuadros de texto, excepto que aparece un pequeño icono de calendario en el lado derecho del cuadro. Para abrir el calendario emergente, los usuarios hacen clic en el icono del calendario. Cuando aparezca el calendario, los usuarios podrán hacer clic en la fecha que deseen o usar las flechas derecha e izquierda para desplazarse por los meses. Si los usuarios desean insertar la fecha actual, pueden hacer clic en el botón Hoy en la parte inferior del calendario.

Abrir el calendario del selector de fecha con navegación por meses y botón Hoy

Principio de página

Consideraciones de compatibilidad

Al diseñar una plantilla de formulario en InfoPath, puede elegir un modo de compatibilidad específico para diseñar una plantilla de formulario compatible con el explorador. Cuando se publica una plantilla de formulario compatible con el explorador en un servidor que ejecuta InfoPath Forms Services y, posteriormente, habilitada para el explorador, los formularios basados en la plantilla de formulario se pueden ver en un explorador web. Al diseñar una plantilla de formulario compatible con exploradores, algunos controles no están disponibles en el panel de tareas Controles porque no se pueden mostrar en un explorador web.

Aunque los selectores de fecha están disponibles cuando diseña una plantilla de formulario compatible con el explorador, tenga en cuenta las siguientes limitaciones:

  • Los selectores de fecha solo son totalmente compatibles con los exploradores Windows Internet Explorer. En otros exploradores web, el selector de fecha aparece como un cuadro de texto, aunque las opciones de formato de fecha son compatibles con el cuadro de texto.
  • El texto de marcador de posición es el texto que aparece dentro de un control en una plantilla de formulario. Un ejemplo de texto de marcador de posición es "Haz clic aquí y escribe". Aunque puede dejar la configuración de texto de marcador de posición para las plantillas de formulario compatibles con el explorador, ese texto no aparece en los exploradores web.

Principio de página

Inserte un selector de fecha

El procedimiento para insertar un selector de fecha difiere ligeramente en función de si está diseñando una nueva plantilla de formulario en blanco o si basa el diseño de la plantilla de formulario en una base de datos u otro origen de datos externo.

La siguiente ilustración muestra el aspecto de un selector de fecha cuando se selecciona en modo de diseño.

Selector de fecha seleccionado en el modo de diseño de InfoPath

Los controles pueden estar enlazados o no enlazados. Cuando un control está enlazado, está conectado a un campo o grupo en el origen de datos para que los datos introducidos en el control se guarden en el archivo de formulario subyacente (.xml). Cuando un control no está enlazado, no está conectado a un campo o grupo y los datos introducidos en el control no se guardan. Cuando seleccione o mueva el puntero sobre un control, aparecerán en la esquina superior derecha del control un texto y un icono de enlace. El texto indica el grupo o campo al que está enlazado el control en el origen de datos. El icono indica si el control está correctamente enlazado a ese grupo o campo. Cuando el enlace es correcto, aparece un icono verde. Si hay algún error con el enlace, verá un icono azul o rojo en su lugar.

El origen de datos de la plantilla de formulario está formado por campos y grupos que se muestran en una vista jerárquica en el panel de Origen de datos. Los controles selector de fecha siempre están enlazados a los campos. En el ejemplo siguiente, el selector de fecha de salida de la plantilla de formulario está enlazado al campo fechadesalida del panel de tareas Origen de datos .

Selector de fecha de salida enlazado al campo de origen de datos departureDate

Insertar un selector de fecha en una nueva plantilla de formulario en blanco

Cuando se diseña una plantilla de formulario nueva, se selecciona automáticamente la casilla Crear automáticamente origen de datos en el panel de Controles. Esto permite que InfoPath cree automáticamente los campos y grupos en el origen de datos a medida que agregue controles a la plantilla de formulario. Estos campos y grupos están representados por iconos de archivo y carpeta en el panel de Origen de datos.

  1. En la plantilla de formulario, coloque el cursor en el lugar donde desea insertar el control.

  2. Si el panel Controles no es visible, haga clic en Más controles en el menú Insertar, o bien, presione ALT+I, C.

  3. En Insertar controles, haga clic en Selector de fecha.

  4. Para agregar una etiqueta al control, escriba el texto por encima o a la izquierda del control, seguido por dos puntos (:).

  5. Para especificar la forma en que se muestra la fecha en el formulario, haga doble clic en el selector de fecha que se insertó en la plantilla de formulario.

  6. Haga clic en la pestaña Datos y luego en Formato.

  7. En la lista Mostrar la fecha como esta , en el cuadro de diálogo Formato de fecha , haga clic en el formato de presentación que desee.

    Nota

    Puede cambiar el formato de presentación de la fecha solo si el tipo de datos es Texto, Fecha o Fecha y hora.

Inserte un selector de fecha en una plantilla de formulario que se base en un origen de datos existente

Si basa el diseño de la plantilla de formulario en un archivo, base de datos o servicio web de lenguaje de marcado extensible (XML), InfoPath deriva los campos y grupos en el panel de Origen de datos de los orígenes de datos ya existentes. En este escenario, puede agregar un selector de fecha arrastrando un campo de selector de fecha desde el panel de tareas Origen de datos a la plantilla de formulario o insertando el selector de fecha mediante el panel de tareas Controles , como se describe en el procedimiento siguiente:

  1. En la plantilla de formulario, coloque el cursor en el lugar donde desea insertar el control.

  2. Si el panel Controles no es visible, haga clic en Más controles en el menú Insertar, o bien, presione ALT+I, C.

  3. En Insertar controles, haga clic en Selector de fecha.

  4. En el cuadro de diálogo Enlace del selector de fecha , selecciona el campo en el que quieras almacenar los datos del selector de fecha y, a continuación, haz clic en Aceptar.

  5. InfoPath utiliza el nombre del campo o grupo como etiqueta de control. Si es necesario, cambie el texto de etiqueta.

  6. Para especificar la forma en que se muestra la fecha en el formulario, haga doble clic en el selector de fecha que se insertó en la plantilla de formulario.

  7. En la pestaña Datos , haga clic en Formato.

  8. En el cuadro de lista Mostrar la fecha como esta , en el cuadro de diálogo Formato de fecha , haga clic en el formato de presentación que desee.

    Nota

    Puede cambiar el formato de presentación de la fecha solo si el tipo de datos es Texto, Fecha o Fecha y hora.

Recomendación

También puede usar el panel de tareas Origen de datos para insertar controles. En el panel de tareas Origen de datos , haga clic con el botón secundario en el campo al que desea enlazar el selector de fecha y, después, haga clic en Selector de fecha en el menú contextual.

Principio de página

Mostrar la fecha actual en un selector de fecha

Para insertar automáticamente la fecha actual en un formulario cuando los usuarios lo abran, puede usar la función hoy con un control de selector de fecha.

  1. Inserta un selector de fecha en la plantilla de formulario.

  2. Haga doble clic en el selector de fecha que insertó en la plantilla de formulario.

  3. Haga clic en la pestaña Datos.

  4. En Valor predeterminado, haga clic en Insertar fórmula .

  5. En el cuadro de diálogo Insertar fórmula , haga clic en Insertar función.

  6. En la lista Categorías del cuadro de diálogo Insertar función , haga clic en Fecha y hora.

  7. En la lista Funciones , haga clic en Hoy y luego en Aceptar dos veces para volver al cuadro de diálogo Propiedades del selector de fecha .
    Observe que today() aparece en el cuadro Valor .

  8. En Valor predeterminado, desactive la casilla Actualizar este valor cuando se vuelva a calcular el resultado de la fórmula .

    Nota

    Si desactiva esta casilla, la fecha no se actualizará automáticamente cada vez que un usuario abra un formulario basado en esta plantilla de formulario. Esto es ideal en situaciones en las que desea que los usuarios vean la fecha en que se creó el formulario. Puede dejar la casilla activada en situaciones en las que tenga un campo Última actualización el o Último abierto el, donde desea que la fecha cambie cada vez que se abre el formulario.

  9. Haga clic en Aceptar para volver a la plantilla de formulario.

  10. Para probar sus cambios, haga clic en Vista previa en la barra Estándar, o presione CTRL+MAYÚS+B.

  11. Compruebe que la fecha que aparece en el selector de fecha tiene el aspecto que quiere. Si no es así, puede cambiar la forma en que se muestra la fecha u hora haciendo clic en el botón Formato en el cuadro de diálogo Propiedades del selector de fecha .

Principio de página

Mostrar la fecha y hora actuales en un selector de fecha

Para insertar automáticamente la fecha y hora actuales en un formulario cuando los usuarios lo abran, puede usar la función ahora con un control de selector de fecha.

  1. Inserta un selector de fecha en la plantilla de formulario.

  2. Haga doble clic en el selector de fecha que insertó en la plantilla de formulario.

  3. Haga clic en la pestaña Datos.

  4. En el cuadro Tipo de datos , haga clic en Fecha y hora (dateTime).

  5. Haga clic en Formato.

  6. En el cuadro de diálogo Formato de fecha y hora , en la lista Mostrar la hora como esta , haga clic en la opción que desee y luego en Aceptar.

  7. En el cuadro de diálogo Propiedades del selector de fecha , en Valor predeterminado, haga clic en Insertar fórmula .

  8. En el cuadro de diálogo Insertar fórmula , haga clic en Insertar función.

  9. En la lista Categorías del cuadro de diálogo Insertar función , haga clic en Fecha y hora.

  10. En la lista Funciones , haga clic en Ahora y luego en Aceptar dos veces para volver al cuadro de diálogo Propiedades del selector de fecha .
    Observe que now() aparece en el cuadro Valor .

  11. En Valor predeterminado, desactive la casilla Actualizar este valor cuando se vuelva a calcular el resultado de la fórmula .

    Nota

    Si desactiva esta casilla, la fecha no se actualizará automáticamente cada vez que un usuario abra un formulario basado en esta plantilla de formulario. Esto es ideal en situaciones en las que desea que los usuarios vean la fecha en que se creó el formulario. Puede dejar la casilla activada en situaciones en las que tenga un campo Última actualización el o Último abierto el, donde desea que la fecha cambie cada vez que se abre el formulario.

  12. Haga clic en Aceptar para volver a la plantilla de formulario.

  13. Para probar sus cambios, haga clic en Vista previa en la barra Estándar, o presione CTRL+MAYÚS+B.

  14. Compruebe que la fecha que aparece en el selector de fecha tiene el aspecto que quiere. Si no es así, puede cambiar la forma en que se muestra la fecha u hora haciendo clic en el botón Formato en el cuadro de diálogo Propiedades del selector de fecha .

Principio de página

Sugerencias de diseño

Use las siguientes sugerencias para refinar la apariencia, el tamaño y otros aspectos de un selector de fecha:

  • Para cambiar el tamaño de varios selectores de fecha a la vez, selecciona los selectores de fecha cuyo tamaño quieres cambiar, en el menú Formato , haz clic en Propiedades y, a continuación, en la pestaña Tamaño , realiza los ajustes necesarios.
  • Para cambiar el borde o el color de un selector de fecha, seleccione el selector de fecha y, en el menú Formato , haga clic en Bordes y sombreado y realice los ajustes necesarios.
  • Para personalizar el texto que aparece en un selector de fecha, use los cuadros Fuente y Tamaño de fuente de la barra de herramientas de Formato . Para cambiar la fuente y el tamaño de fuente de todos los selectores de fecha de la plantilla de formulario a la vez, haga clic con el botón derecho en el selector de fecha que contiene el formato que desea y, después, haga clic en Aplicar fuente a todos los controles del selector de fecha en el menú contextual.
  • Para ver el aspecto que tendrá el selector de fecha con el texto real, haga clic en Datos de ejemplo en el menú Ver . Esto le ayudará a hacerse una idea del aspecto que tendrá el formulario cuando los usuarios lo rellenen.
  • En ocasiones, el texto dentro de un selector de fecha y la etiqueta a la izquierda del selector de fecha pueden parecer ligeramente desalineados. Para volver a alinearlos rápidamente, haz doble clic en el selector de fecha, haz clic en Alinear en la pestaña Tamaño y, a continuación, haz clic en Aplicar. Si el selector de etiqueta y fecha se encuentra en celdas distintas en una tabla de diseño, haga clic con el botón secundario en la celda que contiene la etiqueta, haga clic en Propiedades de tabla en el menú contextual y, a continuación, haga clic en Centrar , en Alineación vertical en la pestaña Celda .
  • Para cambiar la forma en que se muestra la fecha, haga doble clic en el selector de fecha, haga clic en la pestaña Datos y, a continuación, haga clic en el botón Formato . Elija un formato de presentación en el cuadro de diálogo Formato de fecha .

Principio de página