O (función O)

Use la función O, una de las funciones lógicas, para determinar si algunas condiciones de una prueba son VERDADERAS.

Ejemplo

Ejemplos de uso de la función O.

La función O devuelve VERDADERO si alguno de sus argumentos se evalúa como VERDADERO, y devuelve FALSO si todos sus argumentos se evalúan como FALSO.

Un uso común para la función O es expandir la utilidad de otras funciones que realicen pruebas lógicas. Por ejemplo, la función SI realiza una prueba lógica y, después, devuelve un valor si la prueba se evalúa en VERDADERO y otro valor si la prueba se evalúa en FALSO. Mediante el uso de la función O como la prueba lógica de la función SI puede probar distintas condiciones en vez de solo una.

Sintaxis

O(valor_lógico1, [valor_lógico2], ...)

La sintaxis de la función O tiene los siguientes argumentos:

Argumento

Descripción

Valor_lógico1

Requerido. La primera condición que quiere probar que puede evaluarse como VERDADERO o FALSO.

Valor_lógico2, ...

Opcional. Las condiciones adicionales que desea probar que pueden evaluarse como VERDADERO o FALSO, hasta un máximo de 255 condiciones.

Observaciones

  • Los argumentos deben evaluarse como valores lógicos, como VERDADERO o FALSO, o bien en matrices o referencias que contengan valores lógicos.

  • Si un argumento matricial o de referencia contiene texto o celdas vacías, dichos valores se pasarán por alto.

  • Si el rango especificado no contiene valores lógicos, o devuelve el #VALUE! valor de error #¡NUM!.

  • Puede usar una fórmula de matriz O para comprobar si un valor aparece en una matriz. Para introducir una fórmula de matriz, presione CTRL+MAYÚS+ENTRAR.

Ejemplos

Aquí se muestran algunos ejemplos generales del uso de O por sí mismo y junto a la función SI.

Ejemplos de uso de la función O con la función SI.

Fórmula

Descripción

=O(A2>1,A2<100)

Muestra VERDADERO si A2 es superior a 1 O es inferior a 100, de otro modo muestra FALSO.

=SI(O(A2>1,A2<100),A3,"El valor está fuera del rango")

Muestra el valor de la celda A3 si mayor que 1 O es inferior a 100, de otro modo muestra el mensaje "El valor está fuera del rango".

=SI(O(A2<0,A2>50),A2,"El valor está fuera del rango")

Muestra el valor de la celda A2 si es inferior a 0 O es superior a 50, de otro modo muestra un mensaje.

Cálculo de la comisión de ventas

Aquí se muestra un escenario bastante común donde necesitamos calcular si el personal de ventas está cualificado para recibir una comisión mediante SI y O.

Ejemplo de uso de las funciones SI y O para calcular una comisión de ventas.
  • =SI(O(B14>=$B$4,C14>=$B$5),B14*$B$6,0)SI las ventas totales son superiores o iguales (>=) al objetivo de las ventas, O las cuentas son superiores o iguales (>=) al objetivo de la cuenta, entonces se multiplican las ventas totales por el % de la comisión, de otro modo devuelve 0.

¿Necesitas más ayuda?

Siempre puede preguntar a un experto en Excel Tech Community, obtener soporte técnico en la Comunidad de respuestas o sugerir una característica nueva o mejora en el UserVoice de Excel.

Temas relacionados

Vídeo: funciones
si avanzadasaprenda a usar funciones anidadas en una fórmula
si la función
y
la funciónno funcionan
lainformación general de las fórmulas en Excel
Cómo evitar la ruptura de las fórmulas
detecta errores en las fórmulas
métodos abreviados de teclado de Excel
funciones lógicas (referencia)
funciones de Excel (por orden alfabético)Funciones de Excel (por categoría)

Nota:  Esta página se ha traducido mediante un sistema automático y es posible que contenga imprecisiones o errores gramaticales. Nuestro objetivo es que este contenido le resulte útil. ¿Podría decirnos si la información le resultó útil? Aquí puede consultar el artículo en inglés.

Una suscripción para aprovechar al máximo su tiempo

¿Necesita más ayuda?

Ampliar sus conocimientos de Office
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×