Los vínculos del libro se deben mantener y actualizar para que funcionen correctamente. Tendrá que actualizarlos para obtener los valores más recientes y buscarlos en el libro si se rompen.
Actualizar los vínculos del libro
Aquí le mostramos cómo asegurarse de que está recuperando los valores más recientes de los libros de origen.
Actualizar todos los vínculos del libro
- Para abrir el panel Vínculos de libro, seleccioneConsultas y conexiones>de datos>Vínculos de libro.
- Seleccione Actualizar todo en la parte superior del panel.
Actualizar un vínculo específico de un libro
- Para abrir el panel Vínculos de libro, seleccioneConsultas y conexiones>de datos>Vínculos de libro.
- Seleccione el libro de la lista y seleccione Actualizar.
Actualizar todos los vínculos del libro automáticamente
Nota
Los libros de escritorio no tienen el comando Actualizar automáticamente porque esta operación se produce normalmente con un nuevo cálculo automático al abrir el libro. Para obtener más información, vea Cambiar la precisión, la iteración y los nuevos cálculos de fórmulas en Excel.
Controlar la solicitud de inicio para actualizar los vínculos del libro
Puede decidir si los vínculos de este libro se actualizan al abrir el archivo según la configuración del usuario, no se actualizan al abrir el archivo o se actualizan automáticamente sin preguntar al usuario.
Esta opción afecta a todos los usuarios del libro. Si elige no actualizar los vínculos y no preguntar, los usuarios del libro no sabrán que los datos están anticuados.
Para abrir el panel Vínculos de libro, seleccioneConsultas y conexiones>de datos>Vínculos de libro.
Selecciona y expande Configuración de actualización en la esquina superior derecha del panel y selecciona una de las opciones siguientes:
- Solicitar la actualización Le pide al usuario que actualice o no cuando se abra el libro.
- Actualizar siempre Actualiza automáticamente todos los vínculos cuando se abre el libro.
- No actualizar No se actualiza al abrirse y no pregunta al usuario.
Controlar cómo se actualizan los vínculos del libro
Cuando abre un libro de destino y el libro de origen no está abierto, es posible que la barra de confianza le avise para actualizar los vínculos.
Puede controlar si la barra de confianza debe formularle esta pregunta y si desea actualizar todos los vínculos cuando no aparezca esta pregunta. También puede elegir actualizar solo determinados vínculos si el libro contiene más de uno.
Actualizar manualmente todos o ninguno de los vínculos del libro
- Cierre todos los libros de origen. Si un libro de origen queda abierto y los demás se cierran, las actualizaciones no serán uniformes.
- Abra el libro de destino.
- En el cuadro de diálogo de advertencia de vínculos no seguros, seleccione Actualizar. Esto actualiza todos los vínculos de datos del libro.
Si solo desea actualizar vínculos específicos, seleccione No actualizar y vea Cambiar el libro de origen a continuación.
Cuando aparece una barra de advertencia de seguridad al abrir un libro
Si recibe una barra de advertencia de seguridad al abrir un libro por primera vez, significa que todavía no es de confianza. Para confiar en el libro:
Seleccione Habilitar contenido. Esto hace que el libro sea confiable para esta sesión y actualiza los vínculos.
Si un cuadro de diálogo le pide que lo convierta en un documento confiable, seleccione Sí para evitar la advertencia de seguridad en el futuro. Si selecciona no, aparecerá la barra de advertencias de seguridad la próxima vez que abra el libro.
Nota
Dependiendo de la configuración, es posible que también vea el cuadro de diálogo de advertencia de vínculos no seguros.
Mantener vínculos de libros
A veces necesita cambiar el libro de origen, un vínculo del libro se interrumpe o puede que ya no necesite el vínculo del libro.
Abrir el libro de origen
Es posible que desee examinar e inspeccionar el libro de origen primero, antes de realizar cambios importantes.
- Para abrir el panel Vínculos de libro, seleccioneConsultas y conexiones>de datos>Vínculos de libro.
- Seleccione Más comandos (...) junto al libro necesario y, después, seleccione Abrir libro.
Cambiar el libro de origen
Para cambiar el libro de origen de todas las referencias dentro del libro de destino:
- Para abrir el panel Vínculos de libro, seleccioneConsultas y conexiones>de datos>Vínculos de libro.
- Seleccione Más comandos (...) junto al libro necesario y después seleccione Cambiar origen.
- En el cuadro de diálogo Cambiar origen , en Recientes, seleccione el nuevo libro de origen. O bien, seleccione Examinar y, en el cuadro de diálogo, abra el nuevo archivo de origen.
Para cambiar el libro de origen de una referencia concreta dentro del libro de destino:
- Busque el libro que desea usar como nuevo origen de la referencia externa y anote su ubicación.
- En el libro de destino, seleccione la celda con la referencia externa que desea cambiar.
- En la barra de fórmulas, busque una referencia a otro libro, como C:\Reports\[Budget.xlsx], y reemplácela con la ubicación del nuevo libro de origen.
Corregir un vínculo de libro roto
- Para abrir el panel Vínculos de libro, seleccioneConsultas y conexiones>de datos>Vínculos de libro.
-
Seleccione Más comandos (...) junto al libro de datos con vínculos que desea corregir y, a continuación, seleccione Cambiar origen.
- En el cuadro de diálogo Cambiar origen , busque la ubicación del archivo que contiene los datos vinculados.
- Seleccione el nuevo archivo de origen.
Romper un vínculo de libro
Para abrir el panel Vínculos de libro, seleccioneConsultas y conexiones>de datos>Vínculos de libro.
Seleccione Más comandos (...) junto al libro necesario y después seleccione Romper vínculos.
Importante
- Cuando se rompe un vínculo al libro de origen de un vínculo de libro, todas las fórmulas que usan el valor del libro de origen se convierten en sus valores actuales. Por ejemplo, si rompe el vínculo al vínculo del libro =SUMA([Budget.xls]Anual! C10:C25), la fórmula SUMA se reemplaza por el valor calculado, sea cual sea. Además, como esta acción no se puede deshacer, es posible que desee guardar una versión del libro de destino como copia de seguridad.
- Si usa un rango de datos externo, un parámetro de la consulta puede estar usando datos de otro libro. Quizá que sea conveniente comprobar si existen estos tipos de vínculos y quitarlos.
Romper todos los vínculos del libro
- Para abrir el panel Vínculos de libro, seleccioneConsultas y conexiones>de datos>Vínculos de libro.
- Seleccione Dividir todo en la parte superior del panel.
Buscar vínculos de libros
No hay una manera automática de buscar todos los vínculos de libros en un libro. Debe buscar de forma diferente en fórmulas, nombres definidos, objetos (como cuadros de texto o formas), títulos de gráficos y series de datos de gráficos.
Buscar el vínculo del libro siguiente
Puede haber varios vínculos de libro en un libro. Aquí te mostramos cómo localizar la que deseas.
- Para abrir el panel Vínculos de libro, seleccioneConsultas y conexiones>de datos>Vínculos de libro.
- Seleccione el libro de la lista y seleccione Buscar siguiente.
Buscar vínculos de libro usados en fórmulas
Presione Ctrl+F para abrir el cuadro de diálogo Buscar y reemplazar.
Haga clic en Opciones.
En el cuadro Buscar , escriba .xl.
En el cuadro Dentro , haga clic en Libro.
En el cuadro Buscar en , haga clic en Fórmulas.
Haga clic en Buscar todo.
En el cuadro de lista que aparece, busque en la columna Fórmula fórmulas que contengan .xl. En este caso, Excel encontró varias instancias de Master.xlsx de presupuesto.
Para seleccionar la celda con un vínculo de libro, haga clic en el vínculo de dirección de celda para esa fila en el cuadro de lista.
Recomendación
Haga clic en cualquier encabezado de columna para ordenar la columna y agrupar todos los vínculos del libro.
Buscar vínculos de libros usados en nombres definidos
En el grupo Nombres definidos de la pestaña Fórmulas, haga clic en Administrador de nombres.
Compruebe cada entrada de la lista y busque en la columna Se refiere a los vínculos del libro. Los vínculos de libro contienen una referencia a otro libro, como [Budget.xlsx].
Recomendación
- Haga clic en cualquier encabezado de columna para ordenar la columna y agrupar todos los vínculos del libro.
- Puede agrupar varios elementos con las teclas Mayús o Ctrl y hacer clic con el botón izquierdo si desea eliminar varios elementos a la vez.
Buscar vínculos de libro usados en objetos, cuadros de texto o formas
-
Presione Ctrl+G, el método abreviado para el cuadro de diálogo Ir a, luego haga clic enObjetos>especiales>OK. De esta forma, se seleccionarán todos los objetos de la hoja de cálculo activa.
- Presione la tecla Tab para desplazarse entre cada uno de los objetos seleccionados y, a continuación, busque en la barra de fórmulas una
que haga referencia a otro libro, como [Budget.xlsx].
Buscar vínculos de libro usados en títulos de gráficos
- Haga clic en el título del gráfico que desea comprobar.
- En la barra de fórmulas
, busque una referencia a otro libro, como [Budget.xls].
Buscar vínculos de libro usados en series de datos de gráficos
- Seleccione el gráfico que desea comprobar.
- En la pestaña Diseño , en el grupo Selección actual , haga clic en la flecha situada junto al cuadro Elementos de gráfico y, después, haga clic en la serie de datos que desea comprobar.
- En la barra de fórmulas
, busque una referencia a otro libro, como [Budget.xls] en la función SERIE.
Usar el comando Editar vínculos heredado
El comando Editar vínculos heredado se reemplaza por el comando Vínculos del libro . Sin embargo, puede recuperar el comando Editar vínculos anterior agregando el comando Editar vínculos heredado a su grupo personalizado en la cinta de opciones. No puede agregar el comando Editar vínculos al grupo Consultas y conexiones .
Agregue el comando Editar vínculos al grupo personalizado
Con Personalizar la cinta de opciones, debe crear su grupo personalizado y solo entonces puede agregar Editar vínculos a su grupo personalizado en la cinta de opciones de la siguiente manera:
- Haga clic con el botón derecho en la cinta de opciones y seleccione Personalizar la cinta de opciones.
- En la lista desplegable Elegir comandos desde , seleccione Todos los comandos.
- Seleccione Editar vínculos y seleccione la pestaña Datos .
- Haga clic en Nuevo grupo y seleccione Agregar. Editar vínculos se agregará al grupo personalizado.
También puede agregar vínculos de edición a la barra de herramientas de acceso rápido. Para obtener más información, vea Personalizar la barra de herramientas de acceso rápido. El comando Editar vínculos está atenuado si el libro no contiene vínculos de libro.
El cuadro de diálogo Editar vínculos
Al abrir el cuadro de diálogo Editar vínculos, se le presentan varias opciones para tratar con los vínculos existentes. Puede seleccionar libros individuales con Ctrl+clic, o todos ellos con Ctrl+A.
Comandos de edición de vínculos
Actualizar valores
Esto actualizará todos los libros seleccionados.
Cambiar origen
Esta opción es útil cuando desea apuntar vínculos existentes a otro origen. Por ejemplo, es posible que tenga un libro del año anterior y necesite apuntar a un nuevo libro cuando comience un nuevo año. Al seleccionar Cambiar origen , se abrirá un cuadro de diálogo del explorador de archivos, donde podrá examinar el nuevo libro de origen. Si el libro tiene más de una hoja de cálculo, se le pedirá que especifique con cuál establecer el vínculo; simplemente haga clic en la hoja que desee y haga clic en Aceptar.
Nota
Es posible volver a apuntar un libro a sí mismo seleccionándolo en el cuadro de diálogo Cambiar origen. Esto cortará los vínculos de fórmula al libro de origen vinculado originalmente.
Código abierto
Se abrirá el libro de origen.
Romper vínculo
Importante
Cuando rompe un vínculo a un origen, todas las fórmulas que usan dicho origen se convierten en su valor actual. Por ejemplo, el vínculo =SUMA([Budget.xlsx]Anual! C10:C25) se convertiría en la suma de los valores del libro de origen. Dado que esta acción no se puede deshacer, es posible que desee guardar primero una versión del archivo.
En el cuadro de diálogo Editar vínculos , en la lista Orígenes , haga clic en el vínculo que desea romper.
Puede seleccionar libros individuales con Ctrl+clic, o todos ellos con Ctrl+A.Haga clic en Romper vínculo.
Si el vínculo usó un nombre definido, es posible que también desee eliminar el nombre. Para eliminar un nombre:
En la pestaña Fórmulas, en el grupo Nombres definidos, haga clic en Administrador de nombres.
En la columna Nombre, haga clic en el nombre que desea eliminar y, después, en Eliminar.
Nota
Si usa un rango de datos externo, un parámetro de una consulta también puede usar datos de otro libro. Puede que sea conveniente que compruebe si existen estos tipos de vínculos y quitarlos.
Comprobar estado
Esto simplemente muestra una notificación en el panel Editar vínculos si un libro vinculado sigue siendo un origen válido. Debería mostrarse bien, pero si no es así, deberá comprobar el libro de origen. En muchos casos, es posible que se haya movido o eliminado un libro de origen, cortando el vínculo. Si el libro todavía existe, puede usar la opción Cambiar origen para volver a vincular el libro.
Preguntas más frecuentes
¿Por qué veo vínculos nuevos en mi libro?
Las versiones anteriores de Excel ocultan los vínculos en nombres que no están actualmente en uso en el libro. Los enlaces siempre han existido y ya no están ocultos. Para quitar el vínculo, seleccione Romper vínculos para el libro seleccionado en el panel Vínculos de libro .
¿Puedo reemplazar una fórmula única por su valor calculado?
Sí. Cuando se reemplaza una fórmula por su valor, Excel la elimina de forma permanente. Si reemplaza accidentalmente una fórmula con un valor y desea restaurar la fórmula, seleccione Inicio y elija Deshacer o presione Ctrl+Z inmediatamente después de escribir o pegar el valor.
- Presione Ctrl+C para copiar la celda con la fórmula.
- Presione Alt+E+S+V para pegar la fórmula como su valor, o bien seleccionePegar valores de>pegado en elPortapapeles>de inicio>.
¿Qué ocurre si no estoy conectado al origen?
Seleccione No actualizar en el cuadro de diálogo de advertencia de vínculos no seguros. Excel no puede actualizar un origen si no hay ninguna conexión establecida. Por ejemplo, el origen puede estar en una red y es posible que no tenga establecida una conexión con ella.
¿Qué ocurre si no quiero que mis datos actuales se reemplacen por datos nuevos?
Seleccione No actualizar en el cuadro de diálogo de advertencia de vínculos no seguros.
¿Cómo puedo actualizar sin que tarde tanto?
Seleccione No actualizar en el cuadro de diálogo de advertencia de vínculos no seguros. Si no es preciso que los datos sean los más recientes, ahorrará tiempo si no actualiza todos los vínculos. Después de abrir el libro, vaya a la pestaña Datos y seleccione Vínculos del libro en el grupo Consultas & Conexiones y, después, actualice los vínculos solo desde los orígenes que necesite.
¿Cómo puedo no ver este mensaje después de que otra persona haya creado el libro?
Seleccione No actualizar en el cuadro de diálogo de advertencia de vínculos no seguros y póngase en contacto con el propietario del libro. También puede investigar qué vínculos se encuentran en el libro. En la pestaña Datos , en el grupo Consultas & conexiones , seleccione Vínculos de libro.
¿Cómo no volver a ver el mensaje si lo hago de la misma manera cada vez?
Puede seleccionar y expandir la configuración de Actualizar en la esquina superior derecha del panel Vínculos del libro y seleccionar de forma coherente y evitar ver el mensaje de inicio para este libro.
¿Cómo no solicitar todos los libros que abro y actualizar los vínculos automáticamente?
Esta opción afecta a todos los libros que se abran en el PC. Los usuarios que abran el libro en otro PC no se verán afectados.
- En la pestaña Archivo , seleccione Opciones y elija Avanzadas.
- En la sección General , desactive Preguntar si se actualizan los vínculos automáticos. Cuando esta casilla está desactivada, los vínculos se actualizan automáticamente y no se muestra ninguna alerta.
¿Cómo puedo hacer lo mismo para todos los usuarios de este libro?
Advertencia
Esta opción afecta a todos los usuarios del libro. Si elige no actualizar los vínculos y no preguntar, los usuarios del libro no sabrán que los datos están anticuados.
Seleccione y expanda Actualizar configuración en la esquina superior derecha del panel Vínculos del libro y seleccione la opción necesaria.
Nota
Se le seguirá notificando la existencia de vínculos rotos.
¿Qué ocurre si estoy usando una consulta de parámetros?
Los vínculos a consultas de parámetros no se pueden actualizar a menos que el libro de origen esté abierto.
- Seleccione No actualizar en el cuadro de diálogo de advertencia de vínculos no seguros.
- Cierre el libro de destino.
- Abra el libro de origen.
- Abra el libro de destino.
- Seleccione Actualizar.
¿Por qué no puedo elegir "Manual" como opción de actualización para un vínculo externo específico?
Los vínculos de fórmula siempre se establecen en Automático.
Consulte también
Descripción de la administración y el almacenamiento de vínculos de libros en Excel