Sumar valores basados en varias condiciones

Sumar valores basados en varias condiciones

Supongamos que necesita sumar valores con más de una condición, como la suma de las ventas de producto en una región específica. Este es un buen caso para usar la función sumar . Si. conjunto en una fórmula.

Consulte este ejemplo en el que tenemos dos condiciones: queremos la suma de las ventas de carne (de la columna C) en la región sur (de la columna a).

Datos en una hoja de cálculo de Excel

Esta es una fórmula que puede usar para acomplish esto:

= SUMAr. Si. conjunto (D2: D11, a2: A11, "South", C2: C11, "carne")

El resultado es el valor 14.719.

Echemos un vistazo más detenidamente en cada parte de la fórmula.

=SUMAR.SI.CONJUNTO es una fórmula aritmética. Calcula números, que en este caso están en la columna D. El primer paso es especificar la ubicación de los números:

=SUMAR.SI.CONJUNTO(D2:D11,

O sea, quiere que la fórmula sume números de la columna si cumplen las condiciones. Ese rango de celdas es el primer argumento de esta fórmula: el primer fragmento de datos que la función requiere como entrada.

A continuación, desea buscar datos que cumplan dos condiciones, así que especifique su primera condición especificando la ubicación de los datos (a2: A11) y también cuál es la condición (es decir, "South"). Observe las comas entre los argumentos independientes:

=SUMAR.SI.CONJUNTO(D2:D11,A2:A11,”South”,

Las comillas en "South" especifican que se trata de datos de texto.

Por último, especifique los argumentos de la segunda condición: el rango de celdas (C2:C11) que tiene la palabra “meat”, más la palabra en sí (entre comillas) para que Excel pueda encontrar resultados. Finalice la fórmula con un paréntesis de cierre ) y, a continuación, presione Entrar. El resultado, de nuevo, es 14.719.

=SUMAR.SI.CONJUNTO(D2:D11,A2:A11,”South”,C2:C11,”Meat”)

Mientras escribe la función SUMAr. Si no recuerda los argumentos, la ayuda está lista para usar. Después de escribir = sumar. Si. conjunto (, Fórmula Autocompletar aparece debajo de la fórmula, con la lista de argumentos en el orden correcto.

Si miramos la imagen de Fórmula Autocompletar y la lista de argumentos, en nuestro ejemplo rango_sumaes D2: D11, la columna de números que desea sumar; criteria_range1es a2. A11, la columna de datos donde se encuentra criteria1 "South" (sur).

Uso de la fórmula Autocompletar para especificar la función SUMAR.SI.CONJUNTO

A medida que escriba, el resto de los argumentos aparecerá en Fórmula Autocompletar (no se muestra aquí); rango_criterios2 es C2:C11, la columna de datos donde residen los criterios2 “Meat”.

Si hace clic en sumar. Si. conjunto en Fórmula Autocompletar, se abrirá un artículo para obtener más ayuda.

Inténtelo

Si desea experimentar con la función SUMAr. Si. conjunto, aquí tiene algunos datos de ejemplo y una fórmula que usa la función.

Puede trabajar con datos y fórmulas de ejemplo aquí, en este Excel para la Web libro. Cambie valores y fórmulas o agregue sus propios valores y fórmulas y vea los resultados cambiar de forma activa.

Copie todas las celdas de la tabla de abajo y péguelas en la celda A1 de una nueva hoja de cálculo de Excel. Quizás desee ajustar anchos de columna para ver mejor las fórmulas.

Región

Vendedor

Tipo

Ventas

Sur

Ito

Bebidas

3571

Oeste

Lannin

Lácteos

3338

Este

Makovec

Bebidas

5122

Norte

Makovec

Lácteos

6239

Sur

Jordan

Verdura

8677

Sur

Lannin

Carnes

450

Sur

Lannin

Carnes

7673

Este

Makovec

Verdura

664

Norte

Lannin

Verdura

1500

Sur

Jordan

Carnes

6596

Fórmula

 

Descripción

Resultado

' = SUMAr. Si. conjunto (D2: D11
, a2: A11, "South", C2: C11, "carne")

Suma las ventas de carne
de Columna C del Sur
región de la columna A (el resultado es 14719).

= SUMAr. Si. conjunto (D2: D11
, a2: A11, "South", C2: C11, "carne")

Notas: 

Nota:  Esta página se ha traducido mediante un sistema automático y es posible que contenga imprecisiones o errores gramaticales. Nuestro objetivo es que este contenido le resulte útil. ¿Podría decirnos si la información le resultó útil? Aquí puede consultar el artículo en inglés.

Ampliar sus conocimientos de Office
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×