Usar constantes matriciales en fórmulas de matriz

Al introducir una fórmula de matriz, lo más frecuente es usar un rango de celdas en la hoja de cálculo, pero no es necesario. También puede usar constantes de matriz, valores que solo se escriben en la barra de fórmulas dentro de llaves: {}. A continuación, puedes asignar un nombre a tu constante para que sea más fácil de usar.

Puede usar constantes en las fórmulas de matriz o de forma independiente.

  1. En la fórmula de matriz, escriba una llave de apertura, los valores que desee y una llave de cierre. Este es un ejemplo: = suma (a1: E1 * {1, 2, 3, 4, 5})

    La constante está entre llaves ({)} y sí, realmente escribe esas llaves de forma manual.

  2. Escriba el resto de la fórmula y presione Ctrl + Mayús + entrar.

    La fórmula tendrá un aspecto similar a {= suma (a1: E1 * {1, 2, 3, 4, 5})}y el resultado tendrá el siguiente aspecto:


    Una constante de matriz anidada en una fórmula SUMA

    La fórmula ha multiplicado a1 por 1 y B1 por 2, etc., lo que le ahorra de tener que colocar 1, 2, 3, 4, 5 en las celdas de la hoja de cálculo.

Usar una constante para especificar valores en una columna

Para introducir valores en una sola columna, como 3 celdas en la columna C, haga lo siguiente:

  1. Seleccione las celdas que desea usar.

  2. Escriba un signo igual y la constante. Separe los valores de la constante con punto y coma, no comas, y, si está escribiendo texto, escríbalo entre comillas dobles. Por ejemplo: = {"Quarter 1"; " Quarter2";" Trimestre 3 "}

  3. Presione Ctrl+Mayús+Entrar. La constante tiene el siguiente aspecto:

    Constante de matriz vertical que usa texto

    En términos aficionados, esta es una constante vertical unidimensional .

Usar una constante para especificar valores en una fila

Para introducir rápidamente valores en una sola fila, como las celdas F1, G1 y H1, haga lo siguiente:

  1. Seleccione las celdas que desea usar.

  2. Escriba un signo igual y la constante, pero esta vez separe los valores con comas, no puntos y comas. Por ejemplo: = {1, 2, 3, 4, 5}

  3. Presione Ctrl + Mayús + entrar, y la constante tiene el siguiente aspecto:

    Constante de matriz horizontal unidimensional

    En términos aficionados, esta es una constante horizontal unidimensional .

Usar una constante para introducir valores en varias columnas y filas

  1. Seleccione las celdas que desee.

    Asegúrese de que el número de filas y columnas que seleccione coincida con el número de valores de la constante. Por ejemplo, si la constante va a escribir datos en cuatro columnas y tres filas, seleccione esa cantidad de columnas y filas.

  2. Escriba un signo igual y la constante. En este caso, separe los valores de cada fila con comas y use un punto y coma al final de cada fila. Por ejemplo:

    ={1,2,3,4;5,6,7,8;9,10,11,12}

  3. Presione Ctrl + Mayús + entrar y:

    Constante de matriz bidimensional

    En términos aficionados, esta es una constante bidimensional porque rellena columnas y filas. Si se le pregunta, no puede crear una constante tridimensional, lo que significa que no puede anidar una constante dentro de otra.

Usar una constante en una fórmula

Ahora que ya conoce las constantes de matriz, aquí tiene un ejemplo de trabajo.

  • En una celda en blanco, escriba (o copie y pegue) esta fórmula y, a continuación, presione Ctrl + Mayús + entrar:

    =SUMA(A1:E1*{1,2,3,4,5})

    En la celda A3 aparece el valor 85.

    ¿Qué ha ocurrido? Multiplicamos el valor de a1 por 1, el valor de la celda B2 por 2 y así sucesivamente, la función suma agregó esos resultados. También puede escribir la fórmula como = suma (a1 * 1, B1 * 2, C1 * 3, D1 * 4, E1 * 5) .

Si lo desea, puede especificar ambos conjuntos de valores como constantes de matriz:

=SUMA({3,4,5,6,7}*{1,2,3,4,5})

Para probar esto, copie la fórmula, seleccione una celda en blanco y pegue la fórmula en la barra de fórmulas y, a continuación, presione Ctrl + Mayús + entrar. Verás el mismo resultado.

Notas: Si sus constantes no funcionan, busque estos problemas:

  • Asegúrese de que separa los valores con el carácter adecuado. Si omite una coma o un punto y coma, o si coloca uno en el lugar equivocado, es posible que la constante matricial no tenga el aspecto adecuado o que vea un mensaje de advertencia.

  • Es posible que haya seleccionado un rango de celdas que no coincida con el número de elementos de la constante. Por ejemplo, si selecciona una columna de seis celdas para usarla con una constante de cinco celdas, el error #N/A aparece en la celda vacía. Si no selecciona suficientes celdas, Excel omite los valores que no tienen una celda correspondiente.

  • Para obtener más información acerca de las fórmulas de matriz:

Principio de página

¿Necesita más ayuda?

Ampliar sus conocimientos de Office
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×