Usar SI para comprobar si una celda está en blanco

A veces es necesario comprobar si una celda está en blanco (normalmente, para que una fórmula no muestre un resultado sin datos de entrada).

La fórmula de la celda E2 es =SI(D2=1,"Sí",IF(D2=2,"No","Es posible"))

En este caso, usaremos SI con la función ESBLANCO:

  • =SI(ESBLANCO(D2);"En blanco";"No está en blanco")

Lo que equivale a SI(D2 está en blanco, devuelve "En blanco"; en caso contrario, devuelve "No está en blanco"). También podría usar fácilmente su propia fórmula para la condición "No está en blanco". En el ejemplo siguiente usaremos "" en lugar de ESBLANCO. Básicamente, las dos comillas dobles ("") equivalen a "nada".

Comprobar si una celda está en blanco: la fórmula de la celda E2 es =SI(ESBLANCO(D2);"En blanco";"No está en blanco")

=SI(D3="";"En blanco";"No está en blanco")

Esta fórmula dice lo siguiente: SI(D3 no tiene nada, devuelve "En blanco"; en caso contrario, devuelve "No está en blanco"). Este es un ejemplo de un método muy común del uso de "" para evitar que una fórmula realice un cálculo si una celda dependiente está en blanco:

  • =SI(D3="";"";SuFórmula())

    SI(D3 equivale a nada, no se devuelve nada; en caso contrario, calcula la fórmula).

Ampliar sus conocimientos de Office
Explorar los cursos
Obtener nuevas características primero
Únase a los participantes de Office Insider

¿Le ha sido útil esta información?

¡Gracias por sus comentarios!

Gracias por sus comentarios. Quizá le interese ponerse en contacto con uno de nuestros agentes de soporte de Office.

×