Use un botón de comando en un formulario de Access para iniciar una acción o un conjunto de acciones. Por ejemplo, puede crear un botón de comando que abra otro formulario. Para que un botón de comando realice una acción, escriba una macro o procedimiento de evento y adjúntelo a la propiedad Al hacer clic del botón de comando. También puede insertar una macro directamente en la propiedad Al hacer clic . Esto le permite copiar el botón de comando a otros formularios sin perder su funcionalidad.
¿Qué desea hacer?
- Agregar un botón de comando a un formulario mediante un asistente
- Crear un botón arrastrando una macro a un formulario
- Crear un botón de comando sin usar un asistente
- Personalizar un botón de comando
Agregar un botón de comando a un formulario mediante un asistente
El Asistente para botones de comando le ayuda a crear rápidamente botones de comando que realizan una variedad de tareas, como cerrar el formulario, abrir un informe, buscar un registro o ejecutar una macro.
Haga clic con el botón secundario en el formulario en el panel de navegación y, después, haga clic en Vista Diseño en el menú contextual.
En la pestaña Diseño de formulario , en el grupo Controles , asegúrese de que está seleccionada la opción Usar asistentes de control .
En la pestaña Diseño de formulario , en el grupo Controles , haga clic en Botón.
En la cuadrícula de diseño, haga clic donde desee insertar el botón de comando. Se iniciará el Asistente para botones de comando.
Siga las instrucciones del asistente. En la última, haga clic en Finalizar. El asistente crea el botón de comando e inserta una macro en la propiedad Al hacer clic del botón. La macro contiene acciones que realizan la tarea seleccionada en el asistente.
Ver o editar una macro incrustada en un botón de comando
- En el panel de navegación, haga clic con el botón secundario en el formulario que contiene el botón de comando y, después, haga clic en Vista Diseño o Vista Presentación en el menú contextual.
- Haga clic en el botón de comando para seleccionarlo y, a continuación, presione F4 para mostrar su hoja de propiedades.
- En la pestaña Evento de la hoja de propiedades, debe aparecer [Macro incrustada] en el cuadro de propiedades Al hacer clic . Haga clic en cualquier parte del cuadro de propiedades y, a continuación, haga clic en el botón Crear en el lado derecho del cuadro.
Se muestra el Generador de macros, que muestra la acción o acciones que componen la macro incrustada.
Crear un botón arrastrando una macro a un formulario
Si ya ha creado y guardado una macro, puede crear fácilmente un botón de comando que ejecute la macro arrastrándola desde el panel de navegación a un formulario que esté abierto en la vista Diseño.
- Abra el formulario en la vista Diseño haciendo clic con el botón secundario en el formulario del panel de navegación y, después, haciendo clic en Vista Diseño en el menú contextual.
- En el panel de navegación, busque la macro que desea que ejecute el nuevo botón de comando y, a continuación, arrastre la macro al formulario. Access crea automáticamente un botón de comando y utiliza el nombre de la macro como subtítulo del botón. Access también inserta el nombre de la macro en la propiedad Al hacer clic para que la macro se ejecute al hacer clic en el botón. Access usa un nombre genérico para el botón, por lo que es una buena idea escribir un nombre más significativo en la propiedad Nombre del botón. Para mostrar la hoja de propiedades del botón Comando mientras el formulario está abierto en la vista Diseño, haga clic en el botón y presione F4.
Para obtener más información sobre la creación de macros, vea el artículo Crear una macro de interfaz de usuario.
Crear un botón de comando sin usar un asistente
Puede crear un botón de comando sin usar el Asistente para botones de comando. El proceso implica colocar el botón en el formulario y, a continuación, configurar algunas propiedades.
Haga clic con el botón secundario en el formulario en el panel de navegación y, después, haga clic en Vista Diseño en el menú contextual.
En la pestaña Diseño de formulario , en el grupo Controles , asegúrese de que Usar asistentes de control no está seleccionado.
En la pestaña Diseño de formulario , en el grupo Controles , haga clic en Botón.
Haga clic en la ubicación del formulario donde desea colocar el botón de comando. Access coloca el botón de comando en el formulario. Como no se seleccionó Asistentes para el control de uso , Access no realiza ningún procesamiento adicional. Si el Asistente para botones de comando se inicia cuando coloca el botón de comando en el formulario, puede hacer clic en Cancelar en el asistente.
Con el botón de comando seleccionado, presione F4 para mostrar su hoja de propiedades.
Haga clic en la pestaña Todas para mostrar todas las propiedades del botón de comando.
Configure las propiedades para completar el diseño del botón de comando, como se muestra en la tabla siguiente.
Propiedad Descripción Nombre De forma predeterminada, Access da a un nuevo botón de comando el nombre Comando, seguido de un número; por ejemplo, Command34. Aunque no es obligatorio, es una buena idea cambiar el nombre por uno que refleje la función del botón (por ejemplo, cmdSalesReport o CloseFormButton). Esto le ayudará más adelante, si necesita hacer referencia al botón en una macro o en un procedimiento de evento. Título Escriba la etiqueta que desea que se muestre en el botón de comando. Por ejemplo, Informe de ventas o Cerrar formulario. El subtítulo no se muestra si se especifica una imagen en la propiedad Picture. Al hacer clic Use esta propiedad para especificar qué sucede cuando se hace clic en el botón de comando. Para establecer la propiedad, haga clic en el cuadro de propiedades y, a continuación, realice una de las siguientes acciones: haga clic en la flecha desplegable y seleccione una macro guardada; escriba un signo igual ( =) seguido del nombre de la función, como=MsgBox("Hola mundo")O=MyFunction(arguments); haga clic en el botón Compilar y luego en Generador de expresiones; haga clic en el botón Compilar y, a continuación, haga clic en Code Builder para comenzar a crear un procedimiento de eventos que use código de Visual Basic para Aplicaciones (VBA); o haga clic en el botón Compilar y luego en Generador de macros para crear una nueva macro incrustada. Las bases de datos de Access que contienen código VBA deben tener un estado de confianza para poder ejecutar el código.
Para obtener ayuda con otras propiedades no mencionadas aquí, coloque el cursor en un cuadro de propiedades y presione F1.
Personalizar un botón de comando
Access ofrece muchas maneras de personalizar los botones de comando para que pueda tener la apariencia y funcionalidad que desee en el formulario. Por ejemplo, puede crear una fila de botones de comando en una disposición tabular o apilada, o puede hacer que los botones de comando parezcan más hipervínculos.
Haga clic con el botón secundario en el formulario en el panel de navegación y luego haga clic en Vista Diseño.
Siga uno de estos procedimientos:
Crear un diseño horizontal (tabular) o vertical (apilado) de los botones de comando Puede agregar botones de comando a un diseño tabular o apilado para crear una fila o columna de botones alineados con precisión. Después puede cambiar la posición de los botones como un grupo, lo que facilita la modificación de formularios. También puede aplicar estilos de formato a toda la fila o columna de botones de comando al mismo tiempo y puede separar los botones mediante líneas de cuadrícula.
Haga clic con el botón secundario en uno de los botones de comando que quiera agregar al diseño y seleccione Diseño en el menú contextual.
Haga clic en Tabular para iniciar una fila horizontal de botones o haga clic en Apilado para crear una columna vertical de botones. Access dibuja bordes alrededor del botón de comando para indicar el diseño. Cada botón está emparejado con una etiqueta que no puedes eliminar; sin embargo, puedes reducir la etiqueta a un tamaño muy pequeño si no es necesario. En la ilustración siguiente se muestra un botón de comando y su etiqueta asociada en un diseño tabular. Observe cómo está la etiqueta en la siguiente sección superior: esto evita que las etiquetas se repitan para cada registro detallado.
En la siguiente ilustración se muestra un botón de comando y su etiqueta asociada en un diseño apilado. En un diseño apilado, la etiqueta y el botón siempre están en la misma sección.
Agregue más botones de comando al diseño arrastrándolos al área de diseño. Al arrastrar un botón de comando sobre el área de diseño, Access dibuja una barra de inserción horizontal (para un diseño tabular) o una barra de inserción vertical (para un diseño apilado) para indicar dónde se colocará el botón de comando cuando suelte el botón del mouse.
Al soltar el botón del ratón, el control se agrega al diseño.
Mover los botones de comando hacia arriba o hacia abajo en una sección dentro de un diseño tabular Si desea mantener un botón de comando en un diseño tabular, pero desea mover el botón de comando a otra sección del formulario (por ejemplo, de la sección de detalles a la sección Encabezado del formulario), haga lo siguiente:
Seleccione el botón de comando.
Haz clic en Subir o Bajar en la pestaña Organizar . El botón de comando se desplaza hacia arriba o hacia abajo a la sección siguiente, pero permanece dentro del diseño tabular. Si ya hay un control en la posición a la que lo está moviendo, los dos controles intercambian lugares.
Nota
Los comandos Subir y Bajar están deshabilitados para los diseños apilados.
Mover un diseño completo de botones de comando
- Haga clic en cualquiera de los botones de comando del diseño. Aparecerá un selector de diseño en la esquina superior izquierda del diseño.
- Arrastre el selector de diseño para mover el diseño a una nueva ubicación.
Agregar líneas de cuadrícula a un diseño de botones de comando
- Seleccione cualquiera de los botones de comando del diseño.
- Haga clic en el comando Líneas de cuadrícula de la pestaña Organizar y, a continuación, haga clic en el estilo de líneas de cuadrícula que desee.
Hacer que un botón de comando sea transparente Al hacer que un botón de comando sea transparente, puede colocarlo sobre cualquier objeto del formulario y darle a ese objeto la funcionalidad de un botón de comando. Por ejemplo, tiene una imagen que quiere dividir en áreas independientes en las que se puede hacer clic, cada una de las cuales inicia una macro diferente. Puede hacerlo colocando varios botones de comando transparentes sobre la imagen.
Haga clic en el botón de comando que desea hacer transparente y, a continuación, presione F4 para mostrar la hoja de propiedades del botón de comando.
En la pestaña Formato de la hoja de propiedades, haga clic en el cuadro de propiedades Transparente .
Seleccione Sí en la lista desplegable. Todavía puede ver el contorno del botón de comando en la vista Diseño, pero el botón es invisible en la vista Formulario.
Nota
Establecer la propiedad Transparente de un botón de comando en Sí no es lo mismo que establecer su propiedad Visible en No. Ambas operaciones ocultan el botón de comando, pero establecer la propiedad Transparente en Sí deja el botón habilitado. Si establece la propiedad Visible en No , se deshabilita el botón.
Hacer que un botón de comando aparezca como un hipervínculo Si lo desea, puede ocultar un botón de comando, pero dejar el subtítulo visible. El resultado es algo que parece una etiqueta, pero funciona como un botón de comando. También puede subrayar el texto en el subtítulo y cambiar su color para que aparezca como un hipervínculo.
Haga clic en el botón de comando para seleccionarlo y presione F4 para mostrar su hoja de propiedades.
En la pestaña Formato de la hoja de propiedades, haga clic en el cuadro de propiedades Estilo posterior .
En la lista desplegable, seleccione Transparente. El cuerpo del botón de comando está oculto, pero su subtítulo permanece visible.
Para subrayar o cambiar el color del texto en el subtítulo, use las herramientas del grupo Fuente en la pestaña Formato.
Crear un botón Cancelar
Haga clic en el botón de comando y, a continuación, presione F4 para abrir su hoja de propiedades.
En el cuadro Cancelar propiedad, haga clic en Sí. Cuando la propiedad Cancelar de un botón de comando se establece en Sí y el formulario es el formulario activo, un usuario puede seleccionar el botón de comando haciendo clic en él, presionando Esc o Entrar cuando el botón de comando tiene el foco. Cuando la propiedad Cancelar se establece en Sí para un botón de comando, esa propiedad se establece automáticamente en No para todos los demás botones de comando del formulario. Para hacer que un botón Cancelar cancele todas las acciones que han tenido lugar en un formulario o cuadro de diálogo, debe escribir una macro o procedimiento de evento y adjuntarlo a la propiedad Al hacer clic del botón.
Nota
Para un formulario que permite operaciones irreversibles (como eliminaciones), es una buena idea hacer que el botón Cancelar sea el botón de comando predeterminado del formulario. Para ello, establezca la propiedad Cancelar y la propiedad Predeterminado en Sí.
Mostrar una imagen en un botón de comando En el cuadro de propiedades Imagen del botón de comando, escriba la ruta de acceso y el nombre de archivo de un archivo de imagen, como un
.bmp.icoarchivo o.dibun archivo. Si no está seguro de la ruta o el nombre del archivo, haga clic en el botón Crear para abrir el Generador de imágenes.
Haga clic en Examinar para encontrar la imagen que desea usar. O bien haga clic en una de las imágenes de la lista Imágenes disponibles para obtener una vista previa de las imágenes creadas profesionalmente que puede usar. Si encuentra una imagen que quiera usar, haga clic en Aceptar para agregarla al botón de comando. De forma predeterminada, Access establece la propiedad Tipo de imagen como Integrado. Al asignar un gráfico a la propiedad Imagen de un botón de comando, esta configuración crea una copia de la imagen y la almacena en el archivo de base de datos de Access. Los cambios posteriores de la imagen original no se reflejarán en el botón de comando. Para crear un vínculo a la imagen original de modo que los cambios se reflejen en el botón de comando, cambie la propiedad Tipo de imagen a Vinculado. Debe mantener el archivo de imagen original en su ubicación original. Si mueve el archivo de imagen o le cambia el nombre, Access mostrará un mensaje de error al abrir la base de datos y el botón de comando mostrará su subtítulo en lugar de la imagen.
Mostrar una imagen y un subtítulo en un botón de comando Puede mostrar un subtítulo y una imagen en un botón de comando. Use el procedimiento siguiente:
- Agregue una imagen al botón de comando mediante el procedimiento descrito anteriormente en esta sección.
- Seleccione el botón de comando. Si aún no se muestra la hoja de propiedades, presione F4 para mostrarla.
- En la pestaña Formato de la hoja de propiedades, escriba el subtítulo que desee en el cuadro de propiedades Título.
- Haga clic en la flecha desplegable en el cuadro de propiedad Organización de subtítulos de imagen y, a continuación, seleccione la disposición que desee. Por ejemplo, para mostrar el subtítulo debajo de la imagen, seleccione Abajo. Para mostrar el subtítulo a la derecha de la imagen, seleccione Derecha. Para que la organización dependa de la configuración regional del sistema, selecciona General. Con esta configuración, el subtítulo aparece en la derecha para los idiomas que se leen de izquierda a derecha y en la izquierda para los idiomas que se leen de derecha a izquierda.