Puede utilizar Microsoft Query para recuperar datos de orígenes externos. Al usar Microsoft Query para recuperar datos de sus bases de datos y archivos corporativos, no tiene que volver a escribir los datos que desea analizar en Excel. También puede actualizar los Excel y los resúmenes automáticamente desde la base de datos de origen original siempre que la base de datos se actualice con nueva información.

Con Microsoft Query, puede conectarse a orígenes de datos externos, seleccionar datos de esos orígenes externos, importar esos datos a la hoja de cálculo y actualizar los datos según sea necesario para mantener los datos de la hoja de cálculo sincronizados con los datos de los orígenes externos.

Tipos de bases de datos a las que puede acceder     Puede recuperar datos de varios tipos de bases de datos, incluidos Microsoft Office Access, Microsoft SQL Server y Microsoft SQL Server servicios OLAP. También puede recuperar datos de Excel libros y de archivos de texto.

Microsoft Office proporciona controladores que puede usar para recuperar datos de los siguientes orígenes de datos:

  • Microsoft SQL Server Analysis Services (proveedor OLAP )

  • Microsoft Office Access

  • dBASE

  • Microsoft FoxPro

  • Microsoft Office Excel

  • Oracle

  • Paradox

  • Bases de datos de archivos de texto

También puede usar controladores ODBC o controladores de origen de datos de otros fabricantes para recuperar información de orígenes de datos que no se muestran aquí, incluidos otros tipos de bases de datos OLAP. Para obtener información sobre cómo instalar un controlador ODBC o un controlador de origen de datos que no aparece aquí, consulte la documentación de la base de datos o póngase en contacto con el proveedor de la base de datos.

Seleccionar datos de una base de datos     Puede recuperar datos de una base de datos creando una consulta, que es una pregunta que se le pregunta sobre los datos almacenados en una base de datos externa. Por ejemplo, si los datos se almacenan en una base de datos de Access, es posible que desee conocer las cifras de ventas de un producto específico por región. Puede recuperar una parte de los datos seleccionando solo los datos del producto y la región que desea analizar.

Con Microsoft Query, puede seleccionar las columnas de datos que desee e importar solo los datos a Excel.

Actualizar la hoja de cálculo en una sola operación     Una vez que tenga datos externos en un libro de Excel, siempre que la base de datos cambie, puede actualizar los datos para actualizar el análisis, sin tener que volver a crear los informes de resumen y los gráficos. Por ejemplo, puede crear un resumen de ventas mensual y actualizarlo cada mes cuando lleguen las nuevas cifras de ventas.

Cómo Usa Microsoft Query orígenes de datos     Después de configurar un origen de datos para una base de datos en particular, puede usarlo siempre que desee crear una consulta para seleccionar y recuperar datos de esa base de datos, sin tener que volver a escribir toda la información de conexión. Microsoft Query usa el origen de datos para conectarse a la base de datos externa y mostrarle qué datos están disponibles. Después de crear la consulta y devolver los datos Excel Excel, Microsoft Query proporciona al libro de Excel tanto la información de la consulta como del origen de datos para que pueda volver a conectarse a la base de datos cuando desee actualizar los datos.

Diagrama que muestra cómo utiliza Query los orígenes de datos

Usar Microsoft Query para importar datos     para importar datos externos a Excel con Microsoft Query, siga estos pasos básicos, que se describen con más detalle en las secciones siguientes.

¿Qué es un origen de datos?     Un origen de datos es un conjunto almacenado de información que permite a Excel y Microsoft Query conectarse a una base de datos externa. Al usar Microsoft Query para configurar un origen de datos, se proporciona un nombre al origen de datos y, a continuación, se proporciona el nombre y la ubicación de la base de datos o servidor, el tipo de base de datos y la información de inicio de sesión y contraseña. La información también incluye el nombre de un controlador OBDC o un controlador de origen de datos, que es un programa que realiza conexiones a un tipo específico de base de datos.

Para configurar un origen de datos mediante Microsoft Query:

  1. En la pestaña Datos, en el grupo Obtener datos externos, haga clic en De otros orígenesy, a continuación, haga clic en Desde Microsoft Query.

  2. Siga uno de estos procedimientos:

    • Para especificar un origen de datos para una base de datos, un archivo de texto o un Excel, haga clic en la pestaña Bases de datos.

    • Para especificar un origen de datos de cubo OLAP, haga clic en la pestaña Cubos OLAP. Esta pestaña solo está disponible si ejecutó Microsoft Query desde Excel.

  3. Haga doble clic en<Nuevo origen de datos>.

    O bien:

    Haga clic<Nuevo origen de>y, a continuación, haga clic en Aceptar.

    Se muestra el cuadro de diálogo Crear nuevo origen de datos.

  4. En el paso 1, escriba un nombre para identificar el origen de datos.

  5. En el paso 2, haga clic en un controlador para el tipo de base de datos que usa como origen de datos.

    Notas: 

    • Si la base de datos externa a la que desea obtener acceso no es compatible con los controladores ODBC instalados con Microsoft Query, debe obtener e instalar un controlador ODBC compatible con Microsoft Office de un proveedor de terceros, como el fabricante de la base de datos. Póngase en contacto con el proveedor de la base de datos para obtener instrucciones de instalación.

    • Las bases de datos OLAP no requieren controladores ODBC. Al instalar Microsoft Query, los controladores se instalan para bases de datos creadas mediante Microsoft SQL Server Analysis Services. Para conectarse a otras bases de datos OLAP, debe instalar un controlador de origen de datos y un software cliente.

  6. Haga clic Conectary, a continuación, proporcione la información necesaria para conectarse al origen de datos. Para las bases de datos, Excel libros y archivos de texto, la información que proporcione depende del tipo de origen de datos que haya seleccionado. Es posible que se le pida que proporcione un nombre de inicio de sesión, una contraseña, la versión de la base de datos que usa, la ubicación de la base de datos u otra información específica del tipo de base de datos.

    Importante: 

    • Use contraseñas seguras que combinen letras mayúsculas y minúsculas, números y símbolos. En las contraseñas no seguras estos elementos no se combinan. Contraseña segura: Y6dh!et5. Contraseña no segura: Casa27. Las contraseñas deben tener una longitud mínima de 8 caracteres. Una frase para una contraseña que use 14 caracteres o más siempre será más adecuada.

    • Es fundamental que recuerde la contraseña. Si la olvida, Microsoft no podrá recuperarla. Guarde las contraseñas que anote en un lugar seguro, lejos de la información que ayudan a proteger.

  7. Después de escribir la información necesaria, haga clic en Aceptar o Finalizar para volver al cuadro de diálogo Crear nuevo origen de datos.

  8. Si la base de datos tiene tablas y desea que una tabla en particular se muestre automáticamente en el Asistente para consultas, haga clic en el cuadro del paso 4 y, a continuación, haga clic en la tabla que desee.

  9. Si no desea escribir el nombre de inicio de sesión y la contraseña al usar el origen de datos, active la casilla Guardar mi id. de usuario y contraseña en la definición del origen de datos. La contraseña guardada no está cifrada. Si la casilla no está disponible, consulte al administrador de la base de datos para determinar si esta opción se puede hacer disponible.

    Nota de seguridad: Evite guardar la información de inicio de sesión al conectarse a orígenes de datos. Esta información puede almacenarse como texto sin formato y un usuario malintencionado podría acceder a la información para comprometer la seguridad del origen de datos.

Después de completar estos pasos, el nombre del origen de datos aparece en el cuadro de diálogo Elegir origen de datos.

Usar el Asistente para consultas para la mayoría de las consultas     El Asistente para consultas facilita la selección y la recopilación de datos de diferentes tablas y campos de la base de datos. Con el Asistente para consultas, puede seleccionar las tablas y campos que desea incluir. Una combinación interna (una operación de consulta que especifica que las filas de dos tablas se combinan en función de valores de campo idénticos) se crea automáticamente cuando el asistente reconoce un campo de clave principal en una tabla y un campo con el mismo nombre en una segunda tabla.

También puede usar el asistente para ordenar el conjunto de resultados y para hacer un filtrado sencillo. En el paso final del asistente, puede elegir devolver los datos a Excel o refinar aún más la consulta en Microsoft Query. Después de crear la consulta, puede ejecutarla en Excel o en Microsoft Query.

Para iniciar el Asistente para consultas, siga estos pasos.

  1. En la pestaña Datos, en el grupo Obtener datos externos, haga clic en De otros orígenesy, a continuación, haga clic en Desde Microsoft Query.

  2. En el cuadro de diálogo Elegir origen de datos, asegúrese de que la casilla Usar el Asistente para consultas para crear o editar consultas está activada.

  3. Haga doble clic en el origen de datos que desea usar.

    O bien:

    Haga clic en el origen de datos que desea usar y, a continuación, haga clic en Aceptar.

Trabajar directamente en Microsoft Query para otros tipos de consultas     Si desea crear una consulta más compleja de lo que permite el Asistente para consultas, puede trabajar directamente en Microsoft Query. Puede usar Microsoft Query para ver y cambiar las consultas que empiece a crear en el Asistente para consultas, o bien puede crear nuevas consultas sin usar el asistente. Trabaje directamente en Microsoft Query cuando desee crear consultas que realicen lo siguiente:

  • Seleccionar datos específicos de un campo     En una base de datos grande, es posible que desee elegir algunos de los datos de un campo y omitir los datos que no necesite. Por ejemplo, si necesita datos para dos de los productos de un campo que contiene información para muchos productos, puede usar criterio para seleccionar datos solo para los dos productos que desee.

  • Recuperar datos según criterios diferentes cada vez que ejecute la consulta     Si necesita crear el mismo informe de Excel o resumen para varias áreas de los mismos datos externos , como un informe de ventas independiente para cada región, puede crear un consulta de parámetros. Al ejecutar una consulta de parámetros, se le pedirá que use un valor como criterio cuando la consulta seleccione registros. Por ejemplo, una consulta de parámetros puede solicitar que escriba una región específica y podría volver a usar esta consulta para crear cada uno de los informes de ventas regionales.

  • Unir datos de diferentes maneras     Las combinaciones internas que crea el Asistente para consultas son el tipo de combinación más común que se usa para crear consultas. A veces, sin embargo, desea usar otro tipo de combinación. Por ejemplo, si tiene una tabla de información de ventas de productos y una tabla de información del cliente, una combinación interna (el tipo creado por el Asistente para consultas) impedirá la recuperación de registros de clientes para los clientes que no han realizado una compra. Con Microsoft Query, puede unirse a estas tablas para que se recuperen todos los registros de clientes, junto con los datos de ventas de aquellos clientes que han realizado compras.

Para iniciar Microsoft Query, siga estos pasos.

  1. En la pestaña Datos, en el grupo Obtener datos externos, haga clic en De otros orígenesy, a continuación, haga clic en Desde Microsoft Query.

  2. En el cuadro de diálogo Elegir origen de datos, asegúrese de que la casilla Usar el Asistente para consultas para crear o editar consultas esté despejada.

  3. Haga doble clic en el origen de datos que desea usar.

    O bien:

    Haga clic en el origen de datos que desea usar y, a continuación, haga clic en Aceptar.

Volver a uso y compartir consultas     Tanto en el Asistente para consultas como en Microsoft Query, puede guardar las consultas como un archivo .dqy que puede modificar, reutilizar y compartir. Excel puede abrir archivos .dqy directamente, lo que le permite a usted u otros usuarios crear rangos de datos externos adicionales a partir de la misma consulta.

Para abrir una consulta guardada desde Excel:

  1. En la pestaña Datos, en el grupo Obtener datos externos, haga clic en De otros orígenesy, a continuación, haga clic en Desde Microsoft Query. Se muestra el cuadro de diálogo Elegir origen de datos.

  2. En el cuadro de diálogo Elegir origen de datos, haga clic en la pestaña Consultas.

  3. Haga doble clic en la consulta guardada que desea abrir. La consulta se muestra en Microsoft Query.

Si desea abrir una consulta guardada y Microsoft Query ya está abierto, haga clic en el menú Archivo de consulta de Microsoft y, a continuación, haga clic en Abrir.

Si hace doble clic en un archivo .dqy, Excel, ejecuta la consulta y, a continuación, inserta los resultados en una nueva hoja de cálculo.

Si desea compartir un resumen o informe de Excel basado en datos externos, puede proporcionar a otros usuarios un libro que contenga un rango de datos externo o puede crear un plantilla. Una plantilla le permite guardar el resumen o el informe sin guardar los datos externos para que el archivo sea más pequeño. Los datos externos se recuperan cuando un usuario abre la plantilla de informe.

Después de crear una consulta en el Asistente para consultas o en Microsoft Query, puede devolver los datos a una hoja de cálculo Excel consulta. A continuación, los datos se convierten rango de datos externos o un informe de tabla dinámica que puede aplicar formato y actualizar.

Dar formato a los datos recuperados     En Excel, puede usar herramientas, como gráficos o subtotales automáticos, para presentar y resumir los datos recuperados por Microsoft Query. Puede dar formato a los datos y el formato se conserva al actualizar los datos externos. Puede usar sus propias etiquetas de columna en lugar de los nombres de campo y agregar números de fila automáticamente.

Excel puede dar formato automáticamente a los nuevos datos que escriba al final de un rango para que coincidan con las filas anteriores. Excel también puede copiar automáticamente las fórmulas que se han repetido en las filas anteriores y extenderlas a filas adicionales.

Nota: Para poder extenderse a nuevas filas del rango, los formatos y fórmulas deben aparecer en al menos tres de las cinco filas anteriores.

Puede activar esta opción (o desactivarla de nuevo) en cualquier momento:

  1. Haga clic en Archivo, Opciones, Avanzadas.

    En Excel 2007: haga clic en Microsoft Office botón Imagen del botón de Office, haga clic Excelopciones y, a continuación, haga clic en la categoría Avanzadas.

  2. En la sección Opciones de edición, seleccione la comprobación Extender formatos y fórmulas del rango de datos. Para desactivar el formato automático del rango de datos de nuevo, desactive esta casilla.

Actualizar datos externos     Al actualizar datos externos, ejecuta la consulta para recuperar los datos nuevos o modificados que coincidan con las especificaciones. Puede actualizar una consulta tanto en Microsoft Query como en Excel. Excel ofrece varias opciones para actualizar consultas, como actualizar los datos cada vez que abra el libro y actualizarlos automáticamente a intervalos de tiempo. Puede seguir trabajando en Excel mientras se actualizan los datos y también puede comprobar el estado mientras se actualizan los datos. Para obtener más información, vea Actualizar una conexión de datos externos en Excel.

Volver al principio

¿Necesita más ayuda?

Ampliar sus conocimientos
Explorar los cursos
Obtener nuevas características primero
Unirse a Microsoft Office Usuarios de Insider

¿Le ha sido útil esta información?

¿Cuál es tu grado de satisfacción con la calidad del lenguaje?
¿Qué ha afectado a tu experiencia?

¡Gracias por sus comentarios!

×