Ajustar bucles de trabajo por lotes de entradas de elemento de costo cuando se contabiliza un consumo negativo que se aplica desde un resultado negativo en Microsoft Dynamics NAV

Se aplica a
Microsoft Dynamics NAV 5.0 Service Pack 1 Dynamics NAV 2009

Este artículo se aplica a Microsoft Dynamics NAV para todos los países y todas las configuraciones regionales de idioma.

Síntomas

Cuando se contabiliza un consumo negativo que se establece como "Se aplica desde la entrada" en un resultado negativo en Microsoft Dynamics NAV, el trabajo por lotes Ajustar entradas de elemento de costo se repetirá. La resolución en esta revisión impide que los usuarios puedan aplicar el consumo negativo a la salida negativa para la misma orden de producción. Después de aplicar los cambios de código en este artículo, los usuarios recibirán el siguiente mensaje de error cuando intenten publicar el consumo negativo que se aplica a la salida negativa para la misma orden de producción:

Nota

La cantidad debe ser negativa en Nombre de plantilla del Diario diario de artículos='Nombre1',Nombre por lotes del diario='Nombre2',Línea No.='Número'.

Este problema se produce en los siguientes productos:

  • Microsoft Dynamics NAV 2009 R2
  • Microsoft Dynamics NAV 2009 Service Pack 1 (SP1)
  • Microsoft Dynamics NAV 5.0 Service Pack 1

      

Causa

Este problema se produce debido a transacciones incorrectas que se generan dentro de la fabricación.

Resolución

Información de revisiones

Una revisión compatible ya está disponible en Microsoft. Sin embargo, solo está pensado para corregir el problema que se describe en este artículo. Aplicarlo solo a los sistemas que experimentan este problema específico. Esta revisión puede recibir pruebas adicionales. Por lo tanto, si no se ve afectado gravemente por este problema, le recomendamos que espere al siguiente Service Pack de Microsoft Dynamics NAV 2009 o a la siguiente versión de Microsoft Dynamics NAV que contenga esta revisión.

Nota En casos especiales, los cargos que se incurren normalmente por las llamadas de soporte técnico pueden cancelarse si un profesional de soporte técnico de Microsoft Dynamics y productos relacionados determina que una actualización específica resolverá el problema. Se aplicarán los costos habituales de soporte técnico a las consultas y cuestiones de soporte técnico adicionales que no guarden relación con la actualización en cuestión.

Información de instalación

Microsoft proporciona ejemplos de programación solo para ilustración, sin garantía expresa o implícita. Esto incluye, entre otras, las garantías implícitas de comerciabilidad o idoneidad para un propósito determinado. En este artículo se supone que está familiarizado con el lenguaje de programación que se muestra y con las herramientas que se usan para crear y depurar procedimientos. Los ingenieros de soporte técnico de Microsoft pueden ayudar a explicar la funcionalidad de un procedimiento determinado. Sin embargo, no modificarán estos ejemplos para proporcionar funcionalidad adicional o construir procedimientos para satisfacer sus requisitos específicos.

Nota Antes de instalar esta revisión, compruebe que todos los usuarios del cliente de NAV de Microsoft Dynamics han cerrado sesión en el sistema. Esto incluye los servicios de Microsoft Dynamics NAV Application Server (NAS). Usted debe ser el único usuario del cliente que ha iniciado sesión al implementar esta revisión.

Para implementar esta revisión, debe tener una licencia de desarrollador.

Le recomendamos que la cuenta de usuario en la ventana Inicios de sesión de Windows o en la ventana Inicios de sesión de base de datos tenga asignado el id. de rol "SUPER". Si no se puede asignar a la cuenta de usuario el id. de rol "SUPER", debe comprobar que la cuenta de usuario tiene los permisos siguientes:

  • El permiso Modificar para el objeto que va a cambiar.
  • El permiso Execute para el objeto System Object ID 5210 y para el objeto System Object ID 9015.

Nota No es necesario tener derechos sobre los almacenes de datos a menos que tenga que realizar una reparación de datos.

Cambios de código

Nota Pruebe siempre las correcciones de código en un entorno controlado antes de aplicar las correcciones a los equipos de producción.

Para resolver este problema, cambie el código en el elemento Jnl.-Unidades de código de línea de poste (22). Para hacerlo, siga estos pasos.

  1. Cree una nueva función de la siguiente manera:

    PROCEDURE CheckApplFromInProduction@98(VAR GlobalItemLedgerEntry@1000 : Record 32;AppliesFromEntryNo@1001 : Integer)
    

    Para hacerlo, siga estos pasos.

    1. Agregue una variable de la siguiente manera:

      OldItemLedgerEntry@1002 : Record 32;
      
    2. Agregue el código de la función de la siguiente manera:

      IF AppliesFromEntryNo = 0 THEN
      EXIT;
      WITH GlobalItemLedgerEntry DO BEGIN
      IF "Prod. Order No." = '' THEN
      EXIT;
      OldItemLedgerEntry.GET(AppliesFromEntryNo);
      IF NOT AllowProdApplication(OldItemLedgerEntry,GlobalItemLedgEntry) THEN
      ERROR(
      Text022,
      OldItemLedgerEntry."Entry Type",
      "Entry Type",
      "Item No.",
      "Prod. Order No.");
      IF ItemApplnEntry.CheckIsCyclicalLoop("Entry No.",OldItemLedgerEntry) THEN
      ERROR(
      Text022,
      OldItemLedgerEntry."Entry Type",
      "Entry Type",
      "Item No.",
      "Prod. Order No.");
      END;IF AppliesFromEntryNo = 0 THEN
      EXIT;
      WITH GlobalItemLedgerEntry DO BEGIN
      IF "Prod. Order No." = '' THEN
      EXIT;
      OldItemLedgerEntry.GET(AppliesFromEntryNo);
      IF NOT AllowProdApplication(OldItemLedgerEntry,GlobalItemLedgEntry) THEN
      ERROR(
      Text022,
      OldItemLedgerEntry."Entry Type",
      "Entry Type",
      "Item No.",
      "Prod. Order No.");
      IF ItemApplnEntry.CheckIsCyclicalLoop("Entry No.",OldItemLedgerEntry) THEN
      ERROR(
      Text022,
      OldItemLedgerEntry."Entry Type",
      "Entry Type",
      "Item No.",
      "Prod. Order No.");
      END;
      
  2. Cambie el código de la función ItemQtyPosting de la siguiente manera:
    Código existente

    ...
    ApplyItemLedgEntry(GlobalItemLedgEntry,OldItemLedgEntry,GlobalValueEntry,FALSE);
    AutoTrack(GlobalItemLedgEntry);
    ...
    

    Código de reemplazo

    ...
    ApplyItemLedgEntry(GlobalItemLedgEntry,OldItemLedgEntry,GlobalValueEntry,FALSE);
    
    // Add the following line.
    CheckApplFromInProduction(GlobalItemLedgEntry,"Applies-from Entry");
    // End of the added line.
    
    AutoTrack(GlobalItemLedgEntry);
    ...
    

          

Requisitos previos

Debe tener uno de los siguientes productos instalados para aplicar esta revisión:

  • Microsoft Dynamics NAV 2009 R2
  • Microsoft Dynamics NAV 2009 Service Pack 1
  • Microsoft Dynamics NAV 5.0 Service Pack 1

Información sobre la eliminación

No puede quitar esta revisión.

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft que se enumeran en la sección "Aplicable a".

Nota Esto es un artículo "PUBLICACIÓN RÁPIDA" creado directamente desde la organización de soporte técnico de Microsoft. La información contenida se proporciona tal cual en respuesta a nuevos problemas. Como resultado de la rapidez en la publicación, es posible que los materiales incluyan errores tipográficos. Además, se pueden revisar en cualquier momento sin previo aviso. Consulte los Términos de uso para otras consideraciones.