Síntomas
Cuando se conecta desde un equipo con Windows 7 a un espacio de nombres DFS (recurso compartido de red) que se encuentra en Windows Server 2008 R2, puede producir el cambio de nombre o guardar archivos que se encuentran en el segundo nivel de profundidad de subdirectorio (por ejemplo, z:\d1\d2):
"El archivo o la carpeta no existe."
Además, si un archivo se guarda en el directorio z:\d1\d2, el archivo realmente aparecerá en el directorio raíz de z:\ en su lugar.
Causa
Este problema puede producirse si el equipo cliente de Windows 7 se conecta a la DFS recurso compartido de red utilizando la sintaxis \\ipaddress\SHARENAME, pero el cliente no puede conectarse al servidor mediante su nombre (es decir, \\servername\SHARENAME). Cuando se conecta un cliente de Windows 7 a la \\ipaddress\SHARENAME, el servidor indica que el nombre de recurso compartido es realmente un espacio de nombres DFS. El cliente utiliza internamente el nombre del servidor DFS para realizar un seguimiento de la ubicación de la conexión de red, pero si se produce un error en la resolución de nombres para el nombre del servidor, la ruta de acceso de la carpeta no está registrado correctamente.
Solución
Para resolver el problema, aplique la revisión en el equipo cliente o siga los pasos que se describen en la solución.
Información de la revisión
Existe un hotfix disponible desde Microsoft. Sin embargo, esta revisión se diseñó para corregir únicamente el problema que se describe en este artículo. Aplique esta revisión solamente a sistemas que experimenten el problema descripto en este artículo. Esta revisión podría ser sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la próxima actualización de software que contenga este hotfix.
Si la revisión está disponible para su descarga, hay una sección de "Descarga de revisión disponible" en la parte superior de este artículo de Knowledge Base. Si esta sección no aparece, póngase en contacto con el servicio al cliente de Microsoft y soporte técnico para obtener la revisión.
Nota: Si se producen problemas adicionales o si se requiere cualquier otra solución, será necesario crear una solicitud de revisión independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no califican para esta revisión específica. Para obtener una lista completa de los números de teléfono de servicio al cliente de Microsoft o para crear una solicitud de servicio independiente, visite el siguiente sitio Web de Microsoft:
http://support.microsoft.com/contactus/?ws=supportNota: El formulario de "Descarga de Hotfix disponible" muestra los idiomas para los que el Hotfix está disponible. Si no ve su idioma, es porque no hay una revisión para ese idioma.
Requisitos previos
Para aplicar esta revisión, debe ejecutar el Service Pack 1 (SP1) de Windows 7.
Para obtener más información acerca de cómo obtener un Windows 7 o un service pack de Windows Server 2008 R2, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
976932 información acerca de Service Pack 1 para Windows 7 y Windows Server 2008 R2
Requisito de reinicio
Debe reiniciar el equipo después de aplicar este hotfix.
Información de reemplazo de revisión
Esta revisión no sustituye a ninguna revisión publicada previamente.
Información de archivo
La versión en inglés (Estados Unidos) de esta revisión instala archivos que tienen los atributos enumerados en las tablas siguientes. Las fechas y las horas de estos archivos se muestran en la hora Universal coordinada (UTC). Las fechas y las horas de estos archivos en el equipo local se muestran en horario local junto con la diferencia de horario de verano (DST) actual. Además, las fechas y las horas pueden cambiar cuando realiza determinadas operaciones en los archivos.
Notas sobre la información de archivo de Windows 7
Importante: Correcciones urgentes de Windows 7 y Windows Server 2008 R2 se incluyen en los mismos paquetes. Sin embargo, las revisiones en la página solicitud de revisión se enumeran en ambos sistemas operativos. Para solicitar el paquete de revisiones que se aplica a uno o ambos sistemas operativos, seleccione la revisión que aparece bajo "Windows 7/Windows Server 2008 R2" en la página. Siempre consulte la sección "Aplicable a" de los artículos para determinar el sistema operativo real a la que se aplica cada revisión.
-
Los archivos que se aplican a un producto específico, SR_Level (RTM, SPn) y servicio (LDR, GDR) se pueden identificar examinando los números de versión de archivo como se muestra en la siguiente tabla.
Versión
Producto
SR_Level
Tipo de servicio
6.1.760
1.
22 xxxWindows 7
SP1
LDR
-
Los archivos MANIFEST (.manifest) y los archivos MUM (.mum) que se instalan para cada entorno están enumerados por separado en la sección "información de archivo adicional para Windows 7". MUM y los archivos de manifiesto y los archivos de catálogo (.cat) de seguridad asociados, son extremadamente importantes para mantener el estado de los componentes actualizados. Los archivos de catálogo de seguridad, para los cuales no se muestran los atributos, están firmados con una firma digital de Microsoft.
Para todas las versiones basadas en x86 compatibles de Windows 7
Nombre del archivo |
Versión del archivo |
Tamaño de archivo |
Fecha |
Hora |
Plataforma |
---|---|---|---|---|---|
Mrxsmb20.sys |
6.1.7601.22013 |
96,768 |
07-Jun-2012 |
02:22 |
x86 |
Para todas las versiones basadas en x64 compatibles de Windows 7
Nombre del archivo |
Versión del archivo |
Tamaño de archivo |
Fecha |
Hora |
Plataforma |
---|---|---|---|---|---|
Mrxsmb20.sys |
6.1.7601.22013 |
128.000 |
07-Jun-2012 |
02:45 |
x64 |
Más información
Para obtener más información acerca de la terminología de la actualización de software, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
824684 descripción de la terminología estándar que se utiliza para describir las actualizaciones de software de Microsoft
Información adicional de archivos
Información adicional de archivos para Windows 7
Archivos adicionales para todas las versiones basadas en x86 compatibles de Windows 7
Nombre del archivo |
Update.mum |
Versión del archivo |
No aplicable |
Tamaño de archivo |
2.136 |
Fecha (UTC) |
07-Jun-2012 |
Hora (UTC) |
08:05 |
Plataforma |
No aplicable |
Nombre del archivo |
X86_1e185a624ec55ec274ac14b9cc355b04_31bf3856ad364e35_6.1.7601.22013_none_5143c74e912cd003.manifest |
Versión del archivo |
No aplicable |
Tamaño de archivo |
701 |
Fecha (UTC) |
07-Jun-2012 |
Hora (UTC) |
08:05 |
Plataforma |
No aplicable |
Nombre del archivo |
X86_microsoft-windows-smb20-minirdr_31bf3856ad364e35_6.1.7601.22013_none_8d6ad9dc0126ab2b.manifest |
Versión del archivo |
No aplicable |
Tamaño de archivo |
4,035 |
Fecha (UTC) |
07-Jun-2012 |
Hora (UTC) |
06:01 |
Plataforma |
No aplicable |
Archivos adicionales para todas las versiones basadas en x64 compatibles de Windows 7
Nombre del archivo |
Amd64_9e65ee6acfddfd7eb14dd4694dd6a04b_31bf3856ad364e35_6.1.7601.22013_none_0e3b97db9b019ff6.manifest |
Versión del archivo |
No aplicable |
Tamaño de archivo |
705 |
Fecha (UTC) |
07-Jun-2012 |
Hora (UTC) |
08:05 |
Plataforma |
No aplicable |
Nombre del archivo |
Amd64_microsoft-windows-smb20-minirdr_31bf3856ad364e35_6.1.7601.22013_none_e989755fb9841c61.manifest |
Versión del archivo |
No aplicable |
Tamaño de archivo |
4,039 |
Fecha (UTC) |
07-Jun-2012 |
Hora (UTC) |
06:56 |
Plataforma |
No aplicable |
Nombre del archivo |
Update.mum |
Versión del archivo |
No aplicable |
Tamaño de archivo |
2.350 |
Fecha (UTC) |
07-Jun-2012 |
Hora (UTC) |
08:05 |
Plataforma |
No aplicable |
Más información
Aunque el problema puede reproducirse cuando se conecta desde Windows 7 para Windows Server 2008 R2, requiere un espacio de nombres DFS a configurarse para el nombre de recurso COMPARTIDO para que está establecido el bit de "Compatible con DFS" en la respuesta SMB2 Tree Connect.
Después de conectarse a un recurso compartido DFS en el servidor mediante la sintaxis \\ipaddress\SHARENAME, ningún error se muestra cuando se produce un error en la resolución de nombres en el servidor, por lo que el problema de acceso al archivo o carpeta no es aparente.
Solución alternativa
Para corregir el problema, asegúrese de que el cliente puede conectarse al servidor mediante su nombre, en lugar de su dirección IP de Windows 7. O bien, vuelva a configurar al cliente para que la resolución de nombres para el nombre del servidor es correcta. Por ejemplo, asegúrese de que el nombre del cliente del servidor DNS es correcto, o agregar una entrada del archivo hosts para indicar la dirección IP o nombre de asignación.
Por ejemplo, desde un símbolo del sistema administrativo, inicie el Bloc de notas y abra c:\windows\system32\drivers\etc\hosts y agregar una entrada. Por ejemplo, si el nombre del servidor es "NombreDeServidor" y su dirección IP es 10.0.0.1, agregue:
10.0.0.1 ServerName
NOTA: El cliente puede ser capaz de evitar el problema conectándose al servidor mediante la sintaxis \\servername\SHARENAME siempre. Esto hará que el cliente experimenta un error de conexión al conectar con el servidor si se produce un error en la resolución de nombres.