Error "No tiene una licencia" al configurar Microsoft Dynamics CRM para Microsoft Office Outlook

En este artículo se proporciona una resolución para que no tenga una licencia para usar Microsoft Dynamics CRM Online error que puede producirse al configurar Microsoft Dynamics CRM para Microsoft Office Outlook.

Se aplica a: Microsoft Dynamics CRM
Número de KB original: 3091628

Síntomas

Al intentar configurar Microsoft Dynamics CRM para Microsoft Office Outlook, recibe el siguiente mensaje de error:

No tiene una licencia para usar Microsoft Dynamics CRM Online. Póngase en contacto con el administrador de Office 365 para asignarle una licencia de Microsoft Dynamics CRM.

Causa

A su cuenta de usuario no se le ha asignado una licencia de Microsoft Dynamics CRM Online.

Nota:

Si tiene una suscripción Office 365 existente y posteriormente ha agregado una suscripción Microsoft Dynamics CRM Online, no se asigna automáticamente una licencia de Microsoft Dynamics CRM Online al registro de usuario. Si la cuenta de usuario tiene el rol Administrador global o Administrador de servicios, puede iniciar sesión en la aplicación web Microsoft Dynamics CRM para realizar acciones administrativas, pero no puede crear registros como Cuentas, Contactos, Clientes potenciales, etc. Debe tener asignada una licencia de Microsoft Dynamics CRM Online para conectar correctamente Microsoft Dynamics CRM para Microsoft Office Outlook a la instancia de Microsoft Dynamics CRM Online. Dentro de la aplicación web Microsoft Dynamics CRM Online, puede ir a Configuración>Usuarios deseguridad> y cambiar la vista a Usuarios de acceso administrativo. En esta vista se muestran los usuarios que tienen roles administrativos en el portal de Office 365 pero que no tienen asignada una licencia de Microsoft Dynamics CRM Online.

Resolución

Inicie sesión en Office 365 Portal como usuario con privilegios administrativos y asigne una licencia de Microsoft Dynamics CRM Online a su cuenta de usuario. La información de licencia puede tardar unos minutos en sincronizarse entre Office 365 y Microsoft Dynamics CRM Online.

Para obtener pasos detallados sobre cómo asignar una licencia en Office 365, consulte Agregar usuarios y asignar licencias al mismo tiempo.

Más información

Al seleccionar Detalles en el cuadro de diálogo de error o si ve el archivo de registro, se muestra el siguiente error:

Hora| Error| Excepción: al usuario no se le ha asignado ninguna licencia en Microsoft.Crm.Application.Outlook.Config. ServerInfo.RunServerDiagnostics()
en Microsoft.Crm.Application.Outlook.Config. ServerInfo.LoadUserInfo(IClientAuthProvider'1 orgAuthProvider)
en Microsoft.Crm.Application.Outlook.Config. ServerInfo.Initialize(Uri discoveryUri, OrganizationDetail selectedOrg, String displayName, Boolean isPrimary, IClientAuthProvider'1 authenticatedProvider)
en Microsoft.Crm.Application.Outlook.Config. ServerForm.LoadDataToServerInfo()
en Microsoft.Crm.Application.Outlook.Config. ServerForm.<InitializeBackgroundWorkers>b__3(Object sender, DoWorkEventArgs e)
at System.ComponentModel.BackgroundWorker.OnDoWork(DoWorkEventArgs e)
at System.ComponentModel.BackgroundWorker.WorkerThreadStart(Object argument)