El nombre del alias de alias de tabla no es único al abrir determinadas vistas en Microsoft Dynamics CRM 2011

En este artículo se proporciona una solución a un problema en el que es posible que no pueda abrir vistas después de Microsoft Dynamics CRM paquete acumulativo de actualizaciones 12 de 2011.

Se aplica a: Microsoft Dynamics CRM 2011
Número de KB original: 2907665

Síntomas

Es posible que un usuario no pueda abrir vistas después del paquete acumulativo de actualizaciones 12. Este problema se produce cuando las vistas de tipo Vista de búsqueda avanzada se modifican para que se agreguen campos de entidades relacionadas a la columna de presentación. El problema se identifica tanto con entidades predefinidas como con entidades personalizadas.

Causa

Al modificar la vista, el nodo link-entity está disponible dos veces. Pero para un único tipo de nodo de entidad de vínculo, solo debe estar disponible una vez.

Resolución

La instalación de Microsoft Dynamics CRM paquete acumulativo de actualizaciones 15 de 2011 resuelve el problema de las vistas que se modifican después de instalar el paquete acumulativo de actualizaciones 15. Las vistas existentes identificadas antes de instalar el paquete acumulativo de actualizaciones 15 que produce el error deben corregirse manualmente.

Este es un ejemplo que muestra cómo corregir el problema en una vista rota existente:

Se trata de cómo reproducir el problema:

  1. Vaya a Configuración, seleccione Personalizaciones, personalización del sistema, entidades, cuentay vista.
  2. Abra Vista de búsqueda avanzada de la cuenta y seleccione Agregar columnas.
  3. Seleccione Entidad relacionada con contacto principal (contacto) en la lista desplegable Tipo de registro .
  4. Active la casilla situada junto a Nombre completo y seleccione Aceptar.
  5. Seleccione Guardar y cerrar.
  6. Seleccione Publicar todas las personalizaciones.
  7. Abra la vista Cuentas inactivas y seleccione Editar criterios de filtro.
  8. Agregue, modifique o elimine cualquier criterio de filtro (cambie Estado = Inactivo a Estado = Activo), seleccione Aceptar y seleccione Guardar y cerrar.
  9. Seleccione Publicar todas las personalizaciones.
  10. De nuevo, en la vista Cuentas inactivas , seleccione Editar criterios de filtro y Agregar, modificar o eliminar cualquier criterio de filtro (cambie Estado = Activo a Estado = Inactivo).
  11. Seleccione Aceptar.
  12. Seleccione Guardar y cerrar.
  13. Seleccione Publicar todas las personalizaciones.
  14. Vaya a Búsqueda avanzada y seleccione Cuentas en la lista desplegable Buscar: y seleccione Cuentas inactivas en la lista desplegable Usar vista guardada .
  15. Seleccione Resultados.

A continuación se muestra cómo se corrige (con el ejemplo anterior usado para reproducir el problema):

  1. Inicie la aplicación CRM 2011.

  2. Vaya a Configuración, seleccione Personalizaciones y seleccione Soluciones.

  3. Cree una nueva solución y agréguele la entidad Account sin agregar dependencias.

  4. Ahora guarde la solución y expórela como una solución no administrada.

  5. Una vez guardado el archivo ZIP de la solución no administrada, extraiga el archivo.

  6. Abra customizations.xml archivo en un editor XML como Visual Studio 2012 y seleccione CTRL+M+M en el teclado para contraer el XML completo.

  7. Busque el nombre de la vista que estaba generando un error. En este caso, son cuentas inactivas y solo estarán presentes una vez en todo el archivo.

  8. Solo expandirá una consulta guardada en el XML.

  9. En esta sección, expanda <fetchxml> el elemento y busque <Link-entity>.

  10. Verá que el siguiente XML está duplicado:

    <link-entity name="contact" from="contactid" to="primarycontactid" visible="false" link- type="outer" alias="a_410707b195544cd984376608b1802904">
    
    <attribute name="fullname" />
    
    <attribute name="emailaddress1" />
    
    </link-entity>
    

    Solo debería estar presente una vez.

  11. Quite una entrada de este XML del archivo customizations.xml y guarde los cambios.

  12. Ahora vuelva a comprimir los archivos con loscustomizations.xmleditados , [content_Types].xml y solution.xml.

  13. Importe este archivo ZIP en la aplicación CRM y publique toda la personalización.

  14. Solucionará el problema con las vistas inactivas de la cuenta. De este modo, puede corregir todas las demás vistas que producen este error.