Síntomas

Un usuario no pueda abrir vistas después de la actualización de Rollup 12. Este problema se produce cuando se modifican las vistas de tipo "Vista de búsqueda avanzada" tener campos de entidades relacionadas que se agrega a la columna de presentación. Se identificó el problema tanto con las entidades personalizadas o fuera de la caja.

Causa

Al modificar la vista, el nodo de la entidad del vínculo está disponible dos veces. Pero, para un único tipo de entidad del vínculo nodo, debe estar disponible sólo una vez.

Solución

Instalar Microsoft Dynamics CRM 2011 Update Rollup 15 resuelve el problema de las vistas que se modifican después de instalar Update Rollup 15. Las vistas existentes identificadas antes de instalar la actualización de Rollup 15 produce el error debe corregirse manualmente.

Éste es un ejemplo que muestra cómo corregir el problema en una vista rota existente:


Se trata de cómo simplemente reproducir el problema.

1. vaya a configuración, haga clic en personalizaciones, haga clic en Personalizar el sistema, seleccione entidades, seleccione la cuenta y haga clic en ver

2. Abra la "Vista de búsqueda de avanzada cuenta" y haga clic en "Agregar columnas"

3. Seleccione "Principal contacto (Contact)" relacionados con la entidad en la lista desplegable "Tipo de registro"

4. Compruebe la casilla de verificación situada junto a "Nombre completo" y haga clic en Aceptar

5. Haga clic en Guardar y cerrar

6. Haga clic en Publicar todas las personalizaciones

7. Abra vista "Cuentas inactivas" y haga clic en "Editar criterios de filtrado"

8. agregar, modificar o eliminar cualquier filtro criterios (cambiar "estado = inactivo" a "estado = activo"), haga clic en Aceptar y haga clic en Guardar y cerrar

9. Haga clic en Publicar todas las personalizaciones

10. de nuevo, en la vista "Cuentas inactivas", haga clic en "Editar criterios de filtrado" y agregar, modificar o eliminar cualquier criterios de filtro (cambiar "estado = activo" a "estado = inactivo")

11. Haga clic en Aceptar

12. Haga clic en Guardar y cerrar

13. Haga clic en Publicar todas las personalizaciones

14. ir a búsqueda avanzada y seleccione "Cuentas" en "Buscar:" lista desplegable y seleccione inactivo "cuentas" en el menú desplegable "Usar vistas guardadas"

15. Haga clic en resultados



Le mostramos cómo se soluciona (usando el ejemplo anterior utilizado para reproducir el problema):

1. Inicie la aplicación de CRM 2011.

2. vaya a configuración, seleccione las personalizaciones y haga clic en soluciones.

3. crear una nueva solución y Agregar entidad cuenta a ella sin agregar las dependencias.

4. ahora guarde la solución y exportarla como una solución no administrada.

5. una vez guardado el archivo zip de solución no administrada, a continuación, extraiga el archivo.

6. Abra el archivo 'customizations.xml' en un editor de XML como 2012 de Visual Studio y haga clic en CTRL + M + M en el teclado para contraer el código XML completo.

7. buscar el nombre de la vista que se produce el error. En este caso es ' cuentas inactivas "y esto estará presente sólo una vez en todo el archivo.

8. así expandirá sólo 1 consulta guardada en el archivo XML.

9. en esta sección expandir el elemento < fetchxml > y < entidad del vínculo > Buscar.

10. verá que se duplica el siguiente XML:

< nombre de la entidad del vínculo = "contacto" from = "contactid" a = "primarycontactid" visible = "false" del tipo de vínculo = alias "exterior" = "a_410707b195544cd984376608b1802904" >
 
< nombre de atributo = "fullname" / >

< nombre de atributo = "emailaddress1" / >

                  </link-entity>

Esto sólo debe estar presente 1 hora.

10. quitar una entrada de este XML desde el archivo 'archivo ' customizations.xml y guardar los cambios.

11. ahora zip los archivos de nuevo con el archivo customizations.xml editado, [content_Types] .xml y solution.xml.

12. importar este archivo zip en aplicación de CRM y publicar todas las personalizaciones.

13. Esto soluciona el problema con vistas de cuentas inactivas. Se trata de cómo se pueden resolver todas las demás vistas que se produce este error.

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