El servidor Http devolvió la excepción 404 NotFound al usar la sincronización del lado servidor en Microsoft Dynamics 365

En este artículo se proporciona una resolución para resolver los mensajes de error que pueden producirse al intentar probar y habilitar un buzón en Microsoft Dynamics 365.

Se aplica a: Microsoft Dynamics C5 2016
Número de KB original: 3214661

Síntomas

Al probar y habilitar un buzón en Microsoft Dynamics 365 (anteriormente conocido como Microsoft Dynamics CRM Online), se produce uno de los siguientes errores en el área Alertas:

  • El nombre> del buzón <de correo no se sincronice porque se produjo un error al conectarse al servidor de correo electrónico. Se ha notificado al propietario del perfil <de servidor de correo electrónico asociado Email nombre> del perfil de servidor.
  • El nombre> del buzón de correo <no sincronice citas, contactos y tareas porque se produjo un error al conectarse al servidor de Microsoft Exchange. Se ha notificado al propietario del perfil <de servidor de correo electrónico asociado Email nombre> del perfil de servidor.
  • No se puede enviar el mensaje de correo electrónico Mensaje de prueba porque se produjo un error al conectarse al servidor de correo electrónico. El nombre> del buzón de correo <no se sincronice. Se ha notificado al propietario del perfil <de servidor de correo electrónico asociado Email nombre> del perfil de servidor.

Cada uno de los errores anteriores también incluye el siguiente código de error:

Email código de error del servidor: el servidor Http devolvió la excepción 404 NotFound.

Causa

Este problema puede ocurrir debido a uno de los siguientes motivos:

  1. No se encontró el buzón del usuario porque la dirección de correo electrónico no es correcta o el buzón no está disponible actualmente.
  2. La configuración del perfil de servidor Email asociado no está configurada correctamente para poder localizar el buzón.

Resolución

Para solucionar este problema, siga estos pasos:

  1. Compruebe que la dirección de correo electrónico del registro de buzón en Microsoft Dynamics 365 coincide con la dirección de correo electrónico de Exchange. El error incluye un vínculo al registro de buzón en Microsoft Dynamics 365. Puede usar este vínculo para comprobar rápidamente el campo Dirección de Email. Si la dirección de correo electrónico es correcta, compruebe que el buzón está disponible; para ello, ábralo con la aplicación de correo electrónico, como Microsoft Outlook o Outlook Web Access.
  2. Compruebe la configuración del perfil de servidor de Email asociado. Si usa Microsoft Dynamics 365 (en línea) con Exchange local, asegúrese de que usa un perfil de servidor de correo electrónico Exchange Server (híbrido). Use solo un perfil de Exchange Online para los usuarios que tengan buzones en Exchange Online.

Más información

Al seleccionar Ver detalles, verá detalles de error como los siguientes:

ActivityId: <GUID>
Error: System.Net.WebException: Se produjo un error en la solicitud con el estado HTTP 404: No encontrado.
at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall)
at System.Web.Services.Protocols.SoapHttpClientProtocol.EndInvoke(IAsyncResult asyncResult)
at Microsoft.Crm.Asynchronous.EmailConnector.ExchangeServiceBinding.EndFindItem(IAsyncResult asyncResult)
at Microsoft.Crm.Asynchronous.EmailConnector.FindItemsStep.EndCall()
at Microsoft.Crm.Asynchronous.EmailConnector.ExchangeIncomingEmailProviderStep.EndOperation()

ActivityId: <GUID>
Error: System.Net.WebException: Se produjo un error en la solicitud con el estado HTTP 404: No encontrado.
at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall)
at System.Web.Services.Protocols.SoapHttpClientProtocol.EndInvoke(IAsyncResult asyncResult)
at Microsoft.Crm.Asynchronous.EmailConnector.ExchangeServiceBinding.EndCreateItem(IAsyncResult asyncResult)
at Microsoft.Crm.Asynchronous.EmailConnector.ExchangeOutgoingEmailProvider.EndCreateItem()

T:593
ActivityId: <GUID>
Excepción : Excepción no controlada: Microsoft.Exchange.WebServices.Data.ServiceRequestException: Error en la solicitud. El servidor remoto devolvió un error: (404) No encontrado.
at Microsoft.Exchange.WebServices.Data.ServiceRequestBase.EndGetEwsHttpWebResponse(IEwsHttpWebRequest request, IAsyncResult asyncResult)
at Microsoft.Exchange.WebServices.Data.SimpleServiceRequestBase.EndInternalExecute(IAsyncResult asyncResult)
at Microsoft.Exchange.WebServices.Data.MultiResponseServiceRequest'1.EndExecute(IAsyncResult asyncResult)
at Microsoft.Exchange.WebServices.Data.ExchangeService.EndSyncFolderHierarchy(IAsyncResult asyncResult)
at Microsoft.Crm.Asynchronous.EmailConnector.MonitoredExchangeService.EndSyncFolderHierarchy(IAsyncResult asyncResult)
at Microsoft.Crm.Asynchronous.EmailConnector.ExchangeSyncSteps.ExchangeSyncAsyncRemoteStep'2.AfterCall()
at Microsoft.Crm.Asynchronous.EmailConnector.ExchangeSyncSteps.ExchangeSyncAsyncRemoteStep'2.E...