El enrutador de correo electrónico Configuration Manager no pudo recuperar información de usuario y cola del error del servidor Microsoft Dynamics CRM al seleccionar Cargar datos en Microsoft Dynamics CRM 2011

En este artículo se proporciona una solución a un error que se produce al seleccionar Cargar datos en Microsoft Dynamics CRM 2011.

Se aplica a: Microsoft Dynamics CRM 2011
Número de KB original: 2531924

Síntomas

Después de configurar el enrutador de correo electrónico de Microsoft Dynamics CRM 2011 y seleccionar Cargar datos para probar los usuarios del enrutador de correo electrónico crm, recibirá un mensaje de error similar al siguiente ejemplo:

El enrutador de correo electrónico Configuration Manager no pudo recuperar información de usuario y cola del servidor de Microsoft Dynamics CRM. Esto puede indicar que el servidor de Microsoft Dynamics CRM está ocupado. Compruebe que la dirección URL "https://dev.crm.dynamics.com/CrmOrgName" es correcta. Además, este problema puede producirse si las credenciales de acceso especificadas son insuficientes. Para volver a intentarlo, haga clic en Cargar datos. (Se recibió un error no seguro o protegido incorrectamente de la otra parte. Consulte la excepción FaultException interna para obtener el código de error y los detalles).

Causa

Este problema puede producirse debido a cualquiera de los siguientes motivos:

  • El equipo en el que está instalado crm 2011 E-mail Router tiene un problema que afecta a la hora, la fecha o ambos. En concreto, la hora universal coordinada (UTC) en el equipo no es correcta en unos minutos.
  • La cuenta de servicio especificada en el perfil de implementación del enrutador de correo electrónico crm Configuration Manager está bloqueada en Active Directory.
  • La cuenta de servicio especificada en el perfil de implementación del enrutador de correo electrónico crm Configuration Manager tiene permisos de inicio de sesión restrictivos en Active Directory.

Resolución

  • Solución 1

    Actualice la hora y la fecha a los valores locales y la zona horaria correctos en el equipo en el que está instalado crm 2011 E-mail Router. Para ello, siga estos pasos:

    1. Salga del Asistente para configuración del enrutador de correo electrónico de CRM.

    2. Cambie la fecha y hora del sistema operativo mediante una de las siguientes opciones:

      Opción 1: cambiar manualmente la hora del sistema operativo

      1. Seleccione Inicio, seleccione Panel de control, reloj, idioma y región y, a continuación, seleccione Fecha y hora.
      2. Seleccione Cambiar fecha y hora para cambiar la configuración de fecha y hora. Seleccione la fecha (por ejemplo , 1 de febrero de 2011) en el calendario, cambie la hora y, a continuación, seleccione Aceptar.
      3. Seleccione Cambiar zona horaria, seleccione la zona horaria , aplicary, a continuación, seleccione Aceptar.

      Nota:

      Estos pasos son para sistemas operativos Windows 7 o Windows Server 2008 R2. Para cambiar la fecha y hora en Windows XP, consulte el manual de ayuda del sistema operativo.

      Opción 2: Configurar la hora del sistema operativo para sincronizar con un servidor de hora de Internet

      1. Seleccione Inicio, seleccione Panel de control, reloj, idioma y región y, a continuación, seleccione Fecha y hora.
      2. Seleccione la pestaña Hora de Internet y, a continuación, seleccione Cambiar configuración.
      3. Active la casilla situada junto a Sincronizar con un servidor de hora de Internet, seleccione un servidor de hora, seleccione Actualizar ahora y, a continuación, seleccione Aceptar.

      Opción 3: Sincronizar el tiempo en el dominio desde un símbolo del sistema

      Si la máquina es miembro de un dominio, use un símbolo del sistema para sincronizar la hora de la máquina con la hora del dominio. Para ello, siga estos pasos.

      Nota:

      Antes de realizar estas instrucciones, confirme que la hora es correcta en el servidor de hora. Para ello, abra un símbolo del sistema, escriba net time y presione Entrar.

      1. Abra un símbolo del sistema con privilegios elevados; para ello, seleccione Inicio, Todos los programas, Accesorios, Símbolo del sistema con el botón derecho y, después, Ejecutar como administrador.

      2. En el símbolo del sistema, ejecute el siguiente comando:

        net time [{\\ComputerName | /domain[:DomainName] | /rtsdomain[:DomainName]}] [/set]
        

      Nota:

      Para obtener más información sobre el comando net time, consulte Net time

      Opción 4: si la máquina usa un cliente NTP para sincronizarse con un servidor NTP, fuerce una sincronización del cliente NTP.

    3. Abra el Asistente para configuración del enrutador de correo electrónico de CRM.

    4. Seleccione la pestaña Usuarios, Colas y Reenviar buzones .

    5. Seleccione Cargar datos.

    Los datos de usuario de CRM ahora se cargarán correctamente.

  • Solución 2

    Desbloquee la cuenta especificada en el perfil de implementación del enrutador de correo electrónico crm Configuration Manager. Para ello, siga estos pasos:

    1. En un controlador de dominio, inicie Usuarios y equipos de Active Directory.
    2. Busque la cuenta de Active Directory especificada en el perfil de implementación, haga clic con el botón derecho en ella y, a continuación, seleccione Propiedades.
    3. Haga clic con el botón derecho en la cuenta de usuario y, a continuación, seleccione Propiedades.
    4. Seleccione la pestaña Cuenta .
    5. Desactive la casilla Desbloquear cuenta .
    6. Cierre el enrutador de correo electrónico crm Configuration Manager si sigue abierto.
    7. En el servidor en el que está instalado CRM E-mail Router, reinicie el servicio Microsoft CRM Email Router. Para ello, seleccione Inicio, Ejecutar, escriba services.msc y, a continuación, seleccione Aceptar. Busque el servicio Microsoft CRM Email Router, haga clic con el botón derecho en él y, a continuación, seleccione Reiniciar.
    8. Vuelva a iniciar el Configuration Manager crm E-mail Router.
    9. Seleccione la pestaña Usuarios, Colas y Reenviar buzones .
    10. Seleccione Cargar datos.

    La información del usuario ahora debe cargarse correctamente.

  • Resolución 3

    Agregue los servidores CRM y Servicios de federación de Active Directory (AD FS) (AD FS) a la lista de servidores de inicio de sesión de la cuenta de servicio especificada en el perfil de implementación. Para ello, siga estos pasos:

    1. En un controlador de dominio, inicie Usuarios y equipos de Active Directory.
    2. Busque la cuenta de Active Directory especificada en el perfil de implementación, haga clic con el botón derecho en ella y, a continuación, seleccione Propiedades.
    3. Seleccione la pestaña Cuenta .
    4. Seleccione Iniciar sesión en.
    5. Si la opción Este usuario puede iniciar sesión en está establecida en Los siguientes equipos, asegúrese de que los servidores DE AD FS y CRM se especifican en esta lista de equipos. Si no se especifican, agréguelos a la lista.
    6. Vuelva a iniciar el Configuration Manager crm E-mail Router.
    7. Seleccione la pestaña Usuarios, Colas y Reenviar buzones .
    8. Seleccione Cargar datos.

    La información de los usuarios ahora debe cargarse correctamente.