Aparece el mensaje de error "La solución [Nombre de la solución] no tiene una actualización que esté lista para aplicarse" en Microsoft Dynamics 365

En este artículo se proporciona una solución a un error que se produce al seleccionar una solución en Dynamics 365 y, a continuación, seleccionar el botón Aplicar actualización de la solución.

Se aplica a: Microsoft Dynamics 365
Número de KB original: 4457858

Síntomas

Al seleccionar una solución en Dynamics 365 y, a continuación, seleccionar el botón Aplicar actualización de la solución, recibirá el siguiente error:

"La acción no está disponible.
La solución [Nombre de la solución] no tiene una actualización que esté lista para aplicarse".

Si selecciona Descargar archivo de registro, el archivo de registro incluye una referencia al código de error -2147187397.

Causa

Este mensaje aparece si la solución seleccionada no tiene una actualización de la solución que se va a aplicar.

El botón Aplicar actualización de la solución está pensado para usarse cuando haya importado una actualización para otra solución que ya está instalada. Al importar la solución actualizada, aparece una opción Fase para la actualización . Si esta casilla está seleccionada, la acción de actualización no se realiza durante la importación de la solución. Aparece un botón Aplicar actualización de la solución al final del proceso de importación. Si no seleccionó este botón, puede encontrar la solución primaria en la lista de soluciones y, a continuación, seleccionar Aplicar actualización de la solución.

Solución

Use solo el botón Aplicar actualización de solución si ha importado una actualización para una solución que ya estaba instalada y ha elegido la opción Fase de actualización .