Buzón inactivo no es a conectarse automáticamente a una cuenta de Active Directory local

Síntomas

Cuando la cuenta de Active Directory local entra de nuevo en el ámbito de Azure Connect de AD, el buzón inactivo no se vuelve a conectar automáticamente en Exchange Online. Además, recientemente creado se crea un buzón de Exchange en línea.

Note Para los clientes de Microsoft Office 365 dedicado/ITAR, Microsoft Managed Services Service Provisioning proveedor (MMSSPP) vuelve a escribir el msExchMailboxGUID y atributos ExchangeGUID desde el entorno de dedicada a un cliente en instalaciones Active Directory durante la fase de coexistencia. En lugar de un buzón recientemente creado en Exchange Online, se crea un usuario con correo habilitado. Para obtener más información, vea un usuario no puede tener acceso a un buzón que está configurado en Office 365 dedicado/ITAR (vNext).

Causa

Después de quitan objetos de buzón del ámbito de aplicación de Azure Connect de AD, permanecerán en la Papelera de reciclaje de AD Azure durante 30 días. Tendrá que realizar pasos adicionales para volver a conectar un local cuenta de AD un buzón inactivo cuando la cuenta se elimina de la Papelera de reciclaje.

Solución

Para resolver este problema, utilice los siguientes procesos.

Transferir el contenido del buzón de correo original

Restaurar el contenido del buzón de correo inactivo al buzón recientemente creado mediante el cmdlet New-MailboxRestoreRequest . Esto le permite seguir utilizando el buzón nuevo y copiar el contenido original.

Vuelva a conectar el buzón original inactivo

Note Este proceso también funciona para los buzones eliminados suave si se conectan a una nueva cuenta de AD local. El parámetro SoftDeletedMailbox debe utilizarse para sustituir el parámetro InactiveMailboxOnly .

  1. Ejecute el siguiente comando para obtener los atributos de buzones inactivos de Exchange: $InactiveMailbox = Get-Mailbox -InactiveMailboxOnly -Identity <identity of inactive mailbox>

  2. Ejecute el comando siguiente para asociar temporalmente inactivo buzón a una cuenta de nube. Una cuenta se sincronizará a Azure AD: New-Mailbox -InactiveMailbox $InactiveMailbox.DistinguishedName -Name "<name of inactive mailbox>" -DisplayName "<DisplayName of inactive mailbox>" -MicrosoftOnlineServicesID <alias@*.onmicrosoft.com> - Password (ConvertTo-SecureString -String <PasswordString> -AsPlainText -Force) -ResetPasswordOnNextLogon $true

  3. Obtener el valor del parámetro ImmutableID . De forma predeterminada, esto es el atributo ObjectGUID local como una cadena base-64. Se puede convertir ObjectGUID utilizando el siguiente comando en Windows PowerShell: [system.convert]::ToBase64String(([GUID]"<ObjectGUID>").tobytearray())

  4. En AD de Azure, obtener el valor del parámetro ObjectID Azure nueva cuenta AD que se ha sincronizado desde Exchange Online. Para ello, ejecute el siguiente comando:  Get-MsolUser -UserPrincipalName <UPN> | fl objectID

  5. Establezca el parámetro ImmutableID en Azure AD: Set-MsolUser -ObjectId  <ObjectId>  -ImmutableId <ImmutableId>

  6. Traer la cuenta original de Azure AD en el ámbito de Azure Connect de AD.

  7. Compruebe el objeto de buzón y compruebe que la dirección SMTP principal se actualiza desde un valor de nombre principal (de usuario UPN) de usuario temporal a la dirección principal correcta. Note El nuevo buzón no está habilitado para la retención para litigios. Además, recibirá el mensaje de advertencia siguiente:

    Advertencia: Se ha recuperado el buzón inactivo. Para conservar los datos hasta que obtenga una licencia válida, hemos habilitado recuperación de elemento único durante 30 días. Además hemos también habilitado retener durante 30 días. Una vez que se ha asignado una licencia válida para este buzón, puede deshabilitar a esta configuración y utilizar litigios o mantenga en el lugar para conservar los datos.

  8. Aplicar la licencia de Exchange Server y la configuración de suspensión apropiado al nuevo buzón.

Más información

Los pasos descritos en la sección "Resolución" son adaptaciones de las instrucciones del buzón de nube en restaurar un buzón inactivo en Office 365.

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