Coherencia de actualización de la solución de Microsoft Dynamics 365 Portal para implementaciones de varios portales

En este artículo se proporciona una solución a un error que se produce al navegar a un portal asociado a una instancia de Dynamics 365 que contiene algunas soluciones que aún no se han actualizado.

Se aplica a: Microsoft Dynamics CRM
Número de KB original: 4020942

Síntomas

Después de una actualización a las soluciones que admiten un complemento de portal en el Centro de Dynamics 365 Administración, los clientes que tienen varios complementos del portal asociados a la misma instancia de Dynamics 365 podrían experimentar errores si las soluciones para otros tipos de portal aún no se han actualizado. Los usuarios que navegan a un portal asociado a una instancia de Dynamics 365 que contiene algunas soluciones que aún no se han actualizado pueden recibir un error similar al siguiente ejemplo:

Lo sentimos, pero algo salió mal.
[00000000-0000-0000-0000-000000000000]
Nos han notificado sobre este problema y lo echaremos un vistazo en breve.
Gracias por tu paciencia.

Causa

Cuando se implementa un complemento de portal en una instancia de Dynamics 365, se instalan varias soluciones para admitir la funcionalidad del portal. Novedades a estas soluciones están disponibles a medida que se publican mejoras y correcciones, y los clientes pueden implementar esas actualizaciones realizando las acciones adecuadas en el Centro de Dynamics 365 Administración.

Dado que varios tipos de portal comparten muchas soluciones, la actualización de un único tipo de portal sin actualizar ningún otro tipo de portal que se implemente en la misma instancia de Dynamics 365 provocará errores y podría hacer que uno o varios portales no se puedan usar.

Resolución

Para evitar problemas de discrepancia en la versión de la solución, las soluciones para todos los tipos de portal implementadas en una única instancia de Dynamics 365 deben actualizarse más adelante y durante el mismo intervalo de tiempo. Para actualizar las soluciones de complementos del portal para los tipos de portal implementados, se deben realizar los pasos siguientes:

  1. Inicie sesión en el Centro de Dynamics 365 Administración con un usuario con permisos suficientes para actualizar las soluciones de Dynamics 365.
  2. En la pestaña Instancias , seleccione la instancia que tiene dos o más portales implementados.
  3. Con la instancia seleccionada, seleccione el icono Soluciones en el panel de la derecha.
  4. En la vista Soluciones , seleccione un tipo de portal (como Community Portal) que se haya implementado en esta instancia.
  5. Si aparece el botón Actualizar en el panel derecho, selecciónelo para actualizar las soluciones correspondientes en la instancia de Dynamics 365.
  6. Una vez finalizada la actualización, seleccione el siguiente tipo de portal disponible en la vista Soluciones y repita el paso 5.

Cuando se hayan actualizado todos los tipos de portal, no se producirán errores de discrepancia en la versión de la solución.