Email Enrutador no puede enviar correo electrónico desde Microsoft Dynamics debido a los permisos
En este artículo se proporciona una solución a un problema por el que Email Router no puede enviar correo electrónico desde Microsoft Dynamics debido a los permisos.
Se aplica a: Microsoft Dynamics 365 Customer Engagement Online
Número de KB original: 4494727
Síntomas
Cuando se usa el enrutador de Dynamics 365 Email para enviar correo electrónico desde una instancia de Dynamics 365, el correo electrónico puede entrar en un estado de envío pendiente y nunca enviar realmente:
Los registros de excepciones de Dynamics Email Router pueden mostrar el siguiente error:
Error al comprobar si hay mensajes de correo electrónico salientes que se van a procesar:
https://disco.crm.dynamics.com/\<OrgName>
. System.ServiceModel.FaultException'1[Microsoft.Xrm.Sdk.OrganizationServiceFault]: el usuario no tiene privilegios de envío como. (Detalles de error es igual a detalles de excepción:ErrorCode: 0x8004480D
Mensaje: El usuario no tiene privilegios de envío como.
Causa
Este comportamiento puede haber funcionado sin necesidad de estos permisos en versiones anteriores de la aplicación Dynamics 365. Debido a los cambios introducidos en el modelo de seguridad en determinadas iteraciones de las versiones 8.2.2 y 9.x, estos permisos deben concederse explícitamente para que el enrutador de correo electrónico envíe correos electrónicos a otro usuario.
Solución
El usuario que envía este correo electrónico debe permitir que los correos electrónicos se envíen desde otros usuarios de Dynamics en sus opciones personales:
El enrutador de Email también debe tener el permiso Send Email as Another User (Enviar Email como otro usuario) en Dynamics:
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Comentarios
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