Síntomas

Cuando se usa Dynamics 365 Email Router para enviar correo electrónico desde una instancia de Dynamics 365, el correo electrónico puede entrar en un estado de "Envío pendiente" y nunca enviar realmente:

Envío pendiente

Los registros de excepción de Dynamics Email Router pueden mostrar el siguiente error:

Se ha producido un error al comprobar si se procesarán los mensajes de correo electrónico salientes: https://disco.crm.dynamics.com/<OrgName>. System.ServiceModel.FaultException'1[Microsoft.Xrm.Sdk.OrganizationServiceFault]: el usuario no tiene el privilegio send-as. (Detalle de la falla es igual a los detalles de la excepción:

ErrorCode: 0x8004480DMensaje: El usuario no tiene el privilegio send-as.

Causa

Este comportamiento puede haber funcionado sin necesidad de estos permisos en versiones anteriores de la aplicación Dynamics 365. Debido a los cambios introducidos en el modelo de seguridad en ciertas iteraciones de las versiones 8.2.2 y 9.x, estos permisos deben concederse explícitamente para que el enrutador de correo electrónico envíe correos electrónicos en nombre de otro usuario.

Resolución

El usuario que envía este correo electrónico debe permitir que se envíen correos electrónicos de otros usuarios de Dynamics en sus opciones personales:

Opciones personales

La cuenta que está utilizando El E-mail Router también debe tener el permiso "Enviar correo electrónico como otro usuario" dentro de Dynamics:

Rol de seguridad

Más información

Dynamics 365, versión 9.0 E-mail Router

Microsoft Dynamics Email Router está en desuso

Cómo migrar de E-mail Router a Sincronización del lado del servidor

 

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