Iniciar sesión con Microsoft
Iniciar sesión o crear una cuenta
Hola:
Seleccione una cuenta diferente.
Tiene varias cuentas
Elija la cuenta con la que desea iniciar sesión.

Este artículo se aplica a Microsoft Dynamics NAV para los siguientes países y configuraciones regionales de idioma.

  • Alemán (Alemania) (de-de)

  • Austria (Austria) (at-at)

  • Francés (Suiza) (fr-ch)

  • Alemán (Suiza) (de-ch)

  • Italiano (Suiza) (it-ch)

Síntomas

Al ejecutar el "Físico publicado. Invt. Diferencia de pedido". El informe no muestra diferencias. El informe tiene la columna Líneas esperadas, la columna Líneas de grabación y la columna Líneas de seguimiento. La columna de la derecha siempre está vacía. Este problema se produce en los siguientes productos:

  • La versión en alemán de Microsoft Dynamics NAV 2009 R2

  • La versión austriaca de Microsoft Dynamics NAV 2009 R2

  • La versión suiza de Microsoft Dynamics NAV 2009 R2

  • La versión en alemán de Microsoft Dynamics NAV 2009 Service Pack 1

  • La versión austriaca de Microsoft Dynamics NAV 2009 Service Pack 1

  • La versión suiza de Microsoft Dynamics Service Pack 1

Causa

Este problema se produce porque la variable TempPhysInvtDiffListBuffer2 del informe es una variable local y la variable nunca se asigna desde ningún lugar del informe. Además, la variable no es una variable temporal. Por lo tanto, la variable apunta al verdadero "Phys. Invt. Diferenciar. Tabla "Búfer de lista" que siempre está vacía.

Resolución

Información de revisiones

Microsoft ya tiene disponible una revisión compatible. Sin embargo, solo está destinado a corregir el problema que se describe en este artículo. Apliquen solo a los sistemas que están experimentando este problema específico. Esta revisión puede recibir pruebas adicionales. Por lo tanto, si no se ve gravemente afectado por este problema, le recomendamos que espere al próximo Service Pack de Microsoft Dynamics NAV 2009 o a la próxima versión de Microsoft Dynamics NAV que contiene esta revisión.

Nota En casos especiales, los cargos que normalmente se incurran en llamadas de soporte técnico se pueden cancelar si un profesional de soporte técnico para Microsoft Dynamics y productos relacionados determina que una actualización específica resolverá el problema. Los costos de soporte técnico habituales se aplicarán a preguntas y problemas de soporte técnico adicionales que no reúnen los requisitos para la actualización específica en cuestión.


Información de instalación

Microsoft proporciona ejemplos de programación con fines ilustrativos únicamente, sin ninguna garantía, ya sea expresa o implícita. Esto incluye, entre otras, las garantías implícitas de comerciabilidad e idoneidad para un fin determinado. En este artículo se da por supuesto que ya conoce el lenguaje de programación que se muestra, así como las herramientas empleadas para crear y depurar procedimientos. Los ingenieros de soporte técnico de Microsoft pueden ayudar a explicar la funcionalidad de un procedimiento determinado. Sin embargo, no modificarán estos ejemplos para proporcionar funcionalidad adicional o crear procedimientos para cumplir sus requisitos específicos.

Nota Antes de instalar esta revisión, compruebe que todos los usuarios del cliente de Microsoft Navision hayan cerrado sesión en el sistema. Esto incluye usuarios cliente de Microsoft Navision Application Services (NAS). Debe ser el único usuario cliente que haya iniciado sesión al implementar esta revisión.

Para implementar esta revisión, debe tener una licencia de desarrollador.

Se recomienda asignar a la cuenta de usuario en la ventana Inicios de sesión de Windows o en la ventana Inicios de sesión de la base de datos el id. de rol "SUPER". Si a la cuenta de usuario no se le puede asignar el id. de rol "SUPER", debe comprobar que la cuenta de usuario tiene los siguientes permisos:

  • El permiso Modificar para el objeto que va a cambiar.

  • El permiso Ejecutar para el objeto Id. de objeto del sistema 5210 y para el objeto Id. de objeto del sistema 9015.



Nota No tiene que tener derechos sobre los almacenes de datos a menos que tenga que realizar la reparación de datos.

Cambios de código

Nota Pruebe siempre las correcciones de código en un entorno controlado antes de aplicar las correcciones a los equipos de producción.
Para resolver este problema, siga estos pasos:

  1. Cambie la variable TempPhysInvtDiffListBuffer2 en la función CreateDiffListBuffer de una variable local a una variable global del Phys publicado. Invt. Diferencia de pedido. (5005351) de la siguiente manera:

    TempPhysInvtDiffListBuffer2@1140019 : TEMPORARY Record 5005363;

    tempphysinvtdifflistbuffer2@1140019

  2. Cambie el código de la función FindOrCreateDiffListBuffer en el Phys publicado. Invt. Diferencia de pedido. informe (5005351) de la siguiente manera:
    Código existente

      TempPhysInvtDiffListBuffer.INSERT;
    NoOfBufferLines := NoOfBufferLines +1;
    END ELSE BEGIN
    IF NextLineNo = 1 THEN
    ...

    Código de reemplazo

    ...
    TempPhysInvtDiffListBuffer.INSERT;
    NoOfBufferLines := NoOfBufferLines +1;

    // Add the following lines.
    TempPhysInvtDiffListBuffer2 := TempPhysInvtDiffListBuffer;
    TempPhysInvtDiffListBuffer2.INSERT;
    // End of the lines.

    END ELSE BEGIN
    IF NextLineNo = 1 THEN
    ...

Requisitos previos

Debe tener uno de los siguientes productos instalados para aplicar esta revisión:

  • La versión en alemán de Microsoft Dynamics NAV 2009 R2

  • La versión austriaca de Microsoft Dynamics NAV 2009 R2

  • La versión suiza de Microsoft Dynamics NAV 2009 R2

  • La versión en alemán de Microsoft Dynamics NAV 2009 Service Pack 1

  • La versión austriaca de Microsoft Dynamics NAV 2009 Service Pack 1

  • La versión suiza de Microsoft Dynamics Service Pack 1

Información sobre la eliminación

No puede quitar esta revisión.

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "Se aplica a".

Nota Este es un artículo "FAST PUBLISH" creado directamente desde la organización de soporte técnico de Microsoft. La información contenida en este documento se proporciona tal y como se muestra en respuesta a problemas emergentes. Como resultado de la velocidad de su disponibilidad, los materiales pueden incluir errores tipográficos y pueden revisarse en cualquier momento sin previo aviso. Consulte Términos de uso para otras consideraciones.

¿Necesita más ayuda?

¿Quiere más opciones?

Explore las ventajas de las suscripciones, examine los cursos de aprendizaje, aprenda a proteger su dispositivo y mucho más.

Las comunidades le ayudan a formular y responder preguntas, enviar comentarios y leer a expertos con conocimientos extensos.

¿Le ha sido útil esta información?

¿Cuál es tu grado de satisfacción con la calidad del lenguaje?
¿Qué ha afectado a su experiencia?
Si presiona Enviar, sus comentarios se usarán para mejorar los productos y servicios de Microsoft. El administrador de TI podrá recopilar estos datos. Declaración de privacidad.

¡Gracias por sus comentarios!

×