Iniciar sesión con Microsoft
Iniciar sesión o crear una cuenta
Hola:
Seleccione una cuenta diferente.
Tiene varias cuentas
Elija la cuenta con la que desea iniciar sesión.

Síntomas

Imagine el siguiente escenario:

  • Tiene un equipo que ejecuta Windows 8 o Windows Server 2012.

  • Imprimir un archivo mediante una aplicación de 32 bits.

  • El trabajo de impresión ha finalizado correctamente.

En este escenario, el proceso de Splwow64.exe no termina inmediatamente.

Nota: El proceso de Splwow64.exe se utiliza para traducir el modelo de controlador de un sistema operativo de 64 bits y un programa de 32 bits. Splwow64.exe se utiliza para admitir la característica de aislamiento del controlador de impresora. La versión de 32 bits de Windows 8 tiene su propio archivo de Splwow64.exe y la versión de 32 bits de Splwow64.exe también se ve afectada por este problema. Para obtener más información acerca de aislamiento de aplicaciones, consulte el siguiente sitio Web MSDN:

Causa

Este problema se produce porque el proceso de Splwow64.exe permanece en memoria durante más tiempo del necesario con el fin de aumentar el rendimiento del sistema después de finaliza un trabajo de impresión.

Solución

Esta revisión también está disponible en el .

Después de aplicar este hotfix, el hotfix establece el valor de tiempo de espera predeterminado para que el proceso de Splwow64.exe permanezca en memoria durante dos minutos. Por lo tanto, el proceso de Splwow64.exe finaliza dos minutos después de que termine el último trabajo de impresión. Además, puede configurar este valor de tiempo de espera, cambie el valor del registro. Para configurar el valor de tiempo de espera, siga estos pasos:

Importante: esta sección, el método o la tarea contiene pasos que indican cómo modificar el registro. Sin embargo, pueden producirse problemas graves si modifica incorrectamente el registro. Por lo tanto, asegúrese de que sigue estos pasos cuidadosamente. Para una mayor protección, haga una copia de seguridad del registro antes de modificarlo. Entonces, puede restaurar el registro si se produce un problema. Para obtener más información acerca de cómo hacer copia de seguridad y restaurar el registro, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:

cómo hacer copia de seguridad y restaurar el registro en Windows

  1. Deslice desde el borde derecho de la pantalla y, a continuación, pulse Buscar. O bien, si utiliza un mouse, elija la esquina inferior derecha de la pantalla y, a continuación, haga clic en Buscar.

  2. En el cuadro de búsqueda, escriba regedit y, a continuación, puntee o haga clic en regedit.

    UAC Si se le pide que introduzca una contraseña de administrador, escriba la contraseña. Si se le pide que proporcione una confirmación, proporcione una confirmación.

  3. Busque y, a continuación, puntee o haga clic en la subclave del registro siguiente:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print

  4. En el menú Edición , seleccione nuevo y, a continuación, puntee o haga clic en Valor DWORD.

  5. Tipo SplWOW64TimeOutSeconds.

  6. Presione y mantenga presionada o secundario SplWOW64TimeOutSecondsy, a continuación, puntee o haga clic en Modificar.

  7. En el cuadro información del valor , escriba un valor y, a continuación, puntee o haga clic en Aceptar.

  8. Salga del Editor del Registro.

Nota: Debe especificar un valor mayor que cero en el cuadro datos de valor . El valor que especifique es los segundos que el sistema espera periódicamente mientras comprueba si el proceso de Splwow64.exe se descarga. Este comportamiento se produce cuando ha transcurrido el mismo número de segundos después de que ha cerrado el último proceso de impresión de 32 bits. Por lo tanto, cuando un servicio proceso imprime, la capacidad de impresión no se libera hasta que se cierre el servicio y en ha pasado por lo menos el tiempo que especifique en el cuadro datos de valor . Por ejemplo, si escribe 15 en el cuadro información del valor y el último proceso de 32-bit toma dos minutos en Imprimir y, a continuación, cierre, se libera la capacidad de impresión entre dos minutos y 15 segundos y dos minutos y 30 segundos. Si no se especifica ningún valor de tiempo de espera, el valor de tiempo de espera predeterminado es de dos minutos.

Información de la revisión

Existe un hotfix disponible desde Microsoft. Sin embargo, esta revisión se diseñó para corregir únicamente el problema que se describe en este artículo. Aplíquela sólo a sistemas que experimenten este problema específico.

Si la revisión está disponible para su descarga, entonces podrá ver una sección de "Descarga de revisión disponible" en la parte superior de este artículo de Knowledge Base. Si esta sección no aparece, envíe una solicitud al servicio de atención al cliente y soporte técnico para obtener la revisión.

Nota: Si se producen problemas adicionales o si se requiere cualquier otra solución, será necesario crear una solicitud de revisión independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no califican para esta revisión específica. Para obtener una lista completa de los números de teléfono de servicio al cliente de Microsoft o para crear una solicitud de servicio independiente, visite el siguiente sitio Web de Microsoft:

Nota: El formulario de "Descarga de revisión disponible" muestra los idiomas para los que la revisión está disponible. Si no ve su idioma, es porque no hay una revisión para ese idioma.

Requisitos previos

Para aplicar esta revisión, debe ejecutar Windows 8 o Windows Server 2012.

Información del registro

Para utilizar la revisión de este paquete, no es necesario realizar ningún cambio en el registro.

Requisito de reinicio

Debe reiniciar el equipo después de aplicar este hotfix.

Información de reemplazo de revisión

Esta revisión no sustituye a ninguna revisión publicada previamente.

La versión global de esta revisión instala archivos que tienen los atributos enumerados en las tablas siguientes. Las fechas y las horas de estos archivos se muestran en la hora Universal coordinada (UTC). Las fechas y las horas de estos archivos en el equipo local se muestran en horario local junto con la diferencia de horario de verano (DST) actual. Además, las fechas y las horas pueden cambiar cuando realiza determinadas operaciones en los archivos.





Notas sobre la información de archivos de Windows 8 y Windows Server 2012Importante: Las hotfix de Windows 8 y Windows Server 2012 se incluyen en los mismos paquetes. Sin embargo, sólo "Windows 8" aparece en la página solicitud de revisión. Para solicitar el paquete de revisiones que se aplica a uno o ambos sistemas operativos, seleccione la revisión que aparece en "Windows 8" en la página. Siempre consulte la sección "Aplicable a" de los artículos para determinar el sistema operativo real a la que se aplica cada revisión.

  • Los archivos que se aplican a un producto, hito (RTM, SPn) y el servicio (LDR, GDR) se pueden identificar examinando los números de versión de archivo, como se muestra en la siguiente tabla:

    Versión

    Producto

    Hito

    Tipo de servicio

    6.2.920 0.16 xxx

    Windows 8 y Windows Server 2012

    RTM

    GDR

    6.2.920 0.20 xxx

    Windows 8 y Windows Server 2012

    RTM

    LDR

  • Las ramas del servicio GDR contienen solo correcciones de amplia distribución para solucionar problemas críticos extendidos. Las ramas del servicio LDR contienen revisiones además de las correcciones de amplia distribución.

  • Los archivos MANIFEST (.manifest) y los MUM archivos (.mum) que se instalan para cada entorno están enumerados por separado en la sección "Información de archivo adicional para Windows 8 y Windows Server 2012". MUM y los archivos de manifiesto y los archivos de catálogo (.cat) de seguridad asociados, son extremadamente importantes para mantener el estado de los componentes actualizados. Los archivos de catálogo de seguridad, para los cuales no se muestran los atributos, están firmados con una firma digital de Microsoft.

Para todas las versiones compatibles basadas en x86 de Windows 8

Nombre del archivo

Versión del archivo

Tamaño de archivo

Fecha

Hora

Plataforma

Splwow64.exe

6.2.9200.20738

109,056

07-Jun-2013

03:58

x86

Spoolsv.exe

6.2.9200.16384

496,640

26-Jul-2012

03:20

x86

Para todas las versiones de x64 de Windows 8 y de Windows Server 2012

Nombre del archivo

Versión del archivo

Tamaño de archivo

Fecha

Hora

Plataforma

Tipo de servicio

Splwow64.exe

6.2.9200.20738

126,464

07-Jun-2013

06:58

x64

AMD64_MICROSOFT-WINDOWS-PRINTING-SP

Spoolsv.exe

6.2.9200.20738

769,024

07-Jun-2013

06:58

x64

AMD64_MICROSOFT-WINDOWS-PRINTING-SP




Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft que se enumeran en la sección "Aplicable a".

Más información

Para obtener más información acerca del problema similar, haga clic en los números de artículo siguientes para verlos en Microsoft Knowledge Base:

Splwow64.exe proceso no termina después de que finalice un trabajo de impresión en la versión de 64 bits de Windows 7 o Windows Server 2008 R2

no puede utilizar el comando "runas" para imprimir desde distintas cuentas de usuario en una única sesión de un programa de 32 bits en un equipo que está ejecutando la versión de 64 bits de Windows Server 2008 o Windows Vista
Para obtener más información acerca de la terminología de la actualización de software, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:

descripción de la terminología estándar que se utiliza para describir las actualizaciones de software de Microsoft

Información adicional de archivos para Windows 8 y Windows Server 2012

Archivos adicionales para todas las versiones compatibles basadas en x86 de Windows 8

Nombre del archivo

X86_e34daac0d2b6d45e84ab8ebeed6de725_31bf3856ad364e35_6.2.9200.20738_none_75e00f9569a9cc12.manifest

Versión del archivo

No aplicable

Tamaño de archivo

709

Fecha (UTC)

10-Jun-2013

Hora (UTC)

10:50

Plataforma

No aplicable

Nombre del archivo

X86_microsoft-windows-printing-spooler-core_31bf3856ad364e35_6.2.9200.20738_none_d3ba6243abe0fabd.manifest

Versión del archivo

No aplicable

Tamaño de archivo

242,005

Fecha (UTC)

10-Jun-2013

Hora (UTC)

10:50

Plataforma

No aplicable

Archivos adicionales para todas las versiones basadas en x64 compatibles de Windows 8 y de Windows Server 2012

Nombre del archivo

Amd64_microsoft-windows-printing-spooler-core_31bf3856ad364e35_6.2.9200.20738_none_2fd8fdc7643e6bf3.manifest

Versión del archivo

No aplicable

Tamaño de archivo

242,555

Fecha (UTC)

07-Jun-2013

Hora (UTC)

21:33

Plataforma

No aplicable


¿Necesita más ayuda?

¿Quiere más opciones?

Explore las ventajas de las suscripciones, examine los cursos de aprendizaje, aprenda a proteger su dispositivo y mucho más.

Las comunidades le ayudan a formular y responder preguntas, enviar comentarios y leer a expertos con conocimientos extensos.

¿Le ha sido útil esta información?

¿Cuál es tu grado de satisfacción con la calidad del lenguaje?
¿Qué ha afectado a su experiencia?
Si presiona Enviar, sus comentarios se usarán para mejorar los productos y servicios de Microsoft. El administrador de TI podrá recopilar estos datos. Declaración de privacidad.

¡Gracias por sus comentarios!

×