La entidad personalizada no aparece después de importar una solución

En este artículo se proporciona una solución a un problema en el que las entidades personalizadas no se muestran después de importar una solución.

Se aplica a: Microsoft Dynamics CRM 2011
Número de KB original: 2500942

Síntomas

Después de importar una solución a otra organización, la entidad personalizada no aparece.

Causa

Se produce cuando la solución no tiene SiteMap como componente.

También puede ocurrir si no publica las personalizaciones después de importar la solución.

Resolución

Solución 1:

Incluya SiteMap como parte de la solución y vuelva a exportarla. A continuación, importe la solución en otra organización.

  1. Seleccione Configuración, seleccione Soluciones y abra la solución que desea modificar.
  2. Seleccione Extensiones de cliente, seleccione Agregar existente y elija Mapa del sitio.
  3. Seleccione Guardar.
  4. Seleccione Exportar solución y siga el Asistente para exportación para exportar la solución.

Solución 2:

Personalice la entidad personalizada importada en la organización donde se ha importado la solución para mostrar la entidad en el área que desee, como Workplace.

  1. Seleccione Configuración, Personalizaciones y Personalización del sistema.
  2. En Componentes, expanda Entidades y seleccione la entidad que desea modificar.
  3. En áreas que muestran esta entidad, seleccione las áreas para mostrar la entidad personalizada.

Resolución 3:

Publicar todas las personalizaciones:

  1. Seleccione Configuración, Personalizaciones y Personalización del sistema.
  2. Seleccione Publicar todas las personalizaciones.

Publique solo la entidad personalizada:

  1. Seleccione Configuración, Personalizaciones y Personalización del sistema.
  2. En Componentes, expanda Entidades y seleccione la entidad que desea publicar.
  3. Seleccione Publicar en la cinta de opciones.