Error "No se pudo establecer la autenticación mutua" al usar el Analizador de conectividad remota para probar Outlook en cualquier lugar de Microsoft 365

Nota:

Ya no se admite el Asistente para configuración híbrida que se incluye en el Consola de administración de Exchange de Microsoft Exchange Server 2010. Por lo tanto, ya no debe usar el asistente de configuración híbrida anterior. En su lugar, use el Asistente para configuración híbrida de Microsoft 365. Para obtener más información, vea Asistente para configuración híbrida de Microsoft 365 para Exchange 2010.

Síntomas

Nota:

El siguiente escenario solo se aplica a los clientes de Microsoft 365 que tienen una implementación híbrida de Exchange Server y Exchange Online locales.

Cuando se usa la herramienta Analizador de conectividad remota de Microsoft para probar la característica Outlook Anywhere en un entorno de Microsoft 365, la herramienta muestra el siguiente mensaje de error:

No se pudo establecer la autenticación mutua.

Además, un usuario puede experimentar los siguientes síntomas:

  • Al usuario se le solicitan repetidamente credenciales y no se puede conectar a Exchange Online mediante Outlook En cualquier lugar.

  • El usuario recibe el siguiente mensaje de error al usar Outlook 2010 o Outlook 2007 para crear el perfil de Outlook automáticamente:

    No hay disponible una conexión cifrada con el servidor de correo. Haga clic en Siguiente para intentar usar una conexión sin cifrar.

Causa

Este problema se produce si se cumplen una o varias de las condiciones siguientes:

  • El nombre común no coincide con la cadena de autenticación mutua (msstd:) especificada en la herramienta Analizador de conectividad remota.
  • La cadena de autenticación mutua es válida. Sin embargo, el CertPrincipalName atributo del objeto EXPR OutlookProvider almacenado en Active Directory no es válido.

Nota:

La cadena de autenticación mutua equivale a conectarse solo a servidores proxy que tienen este nombre principal en su configuración de certificado en la configuración del proxy de Exchange en Outlook.

Solución

Para resolver este problema, siga estos pasos:

  1. Vea el certificado de servidor web instalado en el servidor híbrido y confirme el nombre común al que se emitió el certificado (por ejemplo, mail.contoso.com).

  2. Abra la configuración del proxy de Exchange en Outlook y compruebe que el nombre de dominio completo (FQDN) del campo Nombre de entidad de seguridad de autenticación mutua se escribe correctamente (por ejemplo, msstd: mail.contoso.com).

  3. Si es necesario, ejecute el siguiente cmdlet mediante el Shell de administración de Exchange para cambiar el CertPrincipalName atributo:

    Set-OutlookProvider EXPR -CertPrincipalName:"msstd:mail.contoso.com"
    

Más información

La herramienta Analizador de conectividad remota negocia una conexión de capa de sockets seguros (SSL) con el host remoto para recuperar varias propiedades en certificados X509. La herramienta evalúa el Subject atributo para identificar el FQDN o el nombre común asignado al certificado (por ejemplo, mail.contoso.com).

Para obtener más información sobre los nombres principales, vea Nombres principales.

Para obtener más información sobre los proveedores de Outlook, vea:

¿Aún necesita ayuda? Vaya a Microsoft Community o a los foros de Exchange TechNet.