Error al usar la herramienta analizador de conectividad remota para probar Outlook en cualquier lugar de un entorno de Office 365: "no se pudo establecer la autenticación mutua"

Nota: Ya no se admite el Asistente para la configuración híbrida que se incluye en la consola de administración de Exchange en Microsoft Exchange Server 2010. Por lo tanto, ya no debe usar el antiguo asistente para la configuración híbrida. En su lugar, use el Asistente para la configuración híbrida de Office 365 que está disponible en http://aka.ms/HybridWizard. Para obtener más información, consulte Asistente de configuración híbrida de Office 365 para Exchange 2010.

PROBLEMA

Nota El siguiente escenario solo se aplica a los clientes de Microsoft Office 365 que tienen una implementación híbrida de Exchange Server local y Exchange Online. Cuando se usa la herramienta analizador de conectividad remota de Microsoft para probar la característica Outlook en cualquier lugar en un entorno de Microsoft Office 365, la herramienta muestra el siguiente mensaje de error:

No se pudo establecer la autenticación mutua.

Además, un usuario puede experimentar los siguientes síntomas:

  • El usuario vuelve a solicitar las credenciales y no puede conectarse a Exchange online de forma repetida con Outlook en cualquier lugar.

  • El usuario recibe el siguiente mensaje de error cuando usa Microsoft Outlook 2010 o Microsoft Office Outlook 2007 para crear el perfil de Outlook automáticamente:

    Una conexión cifrada a su servidor de correo no está disponible. Haga clic en siguiente para intentar usar una conexión no cifrada.

CAUSA

Este problema se produce si se cumplen una o varias de las condiciones siguientes:

  • El nombre común no coincide con la autenticación mutua (msstd:) cadena que se escribe en la herramienta analizador de conectividad remota.

  • La cadena de autenticación mutua es válida. Sin embargo, el atributo CertPrincipalName para el objeto expr OutlookProvider almacenado en Active Directory no es válido.Nota La cadena de autenticación mutua corresponde a los servidores proxy que tienen este nombre principal en su configuración de certificado en la configuración de proxy de Exchange en Outlook.

SOLUCIÓN

Para resolver este problema, siga estos pasos:

  1. Vea el certificado del servidor Web que está instalado en el servidor híbrido y confirme el nombre común para el que se emitió el certificado (por ejemplo, mail.contoso.com).

  2. Abra la configuración de proxy de Exchange en Outlook y compruebe que el nombre de dominio completo (FQDN) en el campo nombre principal de autenticación mutua se haya introducido correctamente (por ejemplo, msstd: mail.contoso.com).

  3. Si es necesario, ejecute el siguiente cmdlet con el shell de administración de Exchange para cambiar el atributo CertPrincipalName :

    Set-OutlookProvider EXPR -CertPrincipalName:"msstd:mail.contoso.com" 

MÁS INFORMACIÓN

La herramienta analizador de conectividad remota negocia una conexión de capa de sockets seguros (SSL) con el host remoto para recuperar diversas propiedades de certificados X509. La herramienta evalúa el atributo de asunto para identificar el nombre completo (FQDN) o el nombre común que se asignó al certificado (por ejemplo, mail.contoso.com). Para obtener más información sobre los nombres principales, vaya al siguiente sitio web de Microsoft Developer Network (MSDN):

Nombres principalesPara obtener más información acerca de los proveedores de Outlook, vaya a los siguientes sitios web de Microsoft:

El servicio de detección automática y los proveedores de Outlook

Set-OutlookProvider

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