Error "Error del motor de impresión de cristal: error al abrir un conjunto de filas" al intentar imprimir un informe en Microsoft Dynamics SL

En este artículo se proporcionan soluciones a los errores que se producen al intentar imprimir un informe en Microsoft Dynamics SL.

Se aplica a: Microsoft Dynamics SL
Número de KB original: 905310

Síntomas

Al intentar imprimir un informe en Microsoft Dynamics SL o en Microsoft Business Solutions - Solomon, recibe un mensaje de error similar al siguiente ejemplo:

Aplicación auxiliar de informes de Cristal para Solomon IV

No se puede iniciar el trabajo de impresión.

Informe: Unidad :\Archivos de programa\Solomon\Module_Code\XXXXX. Error del motor de impresión de cristal RPT: 723 - Error en la unidad de archivo :\Archivos de programa\Solomon\Module_Code\XXXXX. RPT:

No se pudo abrir un conjunto de filas.

Nota:

En este mensaje de error, Unidad representa la unidad en la que instaló Microsoft Dynamics SL, Module_Code representa el código del módulo que corresponde al módulo de Microsoft Dynamics SL en el que se encuentra el informe y XXXXX representa el nombre de archivo del informe.

Causa

Este problema se produce por una o varias de las siguientes razones.

Causa 1

El informe contiene notas. Consulte resolución 1.

Causa 2

Tiene instalado Microsoft Solomon 6.0 y el informe que provoca el error es La distribución de la cuenta (01.ACC). DI) informe. Consulte resolución 2.

Causa 3

El informe es un informe personalizado que usa un preprocesamiento. Consulte resolución 3.

Causa 4

Los nombres de origen de datos (DSN) de Conectividad de Open DataBase (ODBC) faltan o están dañados. Consulte resolución 4.

Causa 5

No se selecciona la opción para usar identificadores entre comillas ANSI. Consulte resolución 5.

Causa 6

No hay suficiente espacio libre en disco en el equipo que ejecuta Microsoft SQL Server y hospeda las bases de datos de Microsoft Dynamics SL o las bases de datos Microsoft Business Solutions - Solomon. Consulte resolución 6.

Resolución

Para resolver este problema, use la resolución adecuada.

Solución 1

Si recibe el mensaje de error al intentar imprimir un informe que contiene notas, haga clic para desactivar la casilla Seleccionar registros distintos en el menú Base de datos de Crystal Reports for Solomon.

Solución 2

Si recibe el mensaje de error solo cuando intenta imprimir la distribución de la cuenta (01.ACC). INFORME DE) y haga que Microsoft Solomon 6.0 esté instalado, reemplace el archivo 01acctdi.rpt que se encuentra en la instalación mediante el archivo 01acctdi.rpt del CD de instalación de Microsoft Solomon 5.5.

Resolución 3

Si recibe el mensaje de error al intentar imprimir un informe personalizado que usa un preprocesamiento, use uno de los métodos siguientes.

Método 1

Agregue el informe personalizado como un elemento independiente en la estructura de menús de Microsoft Dynamics SL.

Método 2

Adjunte el informe personalizado como un nuevo formato de informe a un informe existente que no use un preprocesamiento. Para adjuntar el informe personalizado, siga estos pasos:

  1. Inicie Microsoft Dynamics SL.

  2. En el menú Utilidad , seleccione Mantenimiento del control de informes.

    Nota:

    Se abre el cuadro de diálogo Mantenimiento del control de informes (98.300.00 ).

  3. En el cuadro Número de informe, escriba el número del informe al que desea adjuntar el informe personalizado.

  4. Seleccione Opciones de control.

  5. Compruebe que el cuadro Preproceso esté en blanco. Si el cuadro Preproceso no está en blanco, vuelva al paso 3 y escriba un número de informe diferente.

  6. En la primera fila en blanco, escriba el nombre para mostrar del informe en el cuadro Nombre de formato de informe y, a continuación, escriba el nombre del archivo de informe en el cuadro Formato de informe.

    En este paso, "el informe" hace referencia al informe crystal reports en Microsoft Windows. Por ejemplo, escriba 01accdi en el cuadro Formato de informe si el nombre del archivo de informe es 01accdi.rpt.

  7. Seleccione Guardar. A continuación, seleccione Cerrar.

Resolución 4

Quite y vuelva a crear los DSN odbc de base de datos microsoft Dynamics SL o Microsoft Solomon. Para ello, siga estos pasos:

  1. Seleccione Inicio, seleccione Panel de control, Herramientas administrativas y, a continuación, Orígenes de datos (ODBC).
  2. En la pestaña DSN de usuario , seleccione una base de datos de Dynamics SL y, a continuación, seleccione Quitar. Repita el procedimiento para todas las bases de datos de Dynamics SL que aparecen en la lista.
  3. En la pestaña DSN del sistema , seleccione un origen de datos del sistema relacionado con una base de datos de Dynamics SL y, a continuación, seleccione Quitar.
  4. Seleccione Aceptar.
  5. Para volver a crear los DSN odbc, inicie Microsoft Dynamics SL y, a continuación, ejecute una vista previa de impresión de cualquier informe.

Resolución 5

Active los identificadores citados ansi (American National Standards Institute). Para ello, siga estos pasos:

  1. Seleccione Inicio, seleccione Panel de control, Herramientas administrativas y, a continuación, Orígenes de datos (ODBC).
  2. En la pestaña DSN de usuario , seleccione la base de datos adecuada y, a continuación, seleccione Configurar.
  3. Seleccione Siguiente.
  4. Especifique las credenciales adecuadas y, a continuación, seleccione Siguiente.
  5. Active la casilla Usar identificadores entre comillas ANSI .
  6. Seleccione Siguiente.
  7. Seleccione Finalizar.
  8. Haga clic en Aceptar dos veces.

Resolución 6

Libere espacio en disco en el equipo. Para ello, elimine datos innecesarios o aumente la capacidad del disco.