Se produce el error "No se admite la referencia cultural" al intentar configurar Microsoft Dynamics CRM para Microsoft Office Outlook

Este artículo le ayuda a corregir un problema en el que se obtiene el error "No se admite la referencia cultural" al intentar configurar Microsoft Dynamics CRM para Microsoft Office Outlook.

Se aplica a: Microsoft Dynamics CRM 2011, Microsoft Dynamics CRM 2013, Microsoft Dynamics CRM 2013 Service Pack 1, Microsoft Dynamics CRM 2015, Cliente Microsoft CRM para Microsoft Office Outlook
Número de KB original: 2668553

Síntomas

Al intentar conectarse Microsoft Dynamics CRM para Microsoft Office Outlook, aparece el siguiente mensaje de error:

Hay un problema al comunicarse con el servidor de Microsoft Dynamics CRM. Es posible que el servidor no esté disponible. Inténtelo de nuevo más tarde. Si el problema persiste, póngase en contacto con el administrador del sistema.

No se admite la referencia cultural.
Nombre del parámetro: referencia cultural
0 (0x0000) es un identificador de referencia cultural no válido.
at Microsoft.Crm.MapiStore.DataStore.WaitInitialized()
en Microsoft.Crm.Application.Outlook.Config. OutlookConfigurator.InitializeMapiStoreForFirstTime()
en Microsoft.Crm.Application.Outlook.Config. OutlookConfigurator.Configure(IProgressEventHandler progressEventHandler)
en Microsoft.Crm.Application.Outlook.Config. ConfigEngine.Configure(object stateInfo)

Causa

No se pudo establecer la configuración de idioma en el nivel de usuario en CRM debido a privilegios de usuario insuficientes. Es posible que al rol de seguridad del usuario le falte el privilegio De escritura para la entidad Configuración de usuario .

Resolución

  1. Inicie sesión en la aplicación web Microsoft Dynamics CRM como usuario con el rol Administrador del sistema.

  2. Vaya a Configuración>Roles de seguridad>.

    Nota:

    Si no usa Microsoft Dynamics CRM 2015 o posterior, los roles de seguridad se encuentran en Administración en lugar de Seguridad.

  3. Abra el rol asignado a este usuario.

  4. Haga clic en la pestaña Administración de negocios y conceda el privilegio "Escribir" para la entidad Configuración de usuario . El acceso a nivel de usuario es el requisito mínimo.

  5. Haga clic en Guardar.

  6. Intente conectar Microsoft Dynamics CRM para Microsoft Office Outlook de nuevo.

Si sigue teniendo problemas para conectar CRM para Outlook a su organización de CRM Online, hay disponible una herramienta de diagnóstico para ayudar a diagnosticar el problema:

Diagnóstico de configuración de CRM para Outlook

Más información

Si no está seguro de qué rol de seguridad se asigna al usuario, siga estos pasos:

  1. Vaya a Configuración>Usuarios de seguridad>.

    Nota:

    Si no usa Microsoft Dynamics CRM 2015 o posterior, Users se encuentra en Administración en lugar de Seguridad.

  2. Abra el registro de usuario que se enfrenta a este problema.

  3. En la barra de comandos del registro de usuario, haga clic en Administrar roles.

  4. Busque el rol de seguridad que tiene una marca de verificación junto a él. Siga los pasos proporcionados en la sección Resolución para conceder el privilegio De escritura para la entidad Configuración de usuario .